summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/entrypoints/entrypoints-0.3-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/entrypoints/entrypoints-0.3-r1.ebuild b/dev-python/entrypoints/entrypoints-0.3-r1.ebuild
index 0b64e872fe36..0eb427f32fa5 100644
--- a/dev-python/entrypoints/entrypoints-0.3-r1.ebuild
+++ b/dev-python/entrypoints/entrypoints-0.3-r1.ebuild
@@ -19,13 +19,15 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
- $(python_gen_cond_dep '>=dev-python/configparser-3.5.0[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep '>=dev-python/configparser-3.5.0[${PYTHON_USEDEP}]' -2)
"
BDEPEND="
test? (
${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
- virtual/python-pathlib[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pathlib[${PYTHON_USEDEP}]
+ ' -2)
)
"