summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/capnproto/Manifest1
-rw-r--r--dev-libs/capnproto/capnproto-0.6.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/capnproto/Manifest b/dev-libs/capnproto/Manifest
index b8aa91e93c91..a383d9334279 100644
--- a/dev-libs/capnproto/Manifest
+++ b/dev-libs/capnproto/Manifest
@@ -1 +1,2 @@
DIST capnproto-0.6.0.tar.gz 1199198 SHA256 3b73a3dc39592a30b1bb6d00dff930e5fb277c774a1d40bf6a1aa7758c5fec74 SHA512 4882b2e5d1544517348e436600705d18b41fc82e6fc141a934ad960556ed73781c974d4a45f8c949a297edd5c95fb156fd75f1d7179666dc7ab881f98ac9e69d WHIRLPOOL 466a664f90778c28114eed94bac488c7e104b17225c9b18bd2c1835d23f3bf8ac92f6cbc2d9c123b469c786341d45eb97d881607ba2ffb590ec2fc2776fe5a7b
+DIST capnproto-0.6.1.tar.gz 1720489 SHA256 85210424c09693d8fe158c1970a2bca37af3a0424f02b263f566a1b8a5451a2d SHA512 baea7f867bb789d3bf8cdc9c1a4a0d31cdce3beb7ae1fd9464690a006a86eca841aaac5d86599c2a84a39d62c4d01213b29789c2b7385ad6636fef95fc867dd6 WHIRLPOOL 5c66738f54c7beb68130debc4feaea844575f480b551ebc34b2220a73a2e98e4fd3b9d3c8ca5c146be37629e7b60ad45900d8830b46c9900e51927536f93a5b0
diff --git a/dev-libs/capnproto/capnproto-0.6.1.ebuild b/dev-libs/capnproto/capnproto-0.6.1.ebuild
new file mode 100644
index 000000000000..483f105f07e0
--- /dev/null
+++ b/dev-libs/capnproto/capnproto-0.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="RPC/Serialization system with capabilities support"
+HOMEPAGE="http://capnproto.org"
+SRC_URI="https://github.com/sandstorm-io/capnproto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/061"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="static-libs test"
+
+RDEPEND=""
+DEPEND="test? ( dev-cpp/gtest )"
+
+S=${WORKDIR}/${P}/c++
+
+src_prepare() {
+ sed -e 's/ldconfig/true/' -i Makefile.am || die
+ sed -e 's#gtest/lib/libgtest.la gtest/lib/libgtest_main.la#-lgtest -lgtest_main#' -i Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete
+}