summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/certbot-nginx/Manifest1
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-0.26.0.ebuild34
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-9999.ebuild4
3 files changed, 37 insertions, 2 deletions
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index 525cf0382fb1..f580cd62968f 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -2,3 +2,4 @@ DIST certbot-0.23.0.tar.gz 1144448 BLAKE2B 820c4e3a0245a4ccda90884e38093d4f95ebf
DIST certbot-0.24.0.tar.gz 1149694 BLAKE2B 7c57d59ced97de77e0f98eb11a2bba418ee81ba0eb4506ebc010cb0060c92820617ba2a3464dd398bfec6dc86f4c2dc8e22461d76ae51ccfbb97afab3bbb3681 SHA512 b067da7eea54deb72ff4b516382cbe480ffebcb378489a2b0c52955f7399401d936d8d6587d88473d6f4fa9e864de94514941bde9727a5babbf2d6211ea61b20
DIST certbot-0.25.0.tar.gz 1163858 BLAKE2B 9439b253a505f3cfb25f4ca33e6745b53ac51514dc34b31dd234c8db7dd07b9cb47b0a7edcc565dd7dee4678d0edd99590d2f235fedb77193e8ad1f0459c6b7a SHA512 af0f2498d79e9d54f0609b21b8ec40efe9fbcfa5162eb18bbb8b10cc230b31db6af81c4e85af243d92c527efc55634402b30960d014085f6e6af6e679ca75592
DIST certbot-0.25.1.tar.gz 1160526 BLAKE2B 2dd2196c5986d5f5fe59f711589b6c3393d9c4183febb7048eab0b85e033f81d5c7ff12d7fea3aa69585308f5a4984143e431047fee73b42b16bd49e1cd2d14f SHA512 6395baa33acb4cf9e953294ddb07694ffa1e76424e12114db8df0f64fb3f1872c3145b02d853c139183b2b708d40d236f91d356eb9ecca447f577bd725fee6e5
+DIST certbot-0.26.0.tar.gz 1236499 BLAKE2B ea276f8b0fd4c7c6ce59acdcd3829d45d06ee31ac317bd846083da8ab105ae9357eaafd81992e1493c4965a95a70ee71f2d41875ca7e8c0613cbe44eeb3dffa5 SHA512 19f689d5b8724c6e7aa1539808b1b60913ad0f4a9272ebf6f40115028cef3cb49d9416239e104f125ed549c15e2a032935d0d2da1866548d0a177ef70608dce1
diff --git a/app-crypt/certbot-nginx/certbot-nginx-0.26.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-0.26.0.ebuild
new file mode 100644
index 000000000000..bda8ab5ae6d7
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-0.26.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=app-crypt/certbot-0.22.0[${PYTHON_USEDEP}]
+ >=app-crypt/acme-0.25.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
diff --git a/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild b/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
index dd9e6e8b4372..bda8ab5ae6d7 100644
--- a/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
+++ b/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
@@ -25,8 +25,8 @@ IUSE=""
CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${CDEPEND}
- >=app-crypt/certbot-0.21.1[${PYTHON_USEDEP}]
- >=app-crypt/acme-0.21.1[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-0.22.0[${PYTHON_USEDEP}]
+ >=app-crypt/acme-0.25.0[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
>=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]