summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/bison/Manifest1
-rw-r--r--sys-devel/bison/bison-3.5.3.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/sys-devel/bison/Manifest b/sys-devel/bison/Manifest
index 6173caa6ce59..8fd1396d1839 100644
--- a/sys-devel/bison/Manifest
+++ b/sys-devel/bison/Manifest
@@ -7,3 +7,4 @@ DIST bison-3.4.2.tar.xz 2240532 BLAKE2B fb3d90dc3f21075069684e5d9f8d6982353d909b
DIST bison-3.5.1-patches-01.tar.xz 9388 BLAKE2B 656cdc4fef308df3bc97c8f452ae75440909ed7eae13a8bdfc6b3b380f9d392ac3c9d300cb1e7a6d5548271b6ac63f5dfef594cbf9ef5322f97024468ed8e757 SHA512 195725726575998ff3d274d723ce3f605f9e1478601904668f165c1d9f628ed94380dfa65e546f12e3fc80b41aae7899774208510f382864dffde8545710f211
DIST bison-3.5.1.tar.xz 2354592 BLAKE2B 29e85c8f38f122b90ca38d4def3c9305a562dc29755865fc091f809191c0af435fe8fb5b424da8b69f143f30d8b6439876f735bf45dd8cf9f45e291e93789078 SHA512 f5a075608c563652181e6804cdd280761a05b88f41f4b287d49bbe4c18b08724b057ff95c07dfa3fddb5c95de8b229db76821e9d197d4bec206102f62cb390d8
DIST bison-3.5.2.tar.xz 2362956 BLAKE2B f2c487cff816c010e82e95c23c26323eb4e11c7293a1358359564068b84438edded20586b4729e1432a7718f9ba6a9856298d66c17e45a10d28216272be6eea8 SHA512 f8d213fa58f04ce8e55437ecfa378869a85c07234223dc89dbe7533b7f663a105eddaebd0902fb46b258048400c09d4b8181f033932b74aa41bca13ea5c120aa
+DIST bison-3.5.3.tar.xz 2364904 BLAKE2B def6d9927746691ec06fa78637fe3bace015bd10e3d51389890489d864169f888aa7c7ea5400b8190766a0ab4b45f0edc1cb07dfd572b693e969e43a1b47d73e SHA512 888a1e8d4aeda3ff2d7d0a3a88b63bbfe89bdb718cc64d48c244e05fe6c6cd39526fd88143db379fef3071cf6c2dc2ab2fd69834c24acb23ed5f739584ff6308
diff --git a/sys-devel/bison/bison-3.5.3.ebuild b/sys-devel/bison/bison-3.5.3.ebuild
new file mode 100644
index 000000000000..6c9a25cfeca2
--- /dev/null
+++ b/sys-devel/bison/bison-3.5.3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+PATCHES="${PN}-3.5.1-patches-01.tar.xz"
+
+DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
+HOMEPAGE="https://www.gnu.org/software/bison/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ mirror://gentoo/${PATCHES}
+ https://dev.gentoo.org/~whissi/dist/bison/${PATCHES}
+ https://dev.gentoo.org/~polynomial-c/dist/bison/${PATCHES}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples nls static test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=sys-devel/m4-1.4.16"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/flex
+ examples? ( dev-lang/perl )
+ nls? ( sys-devel/gettext )
+ test? ( dev-lang/perl )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO ) # ChangeLog-2012 ChangeLog-1998 PACKAGING README-alpha README-release
+
+PATCHES=(
+ "${WORKDIR}"/patches/${PN}-3.5-optional-perl.patch #538300
+ "${WORKDIR}"/patches/${PN}-3.5.1-avoid_autoreconf.patch
+)
+
+src_prepare() {
+ # Record date to avoid 'config.status --recheck' & regen of 'tests/package.m4'
+ touch -r configure.ac old.configure.ac || die
+ touch -r configure old.configure || die
+
+ default
+
+ # Restore date after patching
+ touch -r old.configure.ac configure.ac || die
+ touch -r old.configure configure || die
+
+ # The makefiles make the man page depend on the configure script
+ # which we patched above. Touch it to prevent regeneration.
+ touch doc/bison.1 || die #548778 #538300#9
+
+ # Avoid regenerating the info page when the timezone is diff. #574492
+ sed -i '2iexport TZ=UTC' build-aux/mdate-sh || die
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ local myeconfargs=(
+ $(use_enable examples)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # This one is installed by dev-util/yacc
+ mv "${ED}"/usr/bin/yacc{,.bison} || die
+ mv "${ED}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need liby.a
+ rm -r "${ED}"/usr/lib* || die
+}
+
+pkg_postinst() {
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ ! -e ${f} ]] ; then
+ ln -s yacc.bison "${f}"
+ fi
+}
+
+pkg_postrm() {
+ # clean up the dead symlink when we get unmerged #377469
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ -L ${f} && ! -e ${f} ]] ; then
+ rm -f "${f}"
+ fi
+}