summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-irc/shadowircd/Manifest1
-rw-r--r--net-irc/shadowircd/files/format-security.patch384
-rw-r--r--net-irc/shadowircd/files/shadowircd.confd6
-rw-r--r--net-irc/shadowircd/files/shadowircd.initd-r126
-rw-r--r--net-irc/shadowircd/metadata.xml10
-rw-r--r--net-irc/shadowircd/shadowircd-6.3.3-r1.ebuild95
-rw-r--r--profiles/package.mask2
7 files changed, 0 insertions, 524 deletions
diff --git a/net-irc/shadowircd/Manifest b/net-irc/shadowircd/Manifest
deleted file mode 100644
index 62e6e18fb83e..000000000000
--- a/net-irc/shadowircd/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST shadowircd-6.3.3.tar.gz 1980432 BLAKE2B d9f443011668bf407624cb5da2a9f8396861e4c4c7e587bae35d7ac3bd9513a109865e56fd92efc1d022d773c10a36ba95cc2f1f763e06b74f46e300cb142b5a SHA512 f3638bee6d49c56738cf05dd7c67d93344ed5787eb8777589390dbc38a1481e9a28895bdd4534124dcc8dbe247f3e28e299fe0bc0bb89e4d974b4aff734701d4
diff --git a/net-irc/shadowircd/files/format-security.patch b/net-irc/shadowircd/files/format-security.patch
deleted file mode 100644
index bd6e26e28a59..000000000000
--- a/net-irc/shadowircd/files/format-security.patch
+++ /dev/null
@@ -1,384 +0,0 @@
-From 6055fe3ee3b7b932e2a21160251fff0f0c6bcc39 Mon Sep 17 00:00:00 2001
-From: Michael Orlitzky <michael@orlitzky.com>
-Date: Mon, 24 Jul 2017 10:39:43 -0400
-Subject: [PATCH 1/1] Supply trivial format strings to fix format-security
- warnings.
-
-This commit adds a trivial format string "%s" to a number of function
-calls that are otherwise missing them. This avoids GCC's
-format-security warnings, which cause compilation failures with
--Werror=format-security.
-
-Gentoo-Bug: 520620
----
- bandb/bandb.c | 2 +-
- modules/core/m_kill.c | 4 ++--
- modules/m_away.c | 4 ++--
- modules/m_challenge.c | 8 ++++----
- modules/m_info.c | 6 +++---
- modules/m_map.c | 4 ++--
- modules/m_oper.c | 6 +++---
- modules/m_stats.c | 22 +++++++++++-----------
- src/chmode.c | 4 ++--
- src/parse.c | 2 +-
- src/s_auth.c | 2 +-
- src/sslproc.c | 8 ++++----
- 12 files changed, 36 insertions(+), 36 deletions(-)
-
-diff --git a/bandb/bandb.c b/bandb/bandb.c
-index 33166b1..2d272a1 100644
---- a/bandb/bandb.c
-+++ b/bandb/bandb.c
-@@ -289,7 +289,7 @@ db_error_cb(const char *errstr)
- {
- char buf[256];
- rb_snprintf(buf, sizeof(buf), "! :%s", errstr);
-- rb_helper_write(bandb_helper, buf);
-+ rb_helper_write(bandb_helper, "%s", buf);
- rb_sleep(2 << 30, 0);
- exit(1);
- }
-diff --git a/modules/core/m_kill.c b/modules/core/m_kill.c
-index 80df7df..2fa91da 100644
---- a/modules/core/m_kill.c
-+++ b/modules/core/m_kill.c
-@@ -97,7 +97,7 @@ mo_kill(struct Client *client_p, struct Client *source_p, int parc, const char *
- if((target_p = get_history(user, (long) KILLCHASETIMELIMIT)) == NULL)
- {
- if (strchr(user, '.'))
-- sendto_one_numeric(source_p, ERR_CANTKILLSERVER, form_str(ERR_CANTKILLSERVER));
-+ sendto_one_numeric(source_p, ERR_CANTKILLSERVER, "%s", form_str(ERR_CANTKILLSERVER));
- else
- sendto_one_numeric(source_p, ERR_NOSUCHNICK,
- form_str(ERR_NOSUCHNICK), user);
-@@ -216,7 +216,7 @@ ms_kill(struct Client *client_p, struct Client *source_p, int parc, const char *
-
- if(IsServer(target_p) || IsMe(target_p))
- {
-- sendto_one_numeric(source_p, ERR_CANTKILLSERVER, form_str(ERR_CANTKILLSERVER));
-+ sendto_one_numeric(source_p, ERR_CANTKILLSERVER, "%s", form_str(ERR_CANTKILLSERVER));
- return 0;
- }
-
-diff --git a/modules/m_away.c b/modules/m_away.c
-index 557371e..13c4c39 100644
---- a/modules/m_away.c
-+++ b/modules/m_away.c
-@@ -85,7 +85,7 @@ m_away(struct Client *client_p, struct Client *source_p, int parc, const char *p
- free_away(source_p);
- }
- if(MyConnect(source_p))
-- sendto_one_numeric(source_p, RPL_UNAWAY, form_str(RPL_UNAWAY));
-+ sendto_one_numeric(source_p, RPL_UNAWAY, "%s", form_str(RPL_UNAWAY));
- return 0;
- }
-
-@@ -99,7 +99,7 @@ m_away(struct Client *client_p, struct Client *source_p, int parc, const char *p
- }
-
- if(MyConnect(source_p))
-- sendto_one_numeric(source_p, RPL_NOWAWAY, form_str(RPL_NOWAWAY));
-+ sendto_one_numeric(source_p, RPL_NOWAWAY, "%s", form_str(RPL_NOWAWAY));
-
- return 0;
- }
-diff --git a/modules/m_challenge.c b/modules/m_challenge.c
-index 2066095..b8514c4 100644
---- a/modules/m_challenge.c
-+++ b/modules/m_challenge.c
-@@ -172,7 +172,7 @@ m_challenge(struct Client *client_p, struct Client *source_p, int parc, const ch
-
- if(oper_p == NULL)
- {
-- sendto_one_numeric(source_p, ERR_NOOPERHOST, form_str(ERR_NOOPERHOST));
-+ sendto_one_numeric(source_p, ERR_NOOPERHOST, "%s", form_str(ERR_NOOPERHOST));
- ilog(L_FOPER, "FAILED OPER (%s) by (%s!%s@%s) (%s)",
- source_p->localClient->opername, source_p->name,
- source_p->username, source_p->host,
-@@ -203,7 +203,7 @@ m_challenge(struct Client *client_p, struct Client *source_p, int parc, const ch
-
- if(oper_p == NULL)
- {
-- sendto_one_numeric(source_p, ERR_NOOPERHOST, form_str(ERR_NOOPERHOST));
-+ sendto_one_numeric(source_p, ERR_NOOPERHOST, "%s", form_str(ERR_NOOPERHOST));
- ilog(L_FOPER, "FAILED OPER (%s) by (%s!%s@%s) (%s)",
- parv[1], source_p->name,
- source_p->username, source_p->host, source_p->sockhost);
-@@ -223,7 +223,7 @@ m_challenge(struct Client *client_p, struct Client *source_p, int parc, const ch
-
- if(IsOperConfNeedSSL(oper_p) && !IsSSLClient(source_p))
- {
-- sendto_one_numeric(source_p, ERR_NOOPERHOST, form_str(ERR_NOOPERHOST));
-+ sendto_one_numeric(source_p, ERR_NOOPERHOST, "%s", form_str(ERR_NOOPERHOST));
- ilog(L_FOPER, "FAILED CHALLENGE (%s) by (%s!%s@%s) (%s) -- requires SSL/TLS",
- parv[1], source_p->name, source_p->username, source_p->host,
- source_p->sockhost);
-@@ -241,7 +241,7 @@ m_challenge(struct Client *client_p, struct Client *source_p, int parc, const ch
- {
- if (source_p->certfp == NULL || strcasecmp(source_p->certfp, oper_p->certfp))
- {
-- sendto_one_numeric(source_p, ERR_NOOPERHOST, form_str(ERR_NOOPERHOST));
-+ sendto_one_numeric(source_p, ERR_NOOPERHOST, "%s", form_str(ERR_NOOPERHOST));
- ilog(L_FOPER, "FAILED OPER (%s) by (%s!%s@%s) (%s) -- client certificate fingerprint mismatch",
- parv[1], source_p->name,
- source_p->username, source_p->host, source_p->sockhost);
-diff --git a/modules/m_info.c b/modules/m_info.c
-index dd14294..bab156f 100644
---- a/modules/m_info.c
-+++ b/modules/m_info.c
-@@ -722,7 +722,7 @@ m_info(struct Client *client_p, struct Client *source_p, int parc, const char *p
- /* safe enough to give this on a local connect only */
- sendto_one(source_p, form_str(RPL_LOAD2HI),
- me.name, source_p->name, "INFO");
-- sendto_one_numeric(source_p, RPL_ENDOFINFO, form_str(RPL_ENDOFINFO));
-+ sendto_one_numeric(source_p, RPL_ENDOFINFO, "%s", form_str(RPL_ENDOFINFO));
- return 0;
- }
- else
-@@ -736,7 +736,7 @@ m_info(struct Client *client_p, struct Client *source_p, int parc, const char *p
- send_info_text(source_p);
- send_birthdate_online_time(source_p);
-
-- sendto_one_numeric(source_p, RPL_ENDOFINFO, form_str(RPL_ENDOFINFO));
-+ sendto_one_numeric(source_p, RPL_ENDOFINFO, "%s", form_str(RPL_ENDOFINFO));
- return 0;
- }
-
-@@ -761,7 +761,7 @@ mo_info(struct Client *client_p, struct Client *source_p, int parc, const char *
-
- send_birthdate_online_time(source_p);
-
-- sendto_one_numeric(source_p, RPL_ENDOFINFO, form_str(RPL_ENDOFINFO));
-+ sendto_one_numeric(source_p, RPL_ENDOFINFO, "%s", form_str(RPL_ENDOFINFO));
- }
-
- return 0;
-diff --git a/modules/m_map.c b/modules/m_map.c
-index 7a45140..baadc86 100644
---- a/modules/m_map.c
-+++ b/modules/m_map.c
-@@ -59,7 +59,7 @@ m_map(struct Client *client_p, struct Client *source_p, int parc, const char *pa
- }
-
- dump_map(client_p, &me, buf);
-- sendto_one_numeric(client_p, RPL_MAPEND, form_str(RPL_MAPEND));
-+ sendto_one_numeric(client_p, RPL_MAPEND, "%s", form_str(RPL_MAPEND));
- return 0;
- }
-
-@@ -71,7 +71,7 @@ mo_map(struct Client *client_p, struct Client *source_p, int parc, const char *p
- {
- dump_map(client_p, &me, buf);
- scache_send_missing(client_p);
-- sendto_one_numeric(client_p, RPL_MAPEND, form_str(RPL_MAPEND));
-+ sendto_one_numeric(client_p, RPL_MAPEND, "%s", form_str(RPL_MAPEND));
-
- return 0;
- }
-diff --git a/modules/m_oper.c b/modules/m_oper.c
-index b403b28..af1e008 100644
---- a/modules/m_oper.c
-+++ b/modules/m_oper.c
-@@ -83,7 +83,7 @@ m_oper(struct Client *client_p, struct Client *source_p, int parc, const char *p
-
- if(oper_p == NULL)
- {
-- sendto_one_numeric(source_p, ERR_NOOPERHOST, form_str(ERR_NOOPERHOST));
-+ sendto_one_numeric(source_p, ERR_NOOPERHOST, "%s", form_str(ERR_NOOPERHOST));
- ilog(L_FOPER, "FAILED OPER (%s) by (%s!%s@%s) (%s)",
- name, source_p->name,
- source_p->username, source_p->host, source_p->sockhost);
-@@ -100,7 +100,7 @@ m_oper(struct Client *client_p, struct Client *source_p, int parc, const char *p
-
- if(IsOperConfNeedSSL(oper_p) && !IsSSLClient(source_p))
- {
-- sendto_one_numeric(source_p, ERR_NOOPERHOST, form_str(ERR_NOOPERHOST));
-+ sendto_one_numeric(source_p, ERR_NOOPERHOST, "%s", form_str(ERR_NOOPERHOST));
- ilog(L_FOPER, "FAILED OPER (%s) by (%s!%s@%s) (%s) -- requires SSL/TLS",
- name, source_p->name,
- source_p->username, source_p->host, source_p->sockhost);
-@@ -118,7 +118,7 @@ m_oper(struct Client *client_p, struct Client *source_p, int parc, const char *p
- {
- if (source_p->certfp == NULL || strcasecmp(source_p->certfp, oper_p->certfp))
- {
-- sendto_one_numeric(source_p, ERR_NOOPERHOST, form_str(ERR_NOOPERHOST));
-+ sendto_one_numeric(source_p, ERR_NOOPERHOST, "%s", form_str(ERR_NOOPERHOST));
- ilog(L_FOPER, "FAILED OPER (%s) by (%s!%s@%s) (%s) -- client certificate fingerprint mismatch",
- name, source_p->name,
- source_p->username, source_p->host, source_p->sockhost);
-diff --git a/modules/m_stats.c b/modules/m_stats.c
-index dc826bc..51555b4 100644
---- a/modules/m_stats.c
-+++ b/modules/m_stats.c
-@@ -223,7 +223,7 @@ m_stats(struct Client *client_p, struct Client *source_p, int parc, const char *
- if(stats_cmd_table[i].need_oper && !IsOper(source_p))
- {
- sendto_one_numeric(source_p, ERR_NOPRIVILEGES,
-- form_str (ERR_NOPRIVILEGES));
-+ "%s", form_str (ERR_NOPRIVILEGES));
- break;
- }
- if(stats_cmd_table[i].need_admin && !IsOperAdmin(source_p))
-@@ -285,7 +285,7 @@ stats_connect(struct Client *source_p)
- (ConfigServerHide.flatten_links && !IsExemptShide(source_p))) &&
- !IsOper(source_p))
- {
-- sendto_one_numeric(source_p, ERR_NOPRIVILEGES,
-+ sendto_one_numeric(source_p, ERR_NOPRIVILEGES, "%s",
- form_str(ERR_NOPRIVILEGES));
- return;
- }
-@@ -487,7 +487,7 @@ stats_hubleaf(struct Client *source_p)
- (ConfigServerHide.flatten_links && !IsExemptShide(source_p))) &&
- !IsOper(source_p))
- {
-- sendto_one_numeric(source_p, ERR_NOPRIVILEGES,
-+ sendto_one_numeric(source_p, ERR_NOPRIVILEGES, "%s",
- form_str (ERR_NOPRIVILEGES));
- return;
- }
-@@ -513,7 +513,7 @@ stats_auth (struct Client *source_p)
- {
- /* Oper only, if unopered, return ERR_NOPRIVS */
- if((ConfigFileEntry.stats_i_oper_only == 2) && !IsOper (source_p))
-- sendto_one_numeric(source_p, ERR_NOPRIVILEGES,
-+ sendto_one_numeric(source_p, ERR_NOPRIVILEGES, "%s",
- form_str (ERR_NOPRIVILEGES));
-
- /* If unopered, Only return matching auth blocks */
-@@ -556,7 +556,7 @@ stats_tklines(struct Client *source_p)
- {
- /* Oper only, if unopered, return ERR_NOPRIVS */
- if((ConfigFileEntry.stats_k_oper_only == 2) && !IsOper (source_p))
-- sendto_one_numeric(source_p, ERR_NOPRIVILEGES,
-+ sendto_one_numeric(source_p, ERR_NOPRIVILEGES, "%s",
- form_str (ERR_NOPRIVILEGES));
-
- /* If unopered, Only return matching klines */
-@@ -621,7 +621,7 @@ stats_klines(struct Client *source_p)
- {
- /* Oper only, if unopered, return ERR_NOPRIVS */
- if((ConfigFileEntry.stats_k_oper_only == 2) && !IsOper (source_p))
-- sendto_one_numeric(source_p, ERR_NOPRIVILEGES,
-+ sendto_one_numeric(source_p, ERR_NOPRIVILEGES, "%s",
- form_str (ERR_NOPRIVILEGES));
-
- /* If unopered, Only return matching klines */
-@@ -689,7 +689,7 @@ stats_oper(struct Client *source_p)
-
- if(!IsOper(source_p) && ConfigFileEntry.stats_o_oper_only)
- {
-- sendto_one_numeric(source_p, ERR_NOPRIVILEGES,
-+ sendto_one_numeric(source_p, ERR_NOPRIVILEGES, "%s",
- form_str (ERR_NOPRIVILEGES));
- return;
- }
-@@ -752,7 +752,7 @@ static void
- stats_ports (struct Client *source_p)
- {
- if(!IsOper (source_p) && ConfigFileEntry.stats_P_oper_only)
-- sendto_one_numeric(source_p, ERR_NOPRIVILEGES,
-+ sendto_one_numeric(source_p, ERR_NOPRIVILEGES, "%s",
- form_str (ERR_NOPRIVILEGES));
- else
- show_ports (source_p);
-@@ -1063,7 +1063,7 @@ stats_servers (struct Client *source_p)
- if(ConfigServerHide.flatten_links && !IsOper(source_p) &&
- !IsExemptShide(source_p))
- {
-- sendto_one_numeric(source_p, ERR_NOPRIVILEGES,
-+ sendto_one_numeric(source_p, ERR_NOPRIVILEGES, "%s",
- form_str (ERR_NOPRIVILEGES));
- return;
- }
-@@ -1137,7 +1137,7 @@ static void
- stats_class(struct Client *source_p)
- {
- if(ConfigFileEntry.stats_y_oper_only && !IsOper(source_p))
-- sendto_one_numeric(source_p, ERR_NOPRIVILEGES,
-+ sendto_one_numeric(source_p, ERR_NOPRIVILEGES, "%s",
- form_str (ERR_NOPRIVILEGES));
- else
- report_classes(source_p);
-@@ -1411,7 +1411,7 @@ stats_servlinks (struct Client *source_p)
- if(ConfigServerHide.flatten_links && !IsOper (source_p) &&
- !IsExemptShide(source_p))
- {
-- sendto_one_numeric(source_p, ERR_NOPRIVILEGES,
-+ sendto_one_numeric(source_p, ERR_NOPRIVILEGES, "%s",
- form_str (ERR_NOPRIVILEGES));
- return;
- }
-diff --git a/src/chmode.c b/src/chmode.c
-index 0a43199..cd649d3 100644
---- a/src/chmode.c
-+++ b/src/chmode.c
-@@ -644,7 +644,7 @@ chm_hidden(struct Client *source_p, struct Channel *chptr,
- if(!IsOper(source_p) && !IsServer(source_p))
- {
- if(!(*errors & SM_ERR_NOPRIVS))
-- sendto_one_numeric(source_p, ERR_NOPRIVILEGES, form_str(ERR_NOPRIVILEGES));
-+ sendto_one_numeric(source_p, ERR_NOPRIVILEGES, "%s", form_str(ERR_NOPRIVILEGES));
- *errors |= SM_ERR_NOPRIVS;
- return;
- }
-@@ -734,7 +734,7 @@ chm_staff(struct Client *source_p, struct Channel *chptr,
- if(!IsOper(source_p) && !IsServer(source_p))
- {
- if(!(*errors & SM_ERR_NOPRIVS))
-- sendto_one_numeric(source_p, ERR_NOPRIVILEGES, form_str(ERR_NOPRIVILEGES));
-+ sendto_one_numeric(source_p, ERR_NOPRIVILEGES, "%s", form_str(ERR_NOPRIVILEGES));
- *errors |= SM_ERR_NOPRIVS;
- return;
- }
-diff --git a/src/parse.c b/src/parse.c
-index a8ce091..9e17de4 100644
---- a/src/parse.c
-+++ b/src/parse.c
-@@ -719,7 +719,7 @@ static void do_alias(struct alias_entry *aptr, struct Client *source_p, char *te
- int
- m_not_oper(struct Client *client_p, struct Client *source_p, int parc, const char *parv[])
- {
-- sendto_one_numeric(source_p, ERR_NOPRIVILEGES, form_str(ERR_NOPRIVILEGES));
-+ sendto_one_numeric(source_p, ERR_NOPRIVILEGES, "%s", form_str(ERR_NOPRIVILEGES));
- return 0;
- }
-
-diff --git a/src/s_auth.c b/src/s_auth.c
-index 2644ff1..52e4633 100644
---- a/src/s_auth.c
-+++ b/src/s_auth.c
-@@ -116,7 +116,7 @@ typedef enum
- }
- ReportType;
-
--#define sendheader(c, r) sendto_one_notice(c, HeaderMessages[(r)])
-+#define sendheader(c, r) sendto_one_notice(c, "%s", HeaderMessages[(r)])
-
- static rb_dlink_list auth_poll_list;
- static rb_bh *auth_heap;
-diff --git a/src/sslproc.c b/src/sslproc.c
-index 11fadbb..51078fb 100644
---- a/src/sslproc.c
-+++ b/src/sslproc.c
-@@ -455,13 +455,13 @@ ssl_process_cmd_recv(ssl_ctl_t * ctl)
- break;
- case 'I':
- ssl_ok = 0;
-- ilog(L_MAIN, cannot_setup_ssl);
-- sendto_realops_snomask(SNO_GENERAL, L_ALL, cannot_setup_ssl);
-+ ilog(L_MAIN, "%s", cannot_setup_ssl);
-+ sendto_realops_snomask(SNO_GENERAL, L_ALL, "%s", cannot_setup_ssl);
- case 'U':
- zlib_ok = 0;
- ssl_ok = 0;
-- ilog(L_MAIN, no_ssl_or_zlib);
-- sendto_realops_snomask(SNO_GENERAL, L_ALL, no_ssl_or_zlib);
-+ ilog(L_MAIN, "%s", no_ssl_or_zlib);
-+ sendto_realops_snomask(SNO_GENERAL, L_ALL, "%s", no_ssl_or_zlib);
- ssl_killall();
- break;
- case 'z':
---
-2.13.0
-
diff --git a/net-irc/shadowircd/files/shadowircd.confd b/net-irc/shadowircd/files/shadowircd.confd
deleted file mode 100644
index 4712b525985d..000000000000
--- a/net-irc/shadowircd/files/shadowircd.confd
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# Specify any extra options to pass to shadowircd
-SHADOWIRCD_OPTS=""
diff --git a/net-irc/shadowircd/files/shadowircd.initd-r1 b/net-irc/shadowircd/files/shadowircd.initd-r1
deleted file mode 100644
index 38ccab8b3f3f..000000000000
--- a/net-irc/shadowircd/files/shadowircd.initd-r1
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-command="/usr/bin/shadowircd-ircd"
-command_args="${SHADOWIRCD_OPTS}"
-command_user="shadowircd"
-extra_started_commands="reload"
-pidfile="/run/shadowircd/ircd.pid"
-
-depend() {
- use dns net
- provide ircd
-}
-
-start_pre() {
- ebegin "Creating /run/shadowircd for ${SVCNAME}"
- checkpath --directory --owner :shadowircd --mode 0770 /run/shadowircd
- eend $?
-}
-
-reload() {
- ebegin "Reloading ${SVCNAME}"
- start-stop-daemon --signal HUP --pidfile "${pidfile}"
- eend $?
-}
diff --git a/net-irc/shadowircd/metadata.xml b/net-irc/shadowircd/metadata.xml
deleted file mode 100644
index d90bc3272748..000000000000
--- a/net-irc/shadowircd/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <use>
- <flag name="largenet">Enable support/tweaks for large networks</flag>
- </use>
- <upstream>
- <remote-id type="github">shadowircd/shadowircd</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/net-irc/shadowircd/shadowircd-6.3.3-r1.ebuild b/net-irc/shadowircd/shadowircd-6.3.3-r1.ebuild
deleted file mode 100644
index 56dcbf33ad86..000000000000
--- a/net-irc/shadowircd/shadowircd-6.3.3-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit user
-
-DESCRIPTION="An IRCd based on charybdis that adds several useful features"
-HOMEPAGE="http://shadowircd.net"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug +ipv6 largenet ssl zlib"
-
-RDEPEND="ssl? ( dev-libs/openssl:0 )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- virtual/yacc
- sys-devel/flex"
-
-S="${WORKDIR}/${PN}-${P}"
-
-PATCHES=( "${FILESDIR}/format-security.patch" )
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 "${EPREFIX}"/usr ${PN}
-}
-
-src_prepare() {
- default
-
- # Fill the example configuration file with proper paths.
- sed -i \
- -e "s:path =.*modules:path = \"$(get_libdir)/${PN}/modules:g" \
- -e "s:etc/:../etc/${PN}/:g" \
- -e "s:logs/:../var/log/shadowircd/:g" \
- -e "s:test\.\(cert\|key\):ssl.\1:g" \
- doc/example.conf \
- doc/reference.conf \
- || die
-}
-
-src_configure() {
- econf \
- ac_cv_prog_cc_g=no \
- --disable-gnutls \
- $(use_enable debug assert soft) \
- $(use_enable debug iodebug) \
- $(use_enable ipv6) \
- $(use_enable !largenet small-net) \
- $(use_enable ssl openssl) \
- $(use_enable zlib) \
- --with-program-prefix=shadowircd- \
- \
- --enable-fhs-paths \
- --sysconfdir="${EPREFIX}"/etc/${PN} \
- --libdir="${EPREFIX}"/usr/"$(get_libdir)"/${PN} \
- --with-logdir="${EPREFIX}"/var/log/${PN} \
- --with-moduledir="${EPREFIX}"/usr/"$(get_libdir)"/${PN}/modules \
- --with-rundir="${EPREFIX}"/run
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
-
- insinto etc/${PN}
- newins doc/reference.conf ircd.conf
-
- keepdir var/{lib,log}/${PN}
-
- # The runtime directory will be created by the init script, so we
- # kill this here to avoid a QA warning about it.
- rm -rf "${D}"/run || die
-
- # shadowircd needs writing to its state (bandb) and log directories
- fowners :shadowircd /var/{lib,log}/${PN}
- fperms 770 /var/{lib,log}/${PN}
-
- # ensure that shadowircd can access but not modify its configuration
- # while protecting it from others
- fowners :shadowircd /etc/${PN}{,/ircd.conf}
- fperms 750 /etc/${PN}
- fperms 640 /etc/${PN}/ircd.conf
-}
-
-pkg_postinst() {
- elog "All of the shadowircd binaries in PATH have been prefixed with"
- elog "'shadowircd-' to prevent file collisions."
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index c8f73cc71222..835b27bb9353 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -621,7 +621,6 @@ x11-libs/hippo-canvas
# net-im/climm: #674160, dead homepage, last commits in 2010
# net-irc/bip: #674240, may need new snapshot, current ver is from 2013
# net-irc/epic4: #677734, needs bump, current is from 2009, also #613120
-# net-irc/shadowircd: #674528, dead homepage, last commits in 2012
#
# Removal in 30 days.
app-crypt/keynote
@@ -640,7 +639,6 @@ net-im/ayttm
net-im/climm
net-irc/bip
net-irc/epic4
-net-irc/shadowircd
# Miroslav Ć ulc <fordfrog@gentoo.org> (19 Mar 2019)
# Depends on >=virtual/{jdk,jre}-11 which is masked