summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/htpdate/Manifest1
-rw-r--r--net-misc/htpdate/htpdate-1.3.3.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/htpdate/Manifest b/net-misc/htpdate/Manifest
index 50340252857a..42c9d8616177 100644
--- a/net-misc/htpdate/Manifest
+++ b/net-misc/htpdate/Manifest
@@ -1,2 +1,3 @@
DIST htpdate-1.2.2.tar.gz 13625 BLAKE2B 11813def81e3cce1194120a21cf99e8ad288b0f604aab201850f03b6ca786d19792b9586c9d805aa1945bbc651e6afc5099b5c7cb6ea354473a4b3bab01397e3 SHA512 00d52b291004ddb3d0282aef78c5fbe5d9397dbf171a6646803ee7ba4bd0514af6089f7e48a92397dd1b0fbae5ba314f5165c9902028438e16d3516b65724de0
DIST htpdate-1.2.6.tar.gz 15083 BLAKE2B 913337f51fd26e811e33f195e463adc57e2512ba502f668f2429676d962623ea943bdb1d42ceddf6d35e7e8ba727b3f1300b34a8370ed661b3fa5b4b53ef1af7 SHA512 fe7442be5581eea0579060c02fb4ffe52151c6408d1b47afc9be049d2a8b1c8d0acd3b3481680a4b6a50f52622d47266afc0fe8dc67c5bb2a3aca2422e34f23f
+DIST htpdate-1.3.3.tar.gz 16302 BLAKE2B eb19462e1e5d02fe3cda7f4d2c954e2fe4b8dfcc299dc9094466a8652250ce27d37b2cf85716435639580e48295a92ad65521e0420cecac875c9b6e8074d425a SHA512 5d4892ea3626b80e5d529de873f675616dfef156e91d1e574225f91f9496503f55da43aa4f3522cb2b55da7c41dba7d97b3cc557a2704945577ec0243d8bd7f8
diff --git a/net-misc/htpdate/htpdate-1.3.3.ebuild b/net-misc/htpdate/htpdate-1.3.3.ebuild
new file mode 100644
index 000000000000..eedff8c28a70
--- /dev/null
+++ b/net-misc/htpdate/htpdate-1.3.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1 toolchain-funcs
+
+DESCRIPTION="Synchronize local workstation with time offered by remote webservers"
+HOMEPAGE="https://www.vervest.org/htp/"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/twekkel/htpdate"
+else
+ SRC_URI="https://github.com/twekkel/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux"
+fi
+IUSE="+ssl"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="ssl? ( dev-libs/openssl:0= )"
+RDEPEND="${DEPEND}"
+
+# Test suite tries to connect to the Internet
+RESTRICT="test"
+
+DOC_CONTENTS="If you would like to run htpdate as a daemon, set
+appropriate http servers in /etc/conf.d/htpdate!"
+
+PATCHES=( )
+
+src_prepare() {
+ default
+
+ # Use more standard adjtimex() to fix uClibc builds.
+ sed -i 's:ntp_adjtime:adjtimex:g' htpdate.[8c] || die
+ # Don't compress man pages by default
+ sed '/gzip/d' -i Makefile || die
+}
+
+src_compile() {
+ emake CFLAGS="-Wall ${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)" \
+ $(usex ssl "https" '')
+}
+
+src_install() {
+ emake DESTDIR="${D}" STRIP="/bin/true" bindir='$(prefix)/sbin' install
+ dodoc README.md Changelog
+
+ newconfd "${FILESDIR}"/htpdate.conf htpdate
+ newinitd "${FILESDIR}"/htpdate.init-r1 htpdate
+
+ readme.gentoo_create_doc
+}