summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-1.22.7.ebuild48
-rw-r--r--sys-auth/AusweisApp2/Manifest1
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.22.7.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.22.7.ebuild
new file mode 100644
index 000000000000..fd2f4d5730d0
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-1.22.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtwidgets:5
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp2/Manifest b/sys-auth/AusweisApp2/Manifest
index d6abf04ec673..18a60b7efee0 100644
--- a/sys-auth/AusweisApp2/Manifest
+++ b/sys-auth/AusweisApp2/Manifest
@@ -1,2 +1,3 @@
DIST AusweisApp2-1.22.5.tar.gz 11251263 BLAKE2B 8f62864d4e4139b06715765666fb7cc040d7cfc0c3cfb8082399ca24b2edbca754f511a4e7ab1eee6dd4fa3e8ea6cd38d048446877a6cff6ce37d7bddc56e01a SHA512 79cdd749d656aa9b082a80b9db9863bc11f4c5b8e06efefa2eb215724a45894137c5b6b8884d622e4a8203346e1b4d91b292013395a978e06a0201e40693a17d
DIST AusweisApp2-1.22.6.tar.gz 11405656 BLAKE2B 27b9bcee74b134ec899543bfca46269a5dde66b1cafefa3bca58aac5182d6f8864d80a3f61202c5e9690914f28c2d80ee2091055afeb89e6c473662c8b7c4d06 SHA512 747ebdea12a26efd6d50413d6722c770301966e20a866a9fd189a4dacaa15ef03a3e4ca34ce84df3b775c10b8c8406e3786bdb4ffaffd13b35cf35f43c773d47
+DIST AusweisApp2-1.22.7.tar.gz 11406133 BLAKE2B 17bc9824035007bf62037562ebd38c2b3558660060c0eba302ac04e8e9d0eabc7c8cb69d064a1a02be213f91f823030e5afdab74d5614db2c1bc8318ca1f9f22 SHA512 4ea1d2c02e076121b340da6d16973de6dafe513d2e9c96b535063466c06137d8e2a325661478d0cfbd96f506a875dca8d4df6a53af657a8d2eb59e7ad7d1a472