summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-physics/espresso++/Manifest1
-rw-r--r--sci-physics/espresso++/espresso++-1.9.4.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sci-physics/espresso++/Manifest b/sci-physics/espresso++/Manifest
index 7f1b5b27ead8..4d5123326ac5 100644
--- a/sci-physics/espresso++/Manifest
+++ b/sci-physics/espresso++/Manifest
@@ -1 +1,2 @@
DIST espresso++-1.9.3.tar.bz2 14714575 SHA256 602541c9e5889aeff30462f252fa5f2af7d818808ce946d11ee33500f4f2c959 SHA512 0ac90c6b09da0e7503e83cff8180373249760206fc0035b72868376abbd4a0d9121e7c92ae286493230af2080221464fc0f9428ed78101bde32eb926f07bb010 WHIRLPOOL f9fb22f4d113a47eee1d9203d4dabf5f5cef3347d7c17583459a69a6bee7392675a0f5ebab09315c4a740dba2fb412c13f3cb74ba3e8d0c99f51f62452af28e8
+DIST espresso++-1.9.4.tar.gz 23954404 SHA256 dc08381259394a4bd076bfe9b4bd53d687911025258e3a17a473ada12e2e5e68 SHA512 0b5c8ad81c1d6b742909533c58cd791f1702270778f6f140e84108f0da8313418f7fa39d83de2e24f8308e887a1c41d2fcdd0a33ef505d08244a235f95fe611d WHIRLPOOL c56e1055f8edc46b3c80f1d511dc925e9821376033330998fa6ecc0bb8aedf90cd701241f12ab3420afa2198b5b6584458b829dc01fd3c68a5223faeb07e833d
diff --git a/sci-physics/espresso++/espresso++-1.9.4.ebuild b/sci-physics/espresso++/espresso++-1.9.4.ebuild
new file mode 100644
index 000000000000..d011256b2fe7
--- /dev/null
+++ b/sci-physics/espresso++/espresso++-1.9.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils python-r1
+
+DESCRIPTION="A Modern Multiscale Simulation Package for Soft Matter Systems"
+HOMEPAGE="https://www.espresso-pp.de"
+
+MY_PN="${PN//+/p}"
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="git://github.com/${MY_PN}/${MY_PN}.git http://github.com/${MY_PN}/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ virtual/mpi
+ dev-libs/boost:=[python,mpi,${PYTHON_USEDEP}]
+ sci-libs/fftw:3.0
+ >=dev-python/mpi4py-2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ src_configure_internal() {
+ local mycmakeargs=(
+ -DEXTERNAL_BOOST=ON
+ -DEXTERNAL_MPI4PY=ON
+ -DWITH_RC_FILES=OFF
+ )
+ cmake-utils_src_configure
+ }
+ python_foreach_impl src_configure_internal
+}
+
+src_compile() {
+ python_foreach_impl cmake-utils_src_make
+}
+
+src_test() {
+ python_foreach_impl cmake-utils_src_test
+}
+
+src_install() {
+ python_foreach_impl cmake-utils_src_install
+}