summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/qtox/qtox-1.11.0.ebuild12
-rw-r--r--net-im/qtox/qtox-9999.ebuild12
2 files changed, 22 insertions, 2 deletions
diff --git a/net-im/qtox/qtox-1.11.0.ebuild b/net-im/qtox/qtox-1.11.0.ebuild
index d7cf4a9df23f..2e8bb695264d 100644
--- a/net-im/qtox/qtox-1.11.0.ebuild
+++ b/net-im/qtox/qtox-1.11.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit cmake-utils toolchain-funcs unpacker
+inherit cmake-utils gnome2-utils unpacker xdg-utils
DESCRIPTION="Most feature-rich GUI for net-libs/tox using Qt5"
HOMEPAGE="https://github.com/qTox/qTox"
@@ -56,3 +56,13 @@ src_configure() {
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/net-im/qtox/qtox-9999.ebuild b/net-im/qtox/qtox-9999.ebuild
index cd4bd86f7e95..dd9f1a5c5026 100644
--- a/net-im/qtox/qtox-9999.ebuild
+++ b/net-im/qtox/qtox-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit cmake-utils eutils git-r3
+inherit cmake-utils eutils git-r3 gnome2-utils xdg-utils
DESCRIPTION="Most feature-rich GUI for net-libs/tox using Qt5"
HOMEPAGE="https://github.com/qTox/qTox"
@@ -53,3 +53,13 @@ src_configure() {
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}