summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/dnsruby/Manifest1
-rw-r--r--dev-ruby/dnsruby/dnsruby-1.61.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/dnsruby/Manifest b/dev-ruby/dnsruby/Manifest
index c3bb635b7a20..32054a65a2c1 100644
--- a/dev-ruby/dnsruby/Manifest
+++ b/dev-ruby/dnsruby/Manifest
@@ -1 +1,2 @@
DIST dnsruby-1.61.2.gem 257024 BLAKE2B 9b87f0f7e1d3062d30128b131e0ba5fdf7dee8114e0e86f6d63ca79e15db686b412906b685a7db0571fb5678de5148cdb59c0e67c6402c193e13772645be31ba SHA512 39ba76a0ca5073b5d03172754f99fad31c3a9af9e2856b930364eb2a5859619b56a1adbf5c84ccae085afcfdc2e32ffd67cf2a92a4e6150b3a113a03e5c7503d
+DIST dnsruby-1.61.3.gem 259584 BLAKE2B 578d6f2b693de5007d4d15350a4fc6cb948f9e16ee9b0bb511e6b6dc92cf828d30e645522b834a6d42af5dd94b85f0675332b2363e0c2ba3b97c9b35b73bd82f SHA512 4cdf6d83c39c3209873e9bbd15ba33f851f3fb878cf746de98cf615b0f547dfc5af8b4be7d505f87f581755ff73de079b6ea3f6f8c5a11074c1c46d5bc9e8c07
diff --git a/dev-ruby/dnsruby/dnsruby-1.61.3.ebuild b/dev-ruby/dnsruby/dnsruby-1.61.3.ebuild
new file mode 100644
index 000000000000..09e3dc0ebb01
--- /dev/null
+++ b/dev-ruby/dnsruby/dnsruby-1.61.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR="html"
+RUBY_FAKEGEM_EXTRADOC="DNSSEC EXAMPLES README.md"
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby DNS client library"
+HOMEPAGE="https://github.com/alexdalitz/dnsruby"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/addressable-2.5:0"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.4:5 )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Cc]overall/d" Rakefile || die
+ sed -i -e '/display/d' \
+ -e '/Display/,/^}/d' test/spec_helper.rb || die
+}
+
+each_ruby_test() {
+ # only run offline tests
+ #${RUBY} -I .:lib test/ts_dnsruby.rb || die "test failed"
+ ${RUBY} -I .:lib test/ts_offline.rb || die "test failed"
+}