summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/ntpsec/ntpsec-1.2.0-r1.ebuild (renamed from net-misc/ntpsec/ntpsec-1.2.0.ebuild)7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-misc/ntpsec/ntpsec-1.2.0.ebuild b/net-misc/ntpsec/ntpsec-1.2.0-r1.ebuild
index a5193f995902..640727916e0f 100644
--- a/net-misc/ntpsec/ntpsec-1.2.0.ebuild
+++ b/net-misc/ntpsec/ntpsec-1.2.0-r1.ebuild
@@ -3,10 +3,11 @@
EAPI=6
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{6..9} )
PYTHON_REQ_USE='threads(+)'
+DISTUTILS_USE_SETUPTOOLS=no
-inherit flag-o-matic python-r1 waf-utils systemd
+inherit distutils-r1 flag-o-matic waf-utils systemd
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -72,6 +73,7 @@ src_prepare() {
fi
# remove extra default pool servers
sed -i '/use-pool/s/^/#/' "${S}"/etc/ntp.d/default.conf
+
python_copy_sources
}
@@ -122,6 +124,7 @@ src_compile() {
src_install() {
python_install() {
waf-utils_src_install
+ python_fix_shebang "${ED}"
}
python_foreach_impl run_in_build_dir python_install
python_foreach_impl python_optimize