summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-metrics/prometheus/Manifest1
-rw-r--r--app-metrics/prometheus/prometheus-2.7.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-metrics/prometheus/Manifest b/app-metrics/prometheus/Manifest
index adf5fdb5e10a..bbfa60cd2158 100644
--- a/app-metrics/prometheus/Manifest
+++ b/app-metrics/prometheus/Manifest
@@ -3,3 +3,4 @@ DIST prometheus-2.5.0.tar.gz 6123272 BLAKE2B a84b31e24f4448330af63b64ed56b8c535e
DIST prometheus-2.6.0.tar.gz 6607363 BLAKE2B b9449403c840367b5332e27cf5d76b3becf1abcaaff6b2f2fd48441609b91d969ce078a2a3c4a38cc68b421b8e796561be87858adb77ac780f45650147469596 SHA512 75ae11a49de4277c7b4e49b83d7f34c9eb17b6bde988ab84e735109430361856ae0d33179a678b2cfc88342966a8e393a75062142c6f713f8a974aa8f332691e
DIST prometheus-2.6.1.tar.gz 6612143 BLAKE2B 33dc64406dd45f494720a1ff5f6d09ed4b45b3880b15626ab7455909258addc5d1549d3edbf8af9a374516930b297c5bdb6ef51a78cac3cb338357896c0d71ae SHA512 80bf6afa00b60aa4245a53e275a2b9579a7936609aba4ffacbbe478f34e530208e0498d8c5ea53dd3a940726e05bd6fac19fed3d6d9dd209af565d5368b2340f
DIST prometheus-2.7.0.tar.gz 7276755 BLAKE2B 39c5e73f87aa919537eba19c09a0268b1079ffc8527aef6d31637c6cd9339e0c49a60afc44515d18a86aca6056bf0a1707ba02fc441ff63f0f517d864747d5be SHA512 02df7701cc9c50c2792c1a9ddfb6e41345bbc2f12aef8dfb09b5b545499a09a88d13c6d70a090086d35694817d7a5b26312554ebc50b02492bfdbf206f611d03
+DIST prometheus-2.7.1.tar.gz 7276631 BLAKE2B 1066204eebd8e9589ce5972c78f1c56c74ae40739e850731beb7c39a6100aa0c252b444571cffb6cedabddd71f0b6f927e52ce4ebb35a7fd061ed5e4d50436f7 SHA512 d9a9a5cfca48b6a5ea5dda2b319f8c498b11e0e0a4ce0d18fc4d59fba9e5337048120ba12b29d18b957ac5c268f8c17996a9e88ff9ed1e3041d0ed00bc1454d0
diff --git a/app-metrics/prometheus/prometheus-2.7.1.ebuild b/app-metrics/prometheus/prometheus-2.7.1.ebuild
new file mode 100644
index 000000000000..0687f8f10dfc
--- /dev/null
+++ b/app-metrics/prometheus/prometheus-2.7.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus"
+MY_PV=${PV/_rc/-rc.}
+EGIT_COMMIT="v${MY_PV}"
+PROMETHEUS_COMMIT="62e591f"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/go-1.10
+ dev-util/promu"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GO111MODULE=on GOPATH="${S}" GOCACHE="${T}/go-cache" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus-3.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}