summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyotp/pyotp-2.2.6-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pyotp/pyotp-2.2.6-r1.ebuild b/dev-python/pyotp/pyotp-2.2.6-r1.ebuild
new file mode 100644
index 000000000000..cd97f5e226f7
--- /dev/null
+++ b/dev-python/pyotp/pyotp-2.2.6-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="PyOTP is a Python library for generating and verifying one-time passwords."
+HOMEPAGE="https://github.com/pyotp/pyotp https://pypi.org/project/pyotp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Testing failed with ${EPYTHON}"
+}