summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-nntp/pan/Manifest1
-rw-r--r--net-nntp/pan/pan-0.141.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-nntp/pan/Manifest b/net-nntp/pan/Manifest
index 0ffd0e3dba98..de814ef1f61e 100644
--- a/net-nntp/pan/Manifest
+++ b/net-nntp/pan/Manifest
@@ -1 +1,2 @@
DIST pan-0.140.tar.bz2 1563454 SHA256 ba1c65ee75b9eca1f15f6249ea762492309731446edc8b09085b63ad34351c71 SHA512 25936862ec566aa697ce99455320be7e28a341fa9c1ffe3b156d69f242e54e4cf5c454286f59b703aab9aebb0938f3923363a44b36228b4e99fe16e0a0724c9e WHIRLPOOL 3ade64d51148b6adac0c882424ad0b168bed79bcfb38fe2ab51fc9a3c238ac4f2acb2f23ccf64a462566652d7aa71715eb08d85eae11e2685fafb9a48a91e949
+DIST pan-0.141.tar.bz2 1589991 SHA256 ffa63cd078afa18496be86a76db9370eb0ccdab5ae1f2f74ef5adc7753d11aa3 SHA512 35071386ff0ee44a7bb650674c81b7ebba4cc0f22915b67a42e415a68284154ef24e38493f09601b7dec2fe054305ce3433c054cd2f3f557c259b0911c265496 WHIRLPOOL 4dec71a6e7153f0139de503c708e397e521e78bb9700b2450b85a7b46c064c67ce7f5a859059930bf9e88f78694d840d2f642371525fe19d55ddda6cf8325068
diff --git a/net-nntp/pan/pan-0.141.ebuild b/net-nntp/pan/pan-0.141.ebuild
new file mode 100644
index 000000000000..ba31f72980c4
--- /dev/null
+++ b/net-nntp/pan/pan-0.141.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A newsreader for GNOME"
+HOMEPAGE="http://pan.rebelbase.com/"
+SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="dbus gnome-keyring libnotify spell ssl"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ dev-libs/gmime:2.6
+ >=sys-libs/zlib-1.2.0
+ >=x11-libs/gtk+-2.16:2
+ gnome-keyring? ( >=gnome-base/libgnome-keyring-3.2 )
+ libnotify? ( >=x11-libs/libnotify-0.4.1:0= )
+ spell? (
+ >=app-text/enchant-1.6
+ >=app-text/gtkspell-2.0.7:2 )
+ ssl? ( >=net-libs/gnutls-3:0= )
+"
+DEPEND="${RDEPEND}
+ app-text/gnome-doc-utils
+ >=dev-util/intltool-0.35.5
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Wait for webkitgtk4 support
+ # gtk3 support is still not ready (follow what Fedora does)
+ gnome2_src_configure \
+ --without-gtk3 \
+ --without-webkit \
+ $(use_with dbus) \
+ $(use_enable gnome-keyring gkr) \
+ $(use_with spell gtkspell) \
+ $(use_enable libnotify) \
+ $(use_with ssl gnutls)
+}