summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/consul-template/consul-template-0.19.5.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-admin/consul-template/consul-template-0.19.5.ebuild b/app-admin/consul-template/consul-template-0.19.5.ebuild
index dfa6bf036b0b..ab75ab08e38d 100644
--- a/app-admin/consul-template/consul-template-0.19.5.ebuild
+++ b/app-admin/consul-template/consul-template-0.19.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -31,6 +31,9 @@ src_prepare() {
sed -e "s:git rev-parse --short HEAD:echo ${GIT_COMMIT}:" \
-e '/-s \\/d' \
-i src/${EGO_PN}/Makefile || die
+ # Printf format %q has arg r.config.PidFile of wrong type *string
+ sed -e 's|remove pid at %q: %s|remove pid at %v: %s|' \
+ -i src/${EGO_PN}/manager/runner.go || die
}
src_compile() {