summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail-client/evolution/Manifest1
-rw-r--r--mail-client/evolution/evolution-3.22.3.ebuild139
2 files changed, 140 insertions, 0 deletions
diff --git a/mail-client/evolution/Manifest b/mail-client/evolution/Manifest
index 4ec87b8a0304..e82801524cdb 100644
--- a/mail-client/evolution/Manifest
+++ b/mail-client/evolution/Manifest
@@ -1,3 +1,4 @@
DIST evolution-3.20.5.tar.xz 12133872 SHA256 2e13551ce0996963506f0bdde5e01c3b8aa0622849a272ff12877cd595baeb6e SHA512 4b974ac5d8f3918a8012192634e8d131b1f6af0ed40a32181eb9500bc43b8bf4cf29a6fc7e49620638ada8f2456117e263e6162f21c0e1deef81861789a97906 WHIRLPOOL 1ed38bd2b9de97ad50bb832e03b76bf94131e65f0cf05c555d9e62d0e908467382b7e879d8eeb9513a6a09396da77eb2b2ac3a0dd3b97c6f2cde373dd65222ae
DIST evolution-3.22.1.tar.xz 12257260 SHA256 fa652d830f4185c33666770e6e9cfcc39d5e2f09486bbd63a084f3527064e52e SHA512 7306605160fd39999ec8c710f65f4cdadd18b19e5b354748e896d0f3a381fc387b7c6017407db69acb681f67e944d15459d31bf9bd392e7c6071610e0be6d1b9 WHIRLPOOL 183c837ed6629c0fbe858cb8423f03a889db2398c2b4c060346628f111daeee1142ec2f53b12a25f5937e1af36b8002a36abed497236423d4ad19a07891b4643
DIST evolution-3.22.2.tar.xz 12265296 SHA256 670e4cb620d30a57480c7c6f4cfe4e3bef6175a6dddadb2a8607f3532a693d34 SHA512 8727c7b1d0c9480825451d6813863d2f664a606fdbc8a353cc027a58533b30adeecd1bf804ad2ba1cec384bf3d5cbaedfd1c99e810a2e47882f10770df0c422f WHIRLPOOL 8e05fcfa987d1ad443c1b962cc9b07ec0565b30a45647101af67ffbd73245a674b83b156cd18f8b9ed740d54e9bf7c167c19422c3f3c658ad3a04fe75485adb7
+DIST evolution-3.22.3.tar.xz 12269980 SHA256 a7328b0f225e41654643514eefafb02e6819660fd989ec1e8feab4f17e93dc00 SHA512 33d31d8c7dff30e026280fddc599085c1f9d0624e9c3ed95d9815787a48aebefc198b1bb2cb4bab75d283120c72275144ba4f158e8d82a6055c60dcd02b6addc WHIRLPOOL 2e89b65d40f97597e7554fffe235b9477b6529b5eba73fbcb61b53bfd72515ca32c52f55585431ad4b122d14d5be29ea863536ba045dcbbfeb72a181e88301ac
diff --git a/mail-client/evolution/evolution-3.22.3.ebuild b/mail-client/evolution/evolution-3.22.3.ebuild
new file mode 100644
index 000000000000..4324cf88ae45
--- /dev/null
+++ b/mail-client/evolution/evolution-3.22.3.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 flag-o-matic readme.gentoo-r1
+
+DESCRIPTION="Integrated mail, addressbook and calendaring functionality"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+# Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+".
+LICENSE="|| ( LGPL-2 LGPL-3 ) CC-BY-SA-3.0 FDL-1.3+ OPENLDAP"
+SLOT="2.0"
+
+IUSE="+bogofilter crypt geolocation highlight ldap spamassassin spell ssl +weather"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+# We need a graphical pinentry frontend to be able to ask for the GPG
+# password from inside evolution, bug 160302
+PINENTRY_DEPEND="|| ( app-crypt/pinentry[gnome-keyring] app-crypt/pinentry[gtk] app-crypt/pinentry[qt4] app-crypt/pinentry[qt5] )"
+
+# glade-3 support is for maintainers only per configure.ac
+# pst is not mature enough and changes API/ABI frequently
+# dconf explicitely needed for backup plugin
+# gnome-desktop support is optional with --enable-gnome-desktop
+# gnome-autoar (currently disabled because no release has been made)
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.4:=
+ >=app-text/enchant-1.1.7
+ >=dev-libs/glib-2.46:2[dbus]
+ >=dev-libs/libxml2-2.7.3:2
+ >=gnome-base/gnome-desktop-2.91.3:3=
+ >=gnome-base/gsettings-desktop-schemas-2.91.92
+ >=gnome-extra/evolution-data-server-${PV}:=[gtk,weather?]
+ >=media-libs/libcanberra-0.25[gtk3]
+ >=net-libs/libsoup-2.42:2.4
+ >=net-libs/webkit-gtk-2.13.90:4
+ >=x11-libs/cairo-1.9.15:=[glib]
+ >=x11-libs/gdk-pixbuf-2.24:2
+ >=x11-libs/gtk+-3.10:3
+ >=x11-libs/libnotify-0.7:=
+ >=x11-misc/shared-mime-info-0.22
+
+ >=app-text/iso-codes-0.49
+ dev-libs/atk
+ gnome-base/dconf
+ dev-libs/libical:=
+ x11-libs/libSM
+ x11-libs/libICE
+
+ crypt? (
+ >=app-crypt/gnupg-1.4
+ ${PINENTRY_DEPEND}
+ x11-libs/libcryptui )
+ geolocation? (
+ >=media-libs/libchamplain-0.12:0.12[gtk]
+ >=media-libs/clutter-1.0.0:1.0
+ >=media-libs/clutter-gtk-0.90:1.0
+ >=sci-geosciences/geocode-glib-3.10.0
+ x11-libs/mx:1.0 )
+ ldap? ( >=net-nds/openldap-2:= )
+ spell? ( app-text/gtkspell:3 )
+ ssl? (
+ >=dev-libs/nspr-4.6.1:=
+ >=dev-libs/nss-3.11:= )
+ weather? ( >=dev-libs/libgweather-3.10:2= )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40.0
+ >=gnome-base/gnome-common-2.12
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ bogofilter? ( mail-filter/bogofilter )
+ highlight? ( app-text/highlight )
+ spamassassin? ( mail-filter/spamassassin )
+ !gnome-extra/evolution-exchange
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="To change the default browser if you are not using GNOME, edit
+~/.local/share/applications/mimeapps.list so it includes the
+following content:
+
+[Default Applications]
+x-scheme-handler/http=firefox.desktop
+x-scheme-handler/https=firefox.desktop
+
+(replace firefox.desktop with the name of the appropriate .desktop
+file from /usr/share/applications if you use a different browser)."
+
+src_configure() {
+ # Use NSS/NSPR only if 'ssl' is enabled.
+ gnome2_src_configure \
+ --without-glade-catalog \
+ --disable-autoar \
+ --disable-code-coverage \
+ --disable-installed-tests \
+ --disable-pst-import \
+ --enable-canberra \
+ $(use_enable crypt libcryptui) \
+ $(use_enable highlight text-highlight) \
+ $(use_enable geolocation contact-maps) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl nss) \
+ $(use_enable ssl smime) \
+ $(use_with bogofilter) \
+ $(use_with ldap openldap) \
+ $(use_with spamassassin) \
+ $(usex ssl --enable-nss=yes "--without-nspr-libs
+ --without-nspr-includes
+ --without-nss-libs
+ --without-nss-includes") \
+ $(use_enable weather)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Problems with prelink:
+ # https://bugzilla.gnome.org/show_bug.cgi?id=731680
+ # https://bugzilla.gnome.org/show_bug.cgi?id=732148
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1114538
+ echo PRELINK_PATH_MASK=/usr/bin/evolution > ${T}/99${PN}
+ doenvd "${T}"/99${PN}
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}