summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/osinfo-db-tools/Manifest1
-rw-r--r--sys-apps/osinfo-db-tools/osinfo-db-tools-1.6.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/osinfo-db-tools/Manifest b/sys-apps/osinfo-db-tools/Manifest
index c00dcd60952d..11b28ff50ffa 100644
--- a/sys-apps/osinfo-db-tools/Manifest
+++ b/sys-apps/osinfo-db-tools/Manifest
@@ -1 +1,2 @@
DIST osinfo-db-tools-1.4.0.tar.gz 519089 BLAKE2B 2c2e0cdbcd0a795f8deb09727b8b971748f5d0ecc08449238d3054cbd947a0f6059456d4e9feadded47cd0e0aaa87132f1bec7524a3183115dd459eca989d1b0 SHA512 f4813f948551f630cc9936986abc3ef4455647ec529b353dc4fee71f8071beeebac0a2ee1988cede92ea3635bca9bedd400ac9f275e3f5592ff50236d97cfb91
+DIST osinfo-db-tools-1.6.0.tar.gz 547189 BLAKE2B 38db3118d618d620a137b12021fbcf9caffe1e0f67252d2eb7c514d4f25969b152679f55b493bb64abc0925ff07ccea897acfd809d17d7257db2b33a690f4878 SHA512 a3bdf9d913b388b0f567a14245f57c4f1da9dae40d723f8e76096ffdae9d7a8e587ed4832e3e59c820bc01bbb2b74815b3fefd8e1f47cebd903091457fdee951
diff --git a/sys-apps/osinfo-db-tools/osinfo-db-tools-1.6.0.ebuild b/sys-apps/osinfo-db-tools/osinfo-db-tools-1.6.0.ebuild
new file mode 100644
index 000000000000..e3002f6cee03
--- /dev/null
+++ b/sys-apps/osinfo-db-tools/osinfo-db-tools-1.6.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-single-r1 gnome2
+
+DESCRIPTION="Tools for managing the osinfo database"
+HOMEPAGE="https://libosinfo.org/"
+SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+# Blocker on old libosinfo as osinfo-db-validate was part of it before
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/libxml2-2.6.0
+ >=app-arch/libarchive-3.0.0:=
+ dev-libs/json-glib
+ net-libs/libsoup:2.4
+ !<sys-libs/libosinfo-1.0.0
+"
+# perl dep is for pod2man (and syntax check but only in git, but configure check exists in release)
+# libxslt is checked for in configure.ac, but never used in 1.1.0
+DEPEND="${RDEPEND}
+ >=dev-libs/libxslt-1.0.0
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.19.8
+ dev-lang/perl
+ test? ( ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+"
+
+pkg_setup() {
+ use test && python-single-r1_pkg_setup
+}