summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/rsyslog/files/rsyslog-8.1903.0-add-py3-support-to-omhttp-test.patch (renamed from app-admin/rsyslog/files/rsyslog-8.1903.0-add-py3-support-to-omhttp-test.patch.patch)0
-rw-r--r--app-admin/rsyslog/files/rsyslog-8.1903.0-fix-py3-compatibility-in-diag.sh.patch22
-rw-r--r--app-admin/rsyslog/rsyslog-8.1903.0.ebuild3
3 files changed, 24 insertions, 1 deletions
diff --git a/app-admin/rsyslog/files/rsyslog-8.1903.0-add-py3-support-to-omhttp-test.patch.patch b/app-admin/rsyslog/files/rsyslog-8.1903.0-add-py3-support-to-omhttp-test.patch
index 6600c61666e9..6600c61666e9 100644
--- a/app-admin/rsyslog/files/rsyslog-8.1903.0-add-py3-support-to-omhttp-test.patch.patch
+++ b/app-admin/rsyslog/files/rsyslog-8.1903.0-add-py3-support-to-omhttp-test.patch
diff --git a/app-admin/rsyslog/files/rsyslog-8.1903.0-fix-py3-compatibility-in-diag.sh.patch b/app-admin/rsyslog/files/rsyslog-8.1903.0-fix-py3-compatibility-in-diag.sh.patch
new file mode 100644
index 000000000000..615bb50bdb92
--- /dev/null
+++ b/app-admin/rsyslog/files/rsyslog-8.1903.0-fix-py3-compatibility-in-diag.sh.patch
@@ -0,0 +1,22 @@
+From f0847e46c148233b6ab5d6088ca4e1dc664e82a4 Mon Sep 17 00:00:00 2001
+From: Thomas Deutschmann <whissi@whissi.de>
+Date: Sat, 6 Apr 2019 02:07:51 +0200
+Subject: [PATCH] testbench: fix Python 3 compatibility
+
+---
+ tests/diag.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/diag.sh b/tests/diag.sh
+index 5b4b3df46..2926e6ac2 100755
+--- a/tests/diag.sh
++++ b/tests/diag.sh
+@@ -1334,7 +1334,7 @@ get_inode() {
+ printf 'FAIL: file "%s" does not exist in get_inode\n' "$1"
+ error_exit 100
+ fi
+- python -c 'import os; import stat; print os.lstat("'$1'")[stat.ST_INO]'
++ python -c 'import os; import stat; print(os.lstat("'$1'")[stat.ST_INO])'
+ }
+
+
diff --git a/app-admin/rsyslog/rsyslog-8.1903.0.ebuild b/app-admin/rsyslog/rsyslog-8.1903.0.ebuild
index d1896aca4726..dcc28922f7b5 100644
--- a/app-admin/rsyslog/rsyslog-8.1903.0.ebuild
+++ b/app-admin/rsyslog/rsyslog-8.1903.0.ebuild
@@ -102,7 +102,8 @@ fi
PATCHES=(
"${FILESDIR}"/${P}-add-missing-tests.patch
- "${FILESDIR}"/${P}-add-py3-support-to-omhttp-test.patch.patch
+ "${FILESDIR}"/${P}-add-py3-support-to-omhttp-test.patch
+ "${FILESDIR}"/${P}-fix-py3-compatibility-in-diag.sh.patch
)
CONFIG_CHECK="~INOTIFY_USER"