summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-4.47.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 4f1a88259339..98e9d070ff6e 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -5,3 +5,4 @@ DIST hypothesis-python-4.44.2.tar.gz 3240386 BLAKE2B 3fe3295ba1f7401e1fb74af894d
DIST hypothesis-python-4.45.1.tar.gz 3252805 BLAKE2B ec319d9432ebf723668e14e5f7a07f5aee0736e477eb102f79a528537aae1e2bcca1dfb6e12117026b1976f25cb720f5a0ed389f0c942715eab8470ec8aa0833 SHA512 6da73332c7e48ea9608732117633f6c3960c944ce03a5f67ecb72d2fad2ccb035ea3116762f9512f53735489d87e90a32631b01ee3ab679c8ca65bdebd47c785
DIST hypothesis-python-4.46.0.tar.gz 3253156 BLAKE2B 5e73fdb756aa2fa0b10342d11addeed6a0b258f24ae1ee5fa231fae7ad98d1fcaa792713fc70f05f49408363c29e03571f1aa3b7e7d0810fcb436af53ef9f2ce SHA512 5d3bc696c35e189f594dc69eaa74af7b51710dac46aad48c8978ef8425c0b614aabae03e62e4fdf5dcb98d0284b56ccc1ca7af87c6eee763e686ab84c19b82ec
DIST hypothesis-python-4.46.1.tar.gz 3253625 BLAKE2B ffdc12b26ee486aefafdb477b20ccb05f4790cd7a4ca7a73c0316b9279300f949cdfc7a97f398047cc09c8c386f5297594cc70714dfdc7109aecd829933405fb SHA512 bf27e9f2938ec42459432593abac38871dd80b671738e7650effc8103b49e945819b2528c7976867b6d9c570bcfb87125d51d03e3321a3b4aa2178fc2661f923
+DIST hypothesis-python-4.47.1.tar.gz 3253826 BLAKE2B 6daae1eef6c36b874f44d1e3c7a4ebd18e76c6a4d1543062cc53bbb93d65e1e0a441b084c97cb13f79867e4e77830c2ce71ef779f7086fdfb99756226911d81b SHA512 e3de34822b018a3d7ef474a90eff6b74ce3f214e374cadec34af80b8bdea90bcbc4f8e3de6cac9218729d99e8ffa12dd8216a53078801ba45b76552fac2a6c35
diff --git a/dev-python/hypothesis/hypothesis-4.47.1.ebuild b/dev-python/hypothesis/hypothesis-4.47.1.ebuild
new file mode 100644
index 000000000000..3def9e851218
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-4.47.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local pyver=$(python_is_python3 && echo 3 || echo 2)
+ pytest -vv tests/cover tests/pytest tests/py${pyver} ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}