summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/idea-community/Manifest2
-rw-r--r--dev-util/idea-community/idea-community-2024.1.1.ebuild136
2 files changed, 138 insertions, 0 deletions
diff --git a/dev-util/idea-community/Manifest b/dev-util/idea-community/Manifest
index 4246d030289b..828e3bec3141 100644
--- a/dev-util/idea-community/Manifest
+++ b/dev-util/idea-community/Manifest
@@ -1,2 +1,4 @@
DIST idea-community-2024.1.0-aarch64.tar.gz 817149507 BLAKE2B 02d397fb0d5d2d34d5183389fb08a8631f186411d72431a3428af07563ad10e6d505974b167105028134dcebb711d1d86ec12bc53533b3225d2f210a4fcdcdd4 SHA512 14ee3b1a801cc8b3577b660c18eb623fab03ce98e2462db97d4cf8fa2fc01653f48b73ce20ff6ef07c102897a879809337b9e22afa423cd490b0afd13bd94864
DIST idea-community-2024.1.0-amd64.tar.gz 817447015 BLAKE2B 7b3599bd5d208b7583cb5cdeb8222752b177047e48c69773b4b68ed75b847a4ed98e96d4f4d5338d64147076425d7f94e8d2de39f0e7e407fcb12136f5acba5d SHA512 9911d6dda3f4c3f36fcd2cd16c21440799e7db2450fc70662deacfbe496fe5fed971875652a89ae81194b7b46ded9f7d853bcef0910698a76b3e8764a88c5c75
+DIST idea-community-2024.1.1-aarch64.tar.gz 818376053 BLAKE2B 193d5a735a93840e0857905ee1fb233bbaf3a0eac0c90fc3ef8f370eaa97a0ef7c1f247d73d8455f97d7e578f692ae990f1155a626f8c0372a536bd726bf552d SHA512 5a73b8fadcde4abd75cb50c1a61b3d53fb6fff38a9fc338f8b9dd9f78911e1182f58c0788e935a30e8937232bdcfb8d60894d9baf2f408cc57c4b229c5c8b76d
+DIST idea-community-2024.1.1-amd64.tar.gz 818675061 BLAKE2B cfe995c8f2de6493291d1b47ba5402c07409a0de7f51f73eae1423cf2b87a43191b0e69914ec77d50ae9237bd4ed702118531af169d2b80f9e3ead2449f1a5d3 SHA512 7cec47a883fd084ca91d9dce0e0f9685a9606c503b64f2e6d6932f33af7cb337c1925d884324e867a56cf8164f74916b5b532bef4f828d89f633df0fa8ba3e78
diff --git a/dev-util/idea-community/idea-community-2024.1.1.ebuild b/dev-util/idea-community/idea-community-2024.1.1.ebuild
new file mode 100644
index 000000000000..33f57cb22c20
--- /dev/null
+++ b/dev-util/idea-community/idea-community-2024.1.1.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit desktop wrapper
+
+MY_PV=$(ver_cut 1-3)
+
+DESCRIPTION="A complete toolset for web, mobile and enterprise development"
+HOMEPAGE="https://www.jetbrains.com/idea"
+
+SRC_URI="
+ amd64? ( https://download.jetbrains.com/idea/ideaIC-${MY_PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm64? ( https://download.jetbrains.com/idea/ideaIC-${MY_PV}-aarch64.tar.gz -> ${P}-aarch64.tar.gz )
+ "
+
+S="${WORKDIR}/idea-IC-${PV}"
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 CC-BY-2.5 CDDL-1.1
+ codehaus-classworlds CPL-1.0 EPL-1.0 EPL-2.0
+ GPL-2 GPL-2-with-classpath-exception ISC
+ JDOM LGPL-2.1 LGPL-2.1+ LGPL-3-with-linking-exception MIT
+ MPL-1.0 MPL-1.1 OFL ZLIB"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+DEPEND="
+ || (
+ >=dev-java/openjdk-17.0.8.1_p1:17
+ >=dev-java/openjdk-bin-17.0.8.1_p1:17
+ )"
+
+RDEPEND="${DEPEND}
+ sys-libs/glibc
+ media-libs/harfbuzz
+ dev-java/jansi-native
+ dev-libs/libdbusmenu"
+
+BDEPEND="dev-util/patchelf"
+RESTRICT="splitdebug"
+
+QA_PREBUILT="opt/${PN}/*"
+
+src_unpack() {
+
+ default_src_unpack
+ if [ ! -d "$S" ]; then
+ einfo "Renaming source directory to predictable name..."
+ mv $(ls "${WORKDIR}") "idea-IC-${PV}" || die
+ fi
+}
+
+src_prepare() {
+
+ default_src_prepare
+
+ if use amd64; then
+ JRE_DIR=jre64
+ rm -vf "${S}"/plugins/cwm-plugin/quiche-native/linux-aarch64/libquiche.so
+ else
+ JRE_DIR=jre
+ rm -vf "${S}"/plugins/cwm-plugin/quiche-native/linux-x86-64/libquiche.so
+ fi
+
+ PLUGIN_DIR="${S}/${JRE_DIR}/lib/"
+
+ # rm LLDBFrontEnd after licensing questions with Gentoo License Team
+ rm -vf "${S}"/plugins/Kotlin/bin/linux/LLDBFrontend
+ rm -vf ${PLUGIN_DIR}/libavplugin*
+ rm -vf "${S}"/plugins/maven/lib/maven3/lib/jansi-native/*/libjansi*
+ rm -vrf "${S}"/lib/pty4j-native/linux/ppc64le
+ rm -vf "${S}"/bin/libdbm64*
+ rm -vf "${S}"/lib/pty4j-native/linux/mips64el/libpty.so
+
+ if [[ -d "${S}"/"${JRE_DIR}" ]]; then
+ for file in "${PLUGIN_DIR}"/{libfxplugins.so,libjfxmedia.so}
+ do
+ if [[ -f "$file" ]]; then
+ patchelf --set-rpath '$ORIGIN' $file || die
+ fi
+ done
+ fi
+
+ rm -vf "${S}"/lib/pty4j-native/linux/x86-64/libpty.so
+
+ sed -i \
+ -e "\$a\\\\" \
+ -e "\$a#-----------------------------------------------------------------------" \
+ -e "\$a# Disable automatic updates as these are handled through Gentoo's" \
+ -e "\$a# package manager. See bug #704494" \
+ -e "\$a#-----------------------------------------------------------------------" \
+ -e "\$aide.no.platform.update=Gentoo" bin/idea.properties
+
+ eapply_user
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+ local dst="${D}${dir}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{format.sh,idea.sh,inspect.sh,restarter,fsnotifier}
+ if use amd64; then
+ JRE_DIR=jre64
+ else
+ JRE_DIR=jre
+ fi
+
+ JRE_BINARIES="jaotc java javapackager jjs jrunscript keytool pack200 rmid rmiregistry unpack200"
+ if [[ -d ${JRE_DIR} ]]; then
+ for jrebin in $JRE_BINARIES; do
+ fperms 755 "${dir}"/"${JRE_DIR}"/bin/"${jrebin}"
+ done
+ fi
+
+ # bundled script is always lowercase, and doesn't have -ultimate, -professional suffix.
+ local bundled_script_name="${PN%-*}.sh"
+ make_wrapper "${PN}" "${dir}/bin/$bundled_script_name" || die
+
+ local pngfile="$(find ${dst}/bin -maxdepth 1 -iname '*.png')"
+ newicon $pngfile "${PN}.png" || die "we died"
+
+ make_desktop_entry "${PN}" "IntelliJ Idea Community Edition" "${PN}" "Development;IDE;"
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ mkdir -p "${D}/etc/sysctl.d/" || die
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
+
+ # remove bundled harfbuzz
+ rm -f "${D}"/lib/libharfbuzz.so || die "Unable to remove bundled harfbuzz"
+
+ # remove bundled java
+ rm -r ${dst}/jbr || die "Unable to remove bundled java"
+
+}