summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/chuck/Manifest1
-rw-r--r--media-sound/chuck/chuck-1.2.1.2.ebuild95
-rw-r--r--media-sound/chuck/files/chuck-1.2.1.2-gcc44.patch12
-rw-r--r--media-sound/chuck/files/chuck-1.3.1.3-makefile.patch39
-rw-r--r--media-sound/chuck/files/chuck.eselect-0.1152
5 files changed, 0 insertions, 299 deletions
diff --git a/media-sound/chuck/Manifest b/media-sound/chuck/Manifest
index ce56ee1e500e..2767efe05c4e 100644
--- a/media-sound/chuck/Manifest
+++ b/media-sound/chuck/Manifest
@@ -1,3 +1,2 @@
-DIST chuck-1.2.1.2.tgz 1546875 SHA256 9cb9c246a2fb7ac886c0a3d5f23a5d60eb18aa7717f6ee57f031e42140cf0d2a SHA512 c5666200b54aec825ede1252f8b0b81a4b0608dde6c5a73a8c15cef35877b88d6a9b880a40f980edb7eca00fd4796db23cf46724bf5b858910ddbca4cbd27dbe WHIRLPOOL 54278f4ad348b6e5c7275bb3180e1327f2e9657ad90d823ad0c9c3934346114c83cd40dbb5260405158cc6e028caee336be2d0655e4729af0fc8092d7efd1036
DIST chuck-1.3.5.1.tgz 14686970 SHA256 d141ca61547131edd2b29bdb88183835e4133ef09807674bfa33a4e6e09d1f53 SHA512 450237207150b285954dc2661d6f7829424d4353cdc457a7dce637b6877247b106ad0ed58bdbded17c1f7558e0f01daa7a06642f2727136f6edca5a64d202f73 WHIRLPOOL 5b70e6badffa39e38ea795ea688b4a452cd290dd849d6779e799c7a79e00513fa4b8c07ed64b7243bd0075936ce3ab4bdc99482268d564391ef3a1a96b9f9e8f
DIST chuck-1.3.5.2.tgz 14687476 SHA256 e900b8545ffcb69c6d49354b18c43a9f9b8f789d3ae822f34b408eaee8d3e70b SHA512 00407b0f20fa9adcd9d0c31078ef7593f8a5b026f19086942c3fa56128fd07e202848651e5e8f41f1d70566de766e84f4a049ca4013e65a61b6f6fb10d69ffbc WHIRLPOOL 1eb7da2136d88cec35d7cb26b56e2e4073eb546ee304d6113cf44a82852e0bc5b87e4064bfb87224cfb1080931e68e179d6468be26da9b8e1ad6d987f7d71d7e
diff --git a/media-sound/chuck/chuck-1.2.1.2.ebuild b/media-sound/chuck/chuck-1.2.1.2.ebuild
deleted file mode 100644
index 3b43aab18997..000000000000
--- a/media-sound/chuck/chuck-1.2.1.2.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit toolchain-funcs flag-o-matic eutils
-
-DESCRIPTION="Strongly-timed, Concurrent, and On-the-fly
-Audio Programming Language"
-HOMEPAGE="http://chuck.cs.princeton.edu/release/"
-SRC_URI="http://chuck.cs.princeton.edu/release/files/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86"
-IUSE="oss jack alsa examples"
-
-RDEPEND="jack? ( media-sound/jack-audio-connection-kit )
- alsa? ( media-libs/alsa-lib )
- media-libs/libsndfile
- app-admin/eselect"
-DEPEND="${RDEPEND}
- sys-devel/bison
- sys-devel/flex"
-
-pkg_setup() {
- local cnt=0
- use jack && cnt="$((${cnt} + 1))"
- use alsa && cnt="$((${cnt} + 1))"
- use oss && cnt="$((${cnt} + 1))"
- if [[ "${cnt}" -eq 0 ]] ; then
- eerror "One of the following USE flags is needed: jack, alsa or oss"
- die "Please set one audio engine type"
- elif [[ "${cnt}" -ne 1 ]] ; then
- ewarn "You have set ${P} to use multiple audio engine."
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.2.1.1-hid-smc.patch \
- "${FILESDIR}"/${P}-gcc44.patch
-}
-
-src_compile() {
- # when compile with athlon or athlon-xp flags
- # chuck crashes on removing a shred with a double free or corruption
- # it happens in Chuck_VM_Stack::shutdown() on the line
- # SAFE_DELETE_ARRAY( stack );
- replace-cpu-flags athlon athlon-xp i686
-
- use jack && compile_backend jack
- use alsa && compile_backend alsa
- use oss && compile_backend oss
-}
-
-compile_backend() {
- backend=$1
- einfo "Compiling against ${backend}"
- cd "${S}/src"
- emake -f "makefile.${backend}" CC=$(tc-getCC) CXX=$(tc-getCXX) || die "emake failed"
- mv chuck{,.${backend}}
- emake -f "makefile.${backend}" clean
-}
-
-src_install() {
- use jack && dobin src/chuck.jack
- use alsa && dobin src/chuck.alsa
- use oss && dobin src/chuck.oss
-
- dodoc AUTHORS DEVELOPER PROGRAMMER QUICKSTART README THANKS TODO VERSIONS
- docinto doc
- dodoc doc/*
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins $(find examples -type f)
- for dir in $(find examples/* -type d); do
- insinto /usr/share/doc/${PF}/"${dir}"
- doins "${dir}"/*
- done
- fi
-
- dodir /usr/share/eselect/modules
- insinto /usr/share/eselect/modules
- newins "${FILESDIR}"/chuck.eselect-0.1 chuck.eselect
-}
-
-pkg_postinst() {
- elog "Chuck now can use many audio engines, so you can specify audio engine"
- elog "with chuck.{jack,alsa,oss}"
- elog "Or you can use 'eselect chuck' to set the audio engine"
-
- einfo "Calling eselect chuck update..."
- eselect chuck update --if-unset
-}
diff --git a/media-sound/chuck/files/chuck-1.2.1.2-gcc44.patch b/media-sound/chuck/files/chuck-1.2.1.2-gcc44.patch
deleted file mode 100644
index 8059c97592f7..000000000000
--- a/media-sound/chuck/files/chuck-1.2.1.2-gcc44.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur chuck-1.2.1.2.orig/src/util_string.h chuck-1.2.1.2/src/util_string.h
---- chuck-1.2.1.2.orig/src/util_string.h 2008-07-16 12:55:17.000000000 +0300
-+++ chuck-1.2.1.2/src/util_string.h 2009-06-01 21:33:59.000000000 +0300
-@@ -33,6 +33,8 @@
- #ifndef __UTIL_STRING_H__
- #define __UTIL_STRING_H__
-
-+#include <cstdio>
-+
- #include "chuck_def.h"
- #include <string>
- #include <vector>
diff --git a/media-sound/chuck/files/chuck-1.3.1.3-makefile.patch b/media-sound/chuck/files/chuck-1.3.1.3-makefile.patch
deleted file mode 100644
index e1dad7f56613..000000000000
--- a/media-sound/chuck/files/chuck-1.3.1.3-makefile.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff -ru chuck-1.3.1.3.back/src/makefile chuck-1.3.1.3/src/makefile
---- chuck-1.3.1.3.back/src/makefile 2012-10-07 15:55:19.000000000 +0200
-+++ chuck-1.3.1.3/src/makefile 2012-10-07 15:57:54.000000000 +0200
-@@ -34,8 +34,6 @@
-
- ifneq ($(CHUCK_DEBUG),)
- CFLAGS+= -g
--else
--CFLAGS+= -O3
- endif
-
- ifneq ($(USE_64_BIT_SAMPLE),)
-diff -ru chuck-1.3.1.3.back/src/makefile.alsa chuck-1.3.1.3/src/makefile.alsa
---- chuck-1.3.1.3.back/src/makefile.alsa 2012-10-07 15:55:19.000000000 +0200
-+++ chuck-1.3.1.3/src/makefile.alsa 2012-10-07 15:57:20.000000000 +0200
-@@ -1,4 +1,4 @@
-
--CFLAGS+= -D__LINUX_ALSA__ -O3 -fno-strict-aliasing -D__CK_SNDFILE_NATIVE__
-+CFLAGS+= -D__LINUX_ALSA__ -fno-strict-aliasing -D__CK_SNDFILE_NATIVE__
- LDFLAGS+= -lasound -lstdc++ -ldl -lm -lsndfile -lpthread
-
-diff -ru chuck-1.3.1.3.back/src/makefile.jack chuck-1.3.1.3/src/makefile.jack
---- chuck-1.3.1.3.back/src/makefile.jack 2012-10-07 15:55:19.000000000 +0200
-+++ chuck-1.3.1.3/src/makefile.jack 2012-10-07 15:57:34.000000000 +0200
-@@ -1,4 +1,4 @@
-
--CFLAGS+= -D__UNIX_JACK__ -D__LINUX_JACK__ -O3 -fno-strict-aliasing -D__CK_SNDFILE_NATIVE__
-+CFLAGS+= -D__UNIX_JACK__ -D__LINUX_JACK__ -fno-strict-aliasing -D__CK_SNDFILE_NATIVE__
- LDFLAGS+= -lasound -ljack -lstdc++ -ldl -lm -lsndfile -lpthread
-
-diff -ru chuck-1.3.1.3.back/src/makefile.oss chuck-1.3.1.3/src/makefile.oss
---- chuck-1.3.1.3.back/src/makefile.oss 2012-10-07 15:55:19.000000000 +0200
-+++ chuck-1.3.1.3/src/makefile.oss 2012-10-07 15:57:16.000000000 +0200
-@@ -1,4 +1,4 @@
-
--CFLAGS+= -D__LINUX_OSS__ -O3 -fno-strict-aliasing -D__CK_SNDFILE_NATIVE__
-+CFLAGS+= -D__LINUX_OSS__ -fno-strict-aliasing -D__CK_SNDFILE_NATIVE__
- LDFLAGS+= -lpthread -lstdc++ -ldl -lm -lsndfile
-
diff --git a/media-sound/chuck/files/chuck.eselect-0.1 b/media-sound/chuck/files/chuck.eselect-0.1
deleted file mode 100644
index a074d237cf66..000000000000
--- a/media-sound/chuck/files/chuck.eselect-0.1
+++ /dev/null
@@ -1,152 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-DESCRIPTION="Manage /usr/bin/chuck audio engine"
-MAINTAINER="cedk@gentoo.org"
-SVN_DATE='$Date: 2008/07/20 13:49:00 $'
-VERSION=$(svn_date_to_version "${SVN_DATE}" )
-
-# find a list of unison symlink targets, best first
-find_targets() {
- local f
- for f in "${ROOT}"/usr/bin/chuck.{jack,alsa,oss}; do
- if [[ -f ${f} ]] ; then
- echo "${f##*/chuck.}"
- fi
- done | tac
-}
-
-# find version number of currently symlinked version
-identify_target() {
- local f
- f="$(canonicalise "${ROOT}"/usr/bin/chuck)"
- echo "${f##*/chuck.}"
-}
-
-# try to remove the unison symlink
-remove_symlinks() {
- rm -f "${ROOT}"/usr/bin/chuck &>/dev/null
-}
-
-# set the unison symlink
-set_symlinks() {
- local target="${1}" targets
- if is_number "${target}" && [[ ${target} -ge 1 ]] ; then
- targets=( $(find_targets ) )
- target=${targets[$(( ${target} - 1 ))]}
- fi
- if [[ -f "${ROOT}/usr/bin/chuck.${target}" ]] ; then
- remove_symlinks
- ln -s "chuck.${target}" "${ROOT}/usr/bin/chuck" || \
- die "Could not set ${target} /usr/bin/chuck symlink"
- else
- die -q "Target \"${target}\" doesn't appear to be valid!"
- fi
-}
-
-### show action ###
-
-describe_show() {
- echo "Show the current chuck audio engine"
-}
-
-do_show() {
- [[ -z "${@}" ]] || die -q "Too many parameters"
-
- write_list_start "Current chuck audio engine:"
- if [[ -L "${ROOT}/usr/bin/chuck" ]] ; then
- write_kv_list_entry "$(identify_target)" ""
- elif [[ -e "${ROOT}/usr/bin/chuck" ]] ; then
- write_kv_list_entry "(not a symlink)" ""
- else
- write_kv_list_entry "(unset)" ""
- fi
-}
-
-### list action ###
-
-describe_list() {
- echo "List available chuck audio engines"
-}
-
-do_list() {
- [[ -z "${@}" ]] || die -q "Too many parameters"
-
- local i targets current
- targets=( $(find_targets ) )
- current=$(identify_target)
- if [[ -n ${targets[@]} ]] ; then
- for (( i = 0 ; i < ${#targets[@]} ; i = i + 1 )) ; do
- [[ ${targets[${i}]} == ${current} ]] && \
- targets[${i}]="${targets[${i}]} $(highlight '*' )"
- done
- write_list_start "Available chuck audio engines:"
- write_numbered_list "${targets[@]}"
- else
- write_kv_list_entry "(none found)" ""
- fi
-}
-
-### set action ###
-
-describe_set() {
- echo "Set a new chuck audio engine"
-}
-
-describe_set_options() {
- echo "target : Target audio engine or index from 'list' action"
-}
-
-describe_set_parameters() {
- echo "<target>"
-}
-
-do_set() {
- if [[ -z "${1}" ]] ; then
- die -q "You didn't give me an audio engine"
-
- elif [[ -n "${2}" ]] ; then
- die -q "Too many parameters"
-
- elif [[ -L "${ROOT}/usr/bin/chuck" ]] ; then
- if ! remove_symlinks ; then
- die -q "Can't remove existing audio engine symlink"
- elif ! set_symlinks "${1}" ; then
- die -q "Can't set new audio engine"
- fi
-
- elif [[ -e "${ROOT}/usr/bin/chuck" ]] ; then
- die -q "${ROOT}/usr/bin/chuck seems to be from an old ebuild, please remove manually"
-
- else
- set_symlinks "${1}" || die -q "Can't set new audio engine"
- fi
-}
-
-### update action ###
-
-describe_update() {
- echo "Automatically update the chuck audio engine"
-}
-
-describe_update_options() {
- echo "--if-unset : Do not override currently selected audio engine"
-}
-
-do_update() {
- [[ -z "${1}" ]] || ( [[ -z "${2}" ]] && [[ "${1}" == "--if-unset" ]] ) || \
- die -q "Usage error"
-
- if [[ -L "${ROOT}/usr/bin/chuck" ]] ; then
- [[ ${1} == "--if-unset" ]] && return
- remove_symlinks || die -q "Can't remove existing symlink"
- fi
- if [[ -e "${ROOT}/usr/bin/chuck" ]] ; then
- die -q "${ROOT}/usr/bin/chuck seems to be from an old ebuild, please remove manually"
- elif ! [[ -z $(find_targets ) ]] ; then
- set_symlinks 1 || die -q "Can't set a new audio engine"
- fi
-}
-
-# vim: ts=4 sw=4 noet fdm=marker