summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-dns/totd/Manifest1
-rw-r--r--net-dns/totd/files/totd38
-rw-r--r--net-dns/totd/files/totd-1.5.1-fix-CC.patch11
-rw-r--r--net-dns/totd/files/totd-1.5.1-no_werror.patch11
-rw-r--r--net-dns/totd/metadata.xml10
-rw-r--r--net-dns/totd/totd-1.5.1.ebuild40
-rw-r--r--profiles/package.mask5
7 files changed, 0 insertions, 116 deletions
diff --git a/net-dns/totd/Manifest b/net-dns/totd/Manifest
deleted file mode 100644
index 533c21b3b7ac..000000000000
--- a/net-dns/totd/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST totd-1.5.1.tar.gz 235809 BLAKE2B ceab2edbebe22162db7193a6e20b0ae2c960c1e613afc3a4ecf068c8f7f3d0f798d03d6c392955799c4fbd1fec10561502e4da08c4a5b39ce5d313a2c0e09663 SHA512 47087fd0478bc2952b25a0952ffb7273e4fdebda019f61fd0bad3c0305ab8f6e32b8f8dd042364f9ae6e6bd31c223e8fd3b17e3b4d44219fd6509f530f56025a
diff --git a/net-dns/totd/files/totd b/net-dns/totd/files/totd
deleted file mode 100644
index 79d410acb013..000000000000
--- a/net-dns/totd/files/totd
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need net
-}
-
-checkconfig() {
- if [ ! -f /etc/totd.conf ]
- then
- eerror "The config file /etc/totd.conf does not exist."
- return 1
- else
- return 0
- fi
-}
-
-start() {
- checkconfig || return 1
-
- ebegin "Starting totd"
- start-stop-daemon --start --quiet --exec /usr/sbin/totd
- eend $?
-}
-
-stop() {
- local pid_file
- pid_file="`grep ^pidfile /etc/totd.conf | cut -f2 -d ' '`"
- ebegin "Stopping totd"
- if [ -n "$pid_file" ]
- then
- start-stop-daemon --stop --quiet --pidfile $pid_file
- else
- start-stop-daemon --stop --quiet --pidfile /var/run/totd.pid
- fi
- eend $?
-}
diff --git a/net-dns/totd/files/totd-1.5.1-fix-CC.patch b/net-dns/totd/files/totd-1.5.1-fix-CC.patch
deleted file mode 100644
index 3ebbd419d0e2..000000000000
--- a/net-dns/totd/files/totd-1.5.1-fix-CC.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -4,7 +4,7 @@
- # <$Id: Makefile.in,v 3.43 2005/01/31 11:55:14 dillema Exp $>
- #
-
--CC = gcc
-+CC = @CC@
-
- # These use the standard autoconf variables, which by default are
- # rooted in @prefix@
diff --git a/net-dns/totd/files/totd-1.5.1-no_werror.patch b/net-dns/totd/files/totd-1.5.1-no_werror.patch
deleted file mode 100644
index 246e709d5109..000000000000
--- a/net-dns/totd/files/totd-1.5.1-no_werror.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- totd-1.5.1/Makefile.in 2005-01-31 12:55:14.000000000 +0100
-+++ totd-1.5.1_new/Makefile.in 2007-06-30 22:51:07.000000000 +0200
-@@ -19,7 +19,7 @@
-
- INSTALL = /usr/bin/install
-
--CFLAGS = @CFLAGS@ @DEFS@ -Werror -Wall -DTOTCONF=\"$(TOT_CONFIG_FILE)\" @OPTFLAGS@ $(INCLUDEPATH)
-+CFLAGS = @CFLAGS@ @DEFS@ -Wall -DTOTCONF=\"$(TOT_CONFIG_FILE)\" @OPTFLAGS@ $(INCLUDEPATH)
-
- # When debugging is enabled by --enable-malloc-debug flag to the configure
- # script, the @DBMALLOC@ substitution will contain the empty string, thus
diff --git a/net-dns/totd/metadata.xml b/net-dns/totd/metadata.xml
deleted file mode 100644
index 1dc73d3c7c92..000000000000
--- a/net-dns/totd/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription lang="en">
- Totd ( Trick Or Treat Daemon ) is a small DNS proxy nameserver that
- supports IPv6 only hosts/networks that communicate with the IPv4 world
- using some translation mechanism.
- </longdescription>
-</pkgmetadata>
diff --git a/net-dns/totd/totd-1.5.1.ebuild b/net-dns/totd/totd-1.5.1.ebuild
deleted file mode 100644
index c2661cc9ce63..000000000000
--- a/net-dns/totd/totd-1.5.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Trick Or Treat Daemon, a DNS proxy for 6to4"
-HOMEPAGE="http://www.dillema.net/software/totd.html"
-SRC_URI="http://www.dillema.net/software/${PN}/${P}.tar.gz"
-
-LICENSE="totd BSD BSD-4 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 x86"
-
-PATCHES=(
- "${FILESDIR}"/${P}-no_werror.patch
- "${FILESDIR}"/${P}-fix-CC.patch
-)
-
-src_configure() {
- econf \
- --enable-ipv4 \
- --enable-ipv6 \
- --enable-stf \
- --enable-scoped-rewrite \
- --disable-http-server
-}
-
-src_install() {
- dosbin totd
- doman totd.8
- dodoc totd.conf.sample README INSTALL
-
- doinitd "${FILESDIR}"/totd
-}
-
-pkg_postinst() {
- elog "The totd.conf.sample file in /usr/share/doc/${P}/ contains"
- elog "a sample config file for totd. Make sure you create"
- elog "/etc/totd.conf with the necessary configurations"
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index f3b9d9ec6e09..26c3d2a1269b 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -163,11 +163,6 @@ dev-python/pytest-virtualenv
# Removal on 2024-02-06. Bug #921576.
sys-devel/ucpp
-# John Helmert III <ajak@gentoo.org> (2024-01-06)
-# Unmaintained in Gentoo, outdated, and vulnerable
-# Removal on 2024-02-06. Bugs #856466, #865253
-net-dns/totd
-
# Andreas Sturmlechner <asturm@gentoo.org> (2023-12-25)
# Masked until KF6 is unmasked.
~media-libs/mpvqt-1.0.0