summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/pinfo/Manifest1
-rw-r--r--app-text/pinfo/pinfo-0.6.13.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-text/pinfo/Manifest b/app-text/pinfo/Manifest
index 7b4a67ec27e2..f6fcb600816c 100644
--- a/app-text/pinfo/Manifest
+++ b/app-text/pinfo/Manifest
@@ -1 +1,2 @@
DIST pinfo-0.6.10.tar.bz2 133059 BLAKE2B aaac23583510f42ac8a0c71a380f2bc76c4db6d78518bb4d5399c100bf0aec291c869576b18313e00f8572610cb967c3acb5f8d643c48f1295fd2efa8e16e3e6 SHA512 d3aeb93a668b939a2be7dd397ef5c918a8d108a1a7613ce39d4ef2faafbd549582a35d95c74c1dc74f4c86c9f2bf09b7bca7b5006c5a79302403dd906e8d376e
+DIST pinfo-0.6.13.tar.gz 157103 BLAKE2B 18af4a5ae1bbd2abccb174ce1a3a16e4d17207a10015042723c58f80695c2580ca0c1c60f4f6f4f08e67eb01316fe48cd848a887e65159a6cd4463eca14bdecd SHA512 739e24821a363a087fb9df5651694f051286d4a15c3e51f2421a2aa60b1efe1da558b959ba22a0094e22854534ea5875498156e8ea2e198e31001aecab1a18df
diff --git a/app-text/pinfo/pinfo-0.6.13.ebuild b/app-text/pinfo/pinfo-0.6.13.ebuild
new file mode 100644
index 000000000000..7ea70501a526
--- /dev/null
+++ b/app-text/pinfo/pinfo-0.6.13.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic
+
+DESCRIPTION="Hypertext info and man viewer based on (n)curses"
+HOMEPAGE="https://github.com/baszoetekouw/pinfo"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nls readline"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ nls? ( virtual/libintl )
+"
+
+DEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+ sys-devel/bison
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.9-GROFF_NO_SGR.patch
+ "${FILESDIR}"/${PN}-0.6.9-lzma-xz.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags -D_BSD_SOURCE -D_DEFAULT_SOURCE # sbrk()
+
+ econf \
+ $(use_with readline) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" sysconfdir="${EPREFIX}/etc" install
+}