summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/ctags/ctags-20220828.0-r1.ebuild (renamed from dev-util/ctags/ctags-20220828.0.ebuild)4
-rw-r--r--dev-util/ctags/ctags-99999999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/dev-util/ctags/ctags-20220828.0.ebuild b/dev-util/ctags/ctags-20220828.0-r1.ebuild
index ceadc8424f8a..22b038adf5a8 100644
--- a/dev-util/ctags/ctags-20220828.0.ebuild
+++ b/dev-util/ctags/ctags-20220828.0-r1.ebuild
@@ -21,12 +21,13 @@ fi
LICENSE="GPL-2+"
SLOT="0"
-IUSE="json pcre test xml yaml"
+IUSE="json pcre seccomp test xml yaml"
RESTRICT="!test? ( test )"
DEPEND="
json? ( dev-libs/jansson:= )
pcre? ( dev-libs/libpcre2 )
+ seccomp? ( sys-libs/libseccomp )
xml? ( dev-libs/libxml2:2 )
yaml? ( dev-libs/libyaml )
"
@@ -57,6 +58,7 @@ src_configure() {
econf \
$(use_enable json) \
$(use_enable pcre pcre2) \
+ $(use_enable seccomp) \
$(use_enable xml) \
$(use_enable yaml) \
--disable-etags \
diff --git a/dev-util/ctags/ctags-99999999.ebuild b/dev-util/ctags/ctags-99999999.ebuild
index ceadc8424f8a..22b038adf5a8 100644
--- a/dev-util/ctags/ctags-99999999.ebuild
+++ b/dev-util/ctags/ctags-99999999.ebuild
@@ -21,12 +21,13 @@ fi
LICENSE="GPL-2+"
SLOT="0"
-IUSE="json pcre test xml yaml"
+IUSE="json pcre seccomp test xml yaml"
RESTRICT="!test? ( test )"
DEPEND="
json? ( dev-libs/jansson:= )
pcre? ( dev-libs/libpcre2 )
+ seccomp? ( sys-libs/libseccomp )
xml? ( dev-libs/libxml2:2 )
yaml? ( dev-libs/libyaml )
"
@@ -57,6 +58,7 @@ src_configure() {
econf \
$(use_enable json) \
$(use_enable pcre pcre2) \
+ $(use_enable seccomp) \
$(use_enable xml) \
$(use_enable yaml) \
--disable-etags \