summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/rosconsole/Manifest1
-rw-r--r--dev-ros/rosconsole/rosconsole-1.14.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-ros/rosconsole/Manifest b/dev-ros/rosconsole/Manifest
index 41025165654a..b5f9fd638b57 100644
--- a/dev-ros/rosconsole/Manifest
+++ b/dev-ros/rosconsole/Manifest
@@ -1 +1,2 @@
DIST rosconsole-1.14.0.tar.gz 26166 BLAKE2B 79d73e5918eb5f3837e57e4207b3b42cc3222a92e8357265132d2d0848f966fa1e1aed69f8809af30497ef6b1f52c0de0073c20bf6e309010a8d98e0f745fb9c SHA512 68a5d709294b162d5b424bdbcd70fb66a43ccd8512bc60f571fe24bb0150e52f93addc3f22777c2f5810e95492265be58d3cfc6563a4e66665b3261ef161d5cd
+DIST rosconsole-1.14.2.tar.gz 26212 BLAKE2B b43f07f920a526c740d1ee8c3f5d7f5724ed617adad409df84001571e0df30df65c200bfc50c4c6a97a24642b3ad61340706ed4b6d14822935256bfb305350a3 SHA512 f1af112ada723195acda17edb64f75969a0abea58504d14507470eb36b0649e028cd675a368e040ddc955216da304dd64416fda8de7bc29dcd73c56c8286f311
diff --git a/dev-ros/rosconsole/rosconsole-1.14.2.ebuild b/dev-ros/rosconsole/rosconsole-1.14.2.ebuild
new file mode 100644
index 000000000000..76c9a71eb9d4
--- /dev/null
+++ b/dev-ros/rosconsole/rosconsole-1.14.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/rosconsole"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS console output library"
+LICENSE="BSD"
+SLOT="0"
+IUSE="+log4cxx glog"
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+ dev-ros/rosunit
+ dev-libs/boost:=[threads]
+ log4cxx? ( dev-libs/log4cxx )
+ !log4cxx? ( glog? ( dev-cpp/glog ) )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local ROSCONSOLE_BACKEND=""
+ if use log4cxx; then
+ ROSCONSOLE_BACKEND="log4cxx"
+ elif use glog; then
+ ROSCONSOLE_BACKEND="glog"
+ else
+ ROSCONSOLE_BACKEND="print"
+ fi
+ local mycatkincmakeargs=( "-DROSCONSOLE_BACKEND=${ROSCONSOLE_BACKEND}" )
+ ros-catkin_src_configure
+}