summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/python-memcached/python-memcached-1.58.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/python-memcached/python-memcached-1.58.ebuild b/dev-python/python-memcached/python-memcached-1.58.ebuild
index 15b5d2eda05c..979976df4e01 100644
--- a/dev-python/python-memcached/python-memcached-1.58.ebuild
+++ b/dev-python/python-memcached/python-memcached-1.58.ebuild
@@ -3,12 +3,14 @@
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_4 python3_5 pypy )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
inherit distutils-r1
DESCRIPTION="Pure python memcached client"
-HOMEPAGE="http://www.tummy.com/Community/software/python-memcached/ https://pypi.python.org/pypi/python-memcached"
+HOMEPAGE="
+ http://www.tummy.com/Community/software/python-memcached/
+ https://pypi.python.org/pypi/python-memcached"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="OSL-2.0"
@@ -16,7 +18,8 @@ SLOT="0"
KEYWORDS="amd64 ~arm64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE="test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
test? (
net-misc/memcached
dev-python/nose[${PYTHON_USEDEP}]