summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-board/mt_ncurses_client/files/mt_ncurses_client-0.1.98-format.patch11
-rw-r--r--games-board/mt_ncurses_client/mt_ncurses_client-0.1.98.ebuild6
2 files changed, 16 insertions, 1 deletions
diff --git a/games-board/mt_ncurses_client/files/mt_ncurses_client-0.1.98-format.patch b/games-board/mt_ncurses_client/files/mt_ncurses_client-0.1.98-format.patch
new file mode 100644
index 000000000000..e070a2348bc1
--- /dev/null
+++ b/games-board/mt_ncurses_client/files/mt_ncurses_client-0.1.98-format.patch
@@ -0,0 +1,11 @@
+--- src/player_client.c.old 2015-10-21 14:21:04.317896103 +0200
++++ src/player_client.c 2015-10-21 14:21:40.001225103 +0200
+@@ -38,7 +38,7 @@
+ {
+ player->nick[0] = g_string_new (config->player_name->str);
+
+- g_printerr (player->nick[0]->str);
++ g_printerr ("%s", player->nick[0]->str);
+
+ return 0;
+ }
diff --git a/games-board/mt_ncurses_client/mt_ncurses_client-0.1.98.ebuild b/games-board/mt_ncurses_client/mt_ncurses_client-0.1.98.ebuild
index 6341f8c3fd2e..a92f4356a2e1 100644
--- a/games-board/mt_ncurses_client/mt_ncurses_client-0.1.98.ebuild
+++ b/games-board/mt_ncurses_client/mt_ncurses_client-0.1.98.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI=5
-inherit games
+inherit games eutils
DESCRIPTION="client for the french tarot game maitretarot"
HOMEPAGE="http://www.nongnu.org/maitretarot/"
@@ -21,6 +21,10 @@ DEPEND="dev-libs/glib:2
sys-libs/ncurses"
RDEPEND=${DEPEND}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format.patch
+}
+
src_install() {
default
prepgamesdirs