summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/rhash/Manifest1
-rw-r--r--app-crypt/rhash/rhash-1.4.1.ebuild80
2 files changed, 0 insertions, 81 deletions
diff --git a/app-crypt/rhash/Manifest b/app-crypt/rhash/Manifest
index 33bc436cafeb..29794e046d24 100644
--- a/app-crypt/rhash/Manifest
+++ b/app-crypt/rhash/Manifest
@@ -1,3 +1,2 @@
DIST rhash-1.3.6-src.tar.gz 328097 BLAKE2B c74993d183f0f2e479f0bd5831a9f653b9bd17bbed4d1ba896f6e33db98b7141175cd3c688dc41dfd8ec4b98acb51255ae5b795435cbc9dfb5ab77573cb25543 SHA512 54f7f238ed1fdc01c29cc1338fa86be90b69beff0df8f20d24ce9cb3c48c7f4668b84a3fe0d4d8b04b54bc8145485d493435edf3219de3a637af0f9c007c85c6
-DIST rhash-1.4.1-src.tar.gz 413274 BLAKE2B 2027bccc677e8a1766f0624e67f475713653ddb4be457f9c8434c45019bc730934ca860e69f8b8e1fec349e724b1a366df0f5fb98501c825b44f9b8105068ff7 SHA512 30bbef7ce7815ee4ac062c537206a0b895845f61de4b1fdc0c0494f66284d9f3c1b06f812ea913fa35a3342d230d25d0986a1db644c7b4464bc1185997beb638
DIST rhash-1.4.2-src.tar.gz 416853 BLAKE2B 06322825116cb00aa4987b01610d967eb57c94aa29b43348ec2c31f053fd471a900fcee776714263213e9a79eaf389b2e79d7b34a5afd3e98d68198193b5cbe7 SHA512 41df57e8b3f32c93d8e6f2ac668b32aaa23eb2eaf90a83f109e61e511404a5036ea88bcf2854e19c1ade0f61960e0d9edf01f3d82e1c645fed36579e9d7a6a25
diff --git a/app-crypt/rhash/rhash-1.4.1.ebuild b/app-crypt/rhash/rhash-1.4.1.ebuild
deleted file mode 100644
index 4aa5c894ec98..000000000000
--- a/app-crypt/rhash/rhash-1.4.1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs multilib-minimal
-
-DESCRIPTION="Console utility and library for computing and verifying file hash sums"
-HOMEPAGE="http://rhash.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug nls ssl static-libs"
-
-RDEPEND="
- ssl? (
- dev-libs/openssl:0=[${MULTILIB_USEDEP}]
-)"
-
-DEPEND="
- ${RDEPEND}
-"
-
-BDEPEND="
- nls? ( sys-devel/gettext )
-"
-
-S="${WORKDIR}/RHash-${PV}"
-
-src_prepare() {
- default
-
- if [[ ${CHOST} == *-darwin* && ${CHOST##*darwin} -le 9 ]] ; then
- # we lack posix_memalign
- sed -i -e '/if _POSIX_VERSION/s/if .*$/if 0/' \
- librhash/util.h || die
- fi
-
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- set -- \
- ./configure \
- --target="${CHOST}" \
- --cc="$(tc-getCC)" \
- --ar="$(tc-getAR)" \
- --extra-cflags="${CFLAGS}" \
- --extra-ldflags="${LDFLAGS}" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --sysconfdir="${EPREFIX}"/etc \
- --disable-openssl-runtime \
- --disable-static \
- --enable-lib-shared \
- $(use_enable debug) \
- $(use_enable nls gettext) \
- $(use_enable ssl openssl) \
- $(use_enable static-libs lib-static)
-
- echo "${@}"
- "${@}" || die "configure failed"
-}
-
-# We would add compile-gmo to the build targets but install-gmo always
-# recompiles unconditionally. :(
-
-multilib_src_install() {
- # -j1 needed due to race condition.
- emake DESTDIR="${D}" -j1 \
- install{,-lib-headers,-pkg-config} \
- $(use nls && echo install-gmo) \
- $(use kernel_Winnt || echo install-lib-so-link)
-}
-
-multilib_src_test() {
- emake test
-}