summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-action/maelstrom/files/maelstrom-3.0.6-64bits.patch4
-rw-r--r--games-action/maelstrom/files/maelstrom-3.0.6-warnings.patch4
-rw-r--r--games-action/maelstrom/maelstrom-3.0.6-r3.ebuild72
3 files changed, 76 insertions, 4 deletions
diff --git a/games-action/maelstrom/files/maelstrom-3.0.6-64bits.patch b/games-action/maelstrom/files/maelstrom-3.0.6-64bits.patch
index bdf04d3ad30d..7d6f59a5ac26 100644
--- a/games-action/maelstrom/files/maelstrom-3.0.6-64bits.patch
+++ b/games-action/maelstrom/files/maelstrom-3.0.6-64bits.patch
@@ -1,5 +1,5 @@
---- screenlib/SDL_FrameBuf.cpp.old 2006-10-25 22:37:21.000000000 +0200
-+++ screenlib/SDL_FrameBuf.cpp 2006-10-25 22:38:26.000000000 +0200
+--- a/screenlib/SDL_FrameBuf.cpp 2006-10-25 22:37:21.000000000 +0200
++++ b/screenlib/SDL_FrameBuf.cpp 2006-10-25 22:38:26.000000000 +0200
@@ -847,10 +847,8 @@
/* Update the dirty rectangle map with the new list */
for ( i=0; i<dirtymaplen; ++i ) {
diff --git a/games-action/maelstrom/files/maelstrom-3.0.6-warnings.patch b/games-action/maelstrom/files/maelstrom-3.0.6-warnings.patch
index aa374b096c32..8b2ca084c65f 100644
--- a/games-action/maelstrom/files/maelstrom-3.0.6-warnings.patch
+++ b/games-action/maelstrom/files/maelstrom-3.0.6-warnings.patch
@@ -1,5 +1,5 @@
---- Maelstrom-netd.c.orig 2014-03-18 01:00:28.408099526 -0400
-+++ Maelstrom-netd.c 2014-03-18 01:01:29.892142782 -0400
+--- a/Maelstrom-netd.c 2014-03-18 01:00:28.408099526 -0400
++++ b/Maelstrom-netd.c 2014-03-18 01:01:29.892142782 -0400
@@ -1,7 +1,9 @@
/* Here we go... */
diff --git a/games-action/maelstrom/maelstrom-3.0.6-r3.ebuild b/games-action/maelstrom/maelstrom-3.0.6-r3.ebuild
new file mode 100644
index 000000000000..095e0a2e39b9
--- /dev/null
+++ b/games-action/maelstrom/maelstrom-3.0.6-r3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils user
+
+MY_P=Maelstrom-${PV}
+DESCRIPTION="An asteroids battle game"
+HOMEPAGE="http://www.libsdl.org/projects/Maelstrom/"
+SRC_URI="http://www.libsdl.org/projects/Maelstrom/src/${MY_P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-net"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-security.patch
+ "${FILESDIR}"/${P}-64bits.patch
+ "${FILESDIR}"/${P}-gcc34.patch
+ "${FILESDIR}"/${P}-warnings.patch
+ "${FILESDIR}"/${P}-gcc53.patch
+)
+
+pkg_setup(){
+ enewgroup gamestat 36
+}
+
+src_prepare() {
+ default
+
+ # Install the data into $(datadir)/..., not $(prefix)/games/...
+ sed -i \
+ -e "s:(prefix)/games/:(datadir)/:" configure.in || die
+ sed -i \
+ -e '/make install_gamedata/ { s:=:=$(DESTDIR)/:; s/make/$(MAKE)/; s/install_gamedata/install-binPROGRAMS install_gamedata/; }' Makefile.am || die
+ # Install the high scores file in ${GAMES_STATEDIR}
+ sed -i \
+ -e "s:path.Path(MAELSTROM_SCORES):\"/var/games/\"MAELSTROM_SCORES:" scores.cpp || die
+ mv configure.{in,ac}
+ rm aclocal.m4 acinclude.m4
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc Changelog Docs/{Maelstrom-Announce,*FAQ,MaelstromGPL_press_release,*.Paper,Technical_Notes*}
+
+ newicon "${D}/usr/share/Maelstrom/icon.xpm" maelstrom.xpm
+ make_desktop_entry Maelstrom "Maelstrom" maelstrom
+
+ # Put the high scores file in the right place
+ insinto /var/games
+ doins "${D}/usr/share/Maelstrom/Maelstrom-Scores"
+
+ # clean up some cruft
+ rm -f \
+ "${D}/usr/share/Maelstrom/Maelstrom-Scores" \
+ "${D}/usr/share/Maelstrom/Images/Makefile*"
+
+ # make sure we can update the high scores
+ fowners root:gamestat /var/games/Maelstrom-Scores /usr/bin/Maelstrom{,-netd}
+ fperms 2755 /usr/bin/Maelstrom{,-netd}
+ fperms 660 /var/games/Maelstrom-Scores
+}