summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pypy/pypy-7.3.6_rc1.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/pypy/pypy-7.3.6_rc1.ebuild b/dev-python/pypy/pypy-7.3.6_rc1.ebuild
index d4372953f882..c4b76dcdef06 100644
--- a/dev-python/pypy/pypy-7.3.6_rc1.ebuild
+++ b/dev-python/pypy/pypy-7.3.6_rc1.ebuild
@@ -56,6 +56,10 @@ src_compile() {
mv pypy/module/cpyext/parse/*.h include/ || die
pax-mark m pypy-c
+ # verify the subslot
+ local soabi=$(./pypy-c -c 'import sysconfig; print sysconfig.get_config_var("SOABI")')
+ [[ ${soabi#pypy-} == ${SLOT#*/} ]] || die "update subslot to ${soabi}"
+
einfo "Generating caches and CFFI modules ..."
# Generate Grammar and PatternGrammar pickles.