summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-vcs/gitsh/Manifest1
-rw-r--r--dev-vcs/gitsh/gitsh-0.11.2.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-vcs/gitsh/Manifest b/dev-vcs/gitsh/Manifest
index df7028e59d8f..317131275e2a 100644
--- a/dev-vcs/gitsh/Manifest
+++ b/dev-vcs/gitsh/Manifest
@@ -1 +1,2 @@
DIST gitsh-0.10.tar.gz 57550 SHA256 a5b07c44d68700c6e41681c838625650dbe1313f2bbe0976a3ee30086b4d5f93 SHA512 e51858c62e31e6b3644fb7239e6ffb7e8ffc7dd9983d67f792f739fd3459a8741d29f67709738127754454ff1e0f87014f8eb77cfd506cc5d32c5d9c719b2b16 WHIRLPOOL daac99aa5fef26652e606de5039e00be0d25579c3045e9eb5f4c2195ae34ec038408e29f8c55fdde7b9bef7ad1b3aab31aade2e5a03b60a8bbe46ccd0cf515b1
+DIST gitsh-0.11.2.tar.gz 101503 SHA256 45572b528900bebf5fa2b81e3b04572cbf34dbfee3b17281a1c750ec9518533f SHA512 e8d473b4a13481722eb9a6b9232eb47174ed40f86af45848f33b9b936f09cf2010f8235036d9897bd637b841f35d051d3e426b56642f247b07c3a0d323e9a968 WHIRLPOOL 6d5da503e4f4df3211fc38552d35ce9bd2189bd10430acd234a701a413dc806c2ca4cd3aae2b55fc28d74f82f296ad7a862e72c3629e6c0383bd629c236065ec
diff --git a/dev-vcs/gitsh/gitsh-0.11.2.ebuild b/dev-vcs/gitsh/gitsh-0.11.2.ebuild
new file mode 100644
index 000000000000..cd7ef1442f6a
--- /dev/null
+++ b/dev-vcs/gitsh/gitsh-0.11.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit autotools ruby-fakegem
+
+DESCRIPTION="An interactive shell for git"
+HOMEPAGE="https://github.com/thoughtbot/gitsh"
+SRC_URI="https://github.com/thoughtbot/gitsh/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~amd64-linux"
+IUSE="test"
+
+RDEPEND+=" sys-libs/readline "
+
+DEPEND+=" test? ( dev-vcs/git ) "
+
+ruby_add_rdepend "
+ dev-ruby/bundler
+ dev-ruby/parslet
+ "
+
+ruby_add_bdepend "test? ( dev-ruby/pry )"
+
+DOCS="README.md"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+
+ # Avoid integration tests that assume they can use /usr/bin/ruby
+ rm -f spec/integration/running_scripts_spec.rb || die
+ # or the TTY
+ sed -i -e '/with valid arguments and no script file/,/^ end/ s:^:#:' spec/units/cli_spec.rb || die
+}
+
+each_ruby_prepare() {
+ eautoreconf
+
+ if use test; then
+ git init . || die
+ fi
+}
+
+each_ruby_configure() {
+ RUBY=${RUBY} default
+}
+
+each_ruby_compile() {
+ default
+}
+
+all_ruby_install() {
+ all_fakegem_install
+ doman "${S}"/man/man1/${PN}.1
+}