summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/opencl-headers/opencl-headers-2020.03.13-r1.ebuild (renamed from dev-util/opencl-headers/opencl-headers-2020.03.13.ebuild)15
1 files changed, 6 insertions, 9 deletions
diff --git a/dev-util/opencl-headers/opencl-headers-2020.03.13.ebuild b/dev-util/opencl-headers/opencl-headers-2020.03.13-r1.ebuild
index 0c64e9cc994a..917c0cad3500 100644
--- a/dev-util/opencl-headers/opencl-headers-2020.03.13.ebuild
+++ b/dev-util/opencl-headers/opencl-headers-2020.03.13-r1.ebuild
@@ -3,8 +3,6 @@
EAPI=7
-inherit multilib-minimal
-
MY_PN="OpenCL-Headers"
MY_P="${MY_PN}-${PV}"
@@ -16,14 +14,13 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+# To avoid file collisions in /usr/include/CL/
+DEPEND="!app-eselect/eselect-opencl"
+RDEPEND="${DEPEND}"
+
S="${WORKDIR}/${MY_P}"
-multilib_src_install() {
- # Ideally we would install these directly into /usr/include but that would conflict
- # with eselect-opencl, therefore we install these into the vendor directory used by
- # dev-libs/opencl-icd-loader. Hopefully we will get this resolved soon and we can
- # stop messing with multilib in this package.
- local ocl_dir="/usr/$(get_libdir)/OpenCL/vendors/opencl-icd-loader"
- insinto "${ocl_dir}"/include
+src_install() {
+ insinto /usr/include
doins -r "${S}"/CL
}