summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/zchunk/Manifest1
-rw-r--r--app-arch/zchunk/metadata.xml15
-rw-r--r--app-arch/zchunk/zchunk-1.2.3.ebuild27
-rw-r--r--app-arch/zchunk/zchunk-9999.ebuild27
4 files changed, 70 insertions, 0 deletions
diff --git a/app-arch/zchunk/Manifest b/app-arch/zchunk/Manifest
new file mode 100644
index 000000000000..83cda674af89
--- /dev/null
+++ b/app-arch/zchunk/Manifest
@@ -0,0 +1 @@
+DIST zchunk-1.2.3.tar.gz 1508271 BLAKE2B 7432289f3730083d0634c32f03d1daf2570c21e94ebab0aabeee4527f7ba56aef5cc567dfdb8ede701bea5d0cda4f248f0cf0fdb04e4f5ee1effb888a2907ec9 SHA512 5e46d8c3e36034de8424937cdfac59acdfaf332203e6e5d8b290614cbbe0340998d53b0583b0ef93189f41dc89219a75f50572757ebcea9abd83bd9aad861a73
diff --git a/app-arch/zchunk/metadata.xml b/app-arch/zchunk/metadata.xml
new file mode 100644
index 000000000000..40e1e399be6c
--- /dev/null
+++ b/app-arch/zchunk/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>Matt.Jolly@footclan.ninja</email>
+ <name>Matt Jolly</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">zchunk/zchunk</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/zchunk/zchunk-1.2.3.ebuild b/app-arch/zchunk/zchunk-1.2.3.ebuild
new file mode 100644
index 000000000000..76677dce82f5
--- /dev/null
+++ b/app-arch/zchunk/zchunk-1.2.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="File format designed for highly efficient deltas with good compression"
+HOMEPAGE="https://github.com/zchunk/zchunk"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zchunk/zchunk.git"
+else
+ SRC_URI="https://github.com/zchunk/zchunk/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+DEPEND="
+ app-arch/zstd:=
+ net-misc/curl
+ dev-libs/openssl:=
+"
+RDEPEND="${DEPEND}"
diff --git a/app-arch/zchunk/zchunk-9999.ebuild b/app-arch/zchunk/zchunk-9999.ebuild
new file mode 100644
index 000000000000..76677dce82f5
--- /dev/null
+++ b/app-arch/zchunk/zchunk-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="File format designed for highly efficient deltas with good compression"
+HOMEPAGE="https://github.com/zchunk/zchunk"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zchunk/zchunk.git"
+else
+ SRC_URI="https://github.com/zchunk/zchunk/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+DEPEND="
+ app-arch/zstd:=
+ net-misc/curl
+ dev-libs/openssl:=
+"
+RDEPEND="${DEPEND}"