summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/parole/parole-1.0.0.ebuild10
-rw-r--r--media-video/parole/parole-1.0.1.ebuild10
-rw-r--r--profiles/base/package.use.mask6
3 files changed, 6 insertions, 20 deletions
diff --git a/media-video/parole/parole-1.0.0.ebuild b/media-video/parole/parole-1.0.0.ebuild
index 19fa3b98c738..09bfa0b3870f 100644
--- a/media-video/parole/parole-1.0.0.ebuild
+++ b/media-video/parole/parole-1.0.0.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~mips x86"
-IUSE="clutter libnotify taglib"
+IUSE="libnotify taglib"
COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
>=dev-libs/glib-2.32:2=
@@ -24,11 +24,6 @@ COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
>=xfce-base/libxfce4ui-4.11:0=[gtk3(+)]
>=xfce-base/libxfce4util-4.11:0=
>=xfce-base/xfconf-4.10:0=
- clutter? (
- >=media-libs/clutter-1.16.4:1.0=
- >=media-libs/clutter-gtk-1.4.4:1.0=
- <x11-libs/gtk+-3.22:3
- )
libnotify? ( >=x11-libs/libnotify-0.7:0= )
taglib? ( >=media-libs/taglib-1.6:0= )"
RDEPEND="${COMMON_DEPEND}
@@ -43,7 +38,8 @@ DOCS=( AUTHORS ChangeLog README THANKS TODO )
src_configure() {
local myconf=(
- $(use_enable clutter)
+ # clutter backend does not work with new GTK+3 versions
+ --disable-clutter
$(use_enable taglib)
$(use_enable libnotify notify-plugin)
)
diff --git a/media-video/parole/parole-1.0.1.ebuild b/media-video/parole/parole-1.0.1.ebuild
index 6bc14f9e8690..e25d25434825 100644
--- a/media-video/parole/parole-1.0.1.ebuild
+++ b/media-video/parole/parole-1.0.1.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~mips ~x86"
-IUSE="clutter libnotify taglib"
+IUSE="libnotify taglib"
COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
>=dev-libs/glib-2.32:2=
@@ -24,11 +24,6 @@ COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
>=xfce-base/libxfce4ui-4.11:0=[gtk3(+)]
>=xfce-base/libxfce4util-4.11:0=
>=xfce-base/xfconf-4.10:0=
- clutter? (
- >=media-libs/clutter-1.16.4:1.0=
- >=media-libs/clutter-gtk-1.4.4:1.0=
- <x11-libs/gtk+-3.22:3
- )
libnotify? ( >=x11-libs/libnotify-0.7:0= )
taglib? ( >=media-libs/taglib-1.6:0= )"
RDEPEND="${COMMON_DEPEND}
@@ -43,7 +38,8 @@ DOCS=( AUTHORS ChangeLog README THANKS TODO )
src_configure() {
local myconf=(
- $(use_enable clutter)
+ # clutter backend does not work with new GTK+3 versions
+ --disable-clutter
$(use_enable taglib)
$(use_enable libnotify notify-plugin)
)
diff --git a/profiles/base/package.use.mask b/profiles/base/package.use.mask
index 71ee01400fd4..e2ac9d936519 100644
--- a/profiles/base/package.use.mask
+++ b/profiles/base/package.use.mask
@@ -186,12 +186,6 @@ www-plugins/gnash vaapi
sys-boot/gnu-efi custom-cflags
sys-boot/refind custom-cflags
-# Michał Górny <mgorny@gentoo.org> (8 Jul 2017)
-# The clutter backend is broken with new GTK+3 versions and upstream
-# haven't been able to fix it so far. Enforcing an old GTK+3 version
-# is not a good solution long-term, so mask the flag entirely.
-media-video/parole clutter
-
# Michał Górny <mgorny@gentoo.org> (29 Jun 2017)
# Upstream switched to CMake and no longer provides option to build
# static and shared libs. The flag is preserved not to break USE