summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mail/mswatch/files/mswatch-1.2.0-gcc6.patch12
-rw-r--r--net-mail/mswatch/mswatch-1.2.0-r1.ebuild (renamed from net-mail/mswatch/mswatch-1.2.0.ebuild)29
2 files changed, 30 insertions, 11 deletions
diff --git a/net-mail/mswatch/files/mswatch-1.2.0-gcc6.patch b/net-mail/mswatch/files/mswatch-1.2.0-gcc6.patch
new file mode 100644
index 000000000000..2b4fa4ce5d2b
--- /dev/null
+++ b/net-mail/mswatch/files/mswatch-1.2.0-gcc6.patch
@@ -0,0 +1,12 @@
+--- mswatch-1.2.0/src/lib/util.h.old 2016-09-23 19:09:54.195069503 -0400
++++ mswatch-1.2.0/src/lib/util.h 2016-09-23 19:10:04.663460768 -0400
+@@ -21,9 +21,6 @@
+
+ void drain_fd(int fd);
+
+-// static assert, for compile-time assertion checking
+-#define static_assert(x) switch (x) case 0: case (x):
+-
+ __END_DECLS
+
+
diff --git a/net-mail/mswatch/mswatch-1.2.0.ebuild b/net-mail/mswatch/mswatch-1.2.0-r1.ebuild
index 7f4ba1a6d786..06d3a3d17125 100644
--- a/net-mail/mswatch/mswatch-1.2.0.ebuild
+++ b/net-mail/mswatch/mswatch-1.2.0-r1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
-
-inherit linux-info autotools-utils
+EAPI=6
+inherit linux-info ltprune
DESCRIPTION="A utility to watch mailstores for changes and initiate mailbox syncs"
HOMEPAGE="http://mswatch.sourceforge.net/"
@@ -16,17 +15,25 @@ IUSE="static-libs"
RDEPEND=">=dev-libs/glib-2.6:2"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
CONFIG_CHECK="~INOTIFY_USER"
ERROR_INOTIFY_USER="${P} requires in-kernel inotify support."
-DOCS=( AUTHORS NEWS README THANKS TODO )
-PATCHES=( "${FILESDIR}"/${P}-gcc47.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc47.patch
+ "${FILESDIR}"/${P}-gcc6.patch
+)
src_configure() {
- local myeconfargs=(
- --with-notify=inotify
- )
- autotools-utils_src_configure
+ econf \
+ --with-notify=inotify \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
}