summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/argp-standalone/argp-standalone-1.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-libs/argp-standalone/argp-standalone-1.3-r1.ebuild b/sys-libs/argp-standalone/argp-standalone-1.3-r1.ebuild
new file mode 100644
index 000000000000..17c1c57b000b
--- /dev/null
+++ b/sys-libs/argp-standalone/argp-standalone-1.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Standalone argp library for use with uclibc"
+HOMEPAGE="http://www.lysator.liu.se/~nisse/misc/"
+SRC_URI="http://www.lysator.liu.se/~nisse/misc/argp-standalone-1.3.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~mips ~ppc ~s390 ~sh ~x86"
+IUSE=""
+
+DEPEND="!sys-libs/glibc"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-throw-in-funcdef.patch"
+}
+
+src_configure() {
+ append-cflags -fgnu89-inline
+ default
+}
+
+src_install() {
+ dolib.a libargp.a
+
+ insinto /usr/include
+ doins argp.h
+}