summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/ptpython/ptpython-0.33.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/ptpython/ptpython-0.33.ebuild b/dev-python/ptpython/ptpython-0.33.ebuild
deleted file mode 100644
index 1f10534638a1..000000000000
--- a/dev-python/ptpython/ptpython-0.33.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_5 )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Python REPL build on top of prompt_toolkit"
-HOMEPAGE="https://pypi.org/project/ptpython/ https://github.com/jonathanslenders/ptpython"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="
- dev-python/docopt[${PYTHON_USEDEP}]
- >=dev-python/jedi-0.9.0[${PYTHON_USEDEP}]
- >=dev-python/prompt_toolkit-0.58[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-# Not included
-RESTRICT=test
-
-python_test() {
- "${PYTHON}" tests/run_tests.py || die
-}