summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/jaxb-api/jaxb-api-2.3.3-r1.ebuild50
-rw-r--r--dev-java/jaxb-api/jaxb-api-3.0.1-r1.ebuild38
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-java/jaxb-api/jaxb-api-2.3.3-r1.ebuild b/dev-java/jaxb-api/jaxb-api-2.3.3-r1.ebuild
new file mode 100644
index 000000000000..8e24eccaf3cd
--- /dev/null
+++ b/dev-java/jaxb-api/jaxb-api-2.3.3-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/eclipse-ee4j/jaxb-api/archive/refs/tags/2.3.3.tar.gz --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild jaxb-api-2.3.3.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="jakarta.xml.bind:jakarta.xml.bind-api:2.3.3"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Jakarta XML Binding API"
+HOMEPAGE="https://github.com/eclipse-ee4j/jaxb-api"
+SRC_URI="https://github.com/eclipse-ee4j/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Common dependencies
+# POM: pom.xml
+# jakarta.activation:jakarta.activation-api:1.2.2 -> >=dev-java/jakarta-activation-api-2.0.1:0
+# jakarta.xml.bind:jakarta.xml.bind-api:2.3.3 -> >=dev-java/jaxb-api-2.3.3:0
+
+CDEPEND="dev-java/jakarta-activation-api:1"
+DEPEND="${CDEPEND}
+ >=virtual/jdk-11:*"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.8:*"
+
+DOCS=( ../{LICENSE,NOTICE,README}.md )
+
+S="${WORKDIR}/${P}/${PN}"
+
+JAVA_GENTOO_CLASSPATH="jakarta-activation-api-1"
+JAVA_GENTOO_CLASSPATH_EXTRA="jaxb-api.jar"
+JAVA_SRC_DIR="src/main/java"
+JAVA_RESOURCE_DIRS="src/main/resources"
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="../${PN}-test/src/test/java"
+JAVA_TEST_RESOURCE_DIRS="../${PN}-test/src/test/resources"
+
+src_install() {
+ default
+ java-pkg-simple_src_install
+}
diff --git a/dev-java/jaxb-api/jaxb-api-3.0.1-r1.ebuild b/dev-java/jaxb-api/jaxb-api-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..6b3427db5392
--- /dev/null
+++ b/dev-java/jaxb-api/jaxb-api-3.0.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/eclipse-ee4j/jaxb-api/archive/refs/tags/3.0.1.tar.gz --slot 2 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild jaxb-api-3.0.1.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="jakarta.xml.bind:jakarta.xml.bind-api:3.0.1"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Jakarta XML Binding API"
+HOMEPAGE="https://github.com/eclipse-ee4j/jaxb-api/jakarta.xml.bind-api"
+SRC_URI="https://github.com/eclipse-ee4j/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Common dependencies
+# POM: pom.xml
+# com.sun.activation:jakarta.activation:2.0.1 -> >=dev-java/jakarta-activation-2.0.1:2
+
+CDEPEND="dev-java/jakarta-activation:2"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-11:*"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.8:*"
+
+S="${WORKDIR}/${P}/${PN}"
+
+JAVA_GENTOO_CLASSPATH="jakarta-activation-2"
+JAVA_SRC_DIR="src/main/java"
+JAVA_RESOURCE_DIRS="src/main/resources"