summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/nanoc/Manifest1
-rw-r--r--www-apps/nanoc/nanoc-4.9.6.ebuild93
2 files changed, 0 insertions, 94 deletions
diff --git a/www-apps/nanoc/Manifest b/www-apps/nanoc/Manifest
index 3a63302a211a..11bfa7b27fa7 100644
--- a/www-apps/nanoc/Manifest
+++ b/www-apps/nanoc/Manifest
@@ -1,3 +1,2 @@
DIST nanoc-4.10.4.tar.gz 290367 BLAKE2B 0b5cf03938af1f971fccddb6bed4fa6b67da3aaf93cb7666c52e3ff8fc524f17ff10bf1a60ccf7f7b59f840d4c445ef57677349f5b83bc55e754e7078ac4b8d9 SHA512 5446e351906b5b6bbe5c9059dab86490d5deef5e1197adf5827fe201f2932d5cf79c65bfd9d9370ce57c35d965e013098d39d53fa96db8b4d1c6017977683ea2
DIST nanoc-4.11.0.tar.gz 291654 BLAKE2B ab88bf36b472106f356ae67782dac61f691e0d64646f410ae0cceca7a9df11689dd7a011bf58a773d6b35956f0092deac4db43bb8663d66463b72e10da27c658 SHA512 357345c9247465bd470bf6c71ea2b16e3415680fad6a4d4ee755eeb3a1443664590753003a5de0a740ffcfbaf93049c2c12c1f22de052f4d6efc2382430a4e08
-DIST nanoc-4.9.6.tar.gz 282811 BLAKE2B 109b73e4908b45c055912f6e3b2d18675ee00dd848cf7b84197d1a53c30d5862183dcdbd917f1f6f235f97dc5d33b36ba423f34b72bb83ca6f9f2fda4f0081b3 SHA512 67b2df683c4becfbb9a64462b053544c68117c2459fce8e5941f8415c79f1ec73e9c386622dfdb201cf5473f6b83ff1b1444b6492d247036e696d3761e4589ce
diff --git a/www-apps/nanoc/nanoc-4.9.6.ebuild b/www-apps/nanoc/nanoc-4.9.6.ebuild
deleted file mode 100644
index 9e6642788b8f..000000000000
--- a/www-apps/nanoc/nanoc-4.9.6.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24"
-
-RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="nanoc is a simple but very flexible static site generator written in Ruby"
-HOMEPAGE="https://nanoc.ws/"
-SRC_URI="https://github.com/nanoc/nanoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE="${IUSE} minimal"
-
-DEPEND+="test? ( app-text/asciidoc app-text/highlight )"
-
-RUBY_S="${P}/nanoc"
-
-ruby_add_rdepend "!minimal? (
- dev-ruby/mime-types:*
- dev-ruby/rack:*
- www-servers/adsf
-)
- >=dev-ruby/addressable-2.5
- >=dev-ruby/cri-2.13:0
- dev-ruby/ddmemoize:1
- dev-ruby/ddmetrics:1
- dev-ruby/ddplugin:1
- =dev-ruby/hamster-3*
- >=dev-ruby/parallel-1.12:1
- dev-ruby/ref:2
- >=dev-ruby/slow_enumerator_tools-1.1.0:1
- >=dev-ruby/tomlrb-1.2:1"
-
-ruby_add_bdepend "test? (
- dev-ruby/rspec:3
- dev-ruby/asciidoctor
- dev-ruby/fuubar
- dev-ruby/maruku
- >=dev-ruby/mocha-0.13
- dev-ruby/minitest
- dev-ruby/pry
- dev-ruby/rdoc
- dev-ruby/rouge:2
- dev-ruby/systemu
- dev-ruby/timecop
- dev-ruby/vcr
- dev-ruby/webmock
- dev-ruby/yard
-)
-doc? (
- dev-ruby/kramdown
- dev-ruby/rdiscount
- dev-ruby/yard
-)"
-
-all_ruby_prepare() {
- # Avoid unneeded development dependencies
- sed -i -e '/simplecov/,/SimpleCov.formatter/ s:^:#:' test/helper.rb || die
- sed -i -e '/simplecov/I s:^:#:' \
- -e '/codecov/I s:^:#:' ../common/spec/spec_helper_head.rb || die
- sed -i -e '/coverall/I s:^:#:' \
- -e '/rubocop/ s:^:#:' Rakefile || die
-
- echo "-r ./spec/spec_helper.rb" > .rspec || die
-
- # Avoid tests requiring a network connection
- rm -f test/checking/checks/test_{css,html}.rb || die
-
- # Avoid tests for unpackaged dependencies
- rm spec/nanoc/deploying/fog_spec.rb \
- spec/nanoc/filters/less_spec.rb \
- test/filters/test_{markaby,rainpress}.rb || die
-
- # Use useable tmp dir
- sed -i -e 's:/tmp/whatever:'${T}'/whatever:' spec/nanoc/base/checksummer_spec.rb || die
-
- # Avoid non-fatal failing tests due to specifics in the environment
- sed -i -e '145askip "gentoo"' spec/nanoc/cli/error_handler_spec.rb || die
- sed -i -e '/does not crash when output dir does not exist and/askip "gentoo"' spec/nanoc/cli/commands/view_spec.rb || die
- sed -i -e '/watches with --watch/askip "gentoo"' spec/nanoc/cli/commands/compile_spec.rb || die
-}
-
-each_ruby_test() {
- RUBYLIB="${S}/lib" ${RUBY} -S rake spec test_all || die
-}