summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.9.3-paxmark-mksnapshot.patch41
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.9.3.ebuild2
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.9.3-paxmark-mksnapshot.patch b/dev-qt/qtwebengine/files/qtwebengine-5.9.3-paxmark-mksnapshot.patch
new file mode 100644
index 000000000000..ecedaf62f344
--- /dev/null
+++ b/dev-qt/qtwebengine/files/qtwebengine-5.9.3-paxmark-mksnapshot.patch
@@ -0,0 +1,41 @@
+Bug: https://bugs.gentoo.org/634220
+
+--- a/src/3rdparty/chromium/v8/BUILD.gn
++++ b/src/3rdparty/chromium/v8/BUILD.gn
+@@ -661,6 +661,7 @@ action("run_mksnapshot") {
+
+ deps = [
+ ":mksnapshot($v8_snapshot_toolchain)",
++ ":run_paxmark",
+ ]
+
+ script = "tools/run.py"
+@@ -706,6 +707,28 @@ action("run_mksnapshot") {
+ args += [ rebase_path(v8_embed_script, root_build_dir) ]
+ }
+ }
++action("run_paxmark") {
++ visibility = [ ":*" ] # Only targets in this file can depend on this.
++
++ deps = [
++ ":mksnapshot($v8_snapshot_toolchain)",
++ ]
++
++ script = "/usr/sbin/pypaxctl"
++
++ sources = []
++
++ outputs = [
++ "$target_out_dir/mksnapshot",
++ ]
++
++ args = [
++ "-sm",
++ "./" + rebase_path(get_label_info(":mksnapshot($v8_snapshot_toolchain)",
++ "root_out_dir") + "/mksnapshot",
++ root_build_dir),
++ ]
++}
+
+ action("run_mkpeephole") {
+ visibility = [ ":*" ] # Only targets in this file can depend on this.
diff --git a/dev-qt/qtwebengine/qtwebengine-5.9.3.ebuild b/dev-qt/qtwebengine/qtwebengine-5.9.3.ebuild
index afb0d89df444..b0e35e0db275 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.9.3.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.9.3.ebuild
@@ -76,7 +76,7 @@ DEPEND="${RDEPEND}
PATCHES=( "${FILESDIR}/${P}-icu-60.1.patch" )
src_prepare() {
- use pax_kernel && PATCHES+=( "${FILESDIR}/${PN}-5.9.0-paxmark-mksnapshot.patch" )
+ use pax_kernel && PATCHES+=( "${FILESDIR}/${PN}-5.9.3-paxmark-mksnapshot.patch" )
# bug 620444 - ensure local headers are used
find "${S}" -type f -name "*.pr[fio]" | xargs sed -i -e 's|INCLUDEPATH += |&$$QTWEBENGINE_ROOT/include |' || die