summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-games/openscenegraph-qt/openscenegraph-qt-3.5.7.ebuild6
-rw-r--r--dev-games/openscenegraph/openscenegraph-3.6.4.ebuild64
-rw-r--r--dev-games/physfs/physfs-3.0.2.ebuild7
-rw-r--r--dev-games/physfs/physfs-9999.ebuild7
-rw-r--r--games-action/abuse/abuse-0.9_p20181213-r1.ebuild8
-rw-r--r--games-action/lugaru/lugaru-20151204-r1.ebuild6
-rw-r--r--games-action/supertuxkart/supertuxkart-1.0.ebuild8
-rw-r--r--games-action/violetland/violetland-0.5.ebuild8
-rw-r--r--games-arcade/commandergenius/commandergenius-2.3.3.ebuild6
-rw-r--r--games-arcade/slimevolley/slimevolley-2.4.2-r1.ebuild5
-rw-r--r--games-arcade/supertux/supertux-0.6.0.ebuild6
-rw-r--r--games-arcade/supertux/supertux-0.6.1.1.ebuild6
-rw-r--r--games-board/cockatrice/cockatrice-20190304-r1.ebuild4
-rw-r--r--games-emulation/hatari/hatari-2.2.1.ebuild8
-rw-r--r--games-emulation/vbam/vbam-2.1.4.ebuild6
-rw-r--r--games-emulation/vbam/vbam-9999.ebuild6
-rw-r--r--games-engines/openmw/openmw-0.45.0.ebuild12
-rw-r--r--games-fps/doomsday/doomsday-2.1.1.ebuild8
-rw-r--r--games-puzzle/pingus/pingus-9999.ebuild4
-rw-r--r--games-roguelike/moria/moria-5.7.10.ebuild4
-rw-r--r--games-strategy/hedgewars/hedgewars-1.0.0-r1.ebuild6
-rw-r--r--games-strategy/wesnoth/wesnoth-1.14.7.ebuild10
-rw-r--r--games-strategy/wesnoth/wesnoth-1.14.9.ebuild9
-rw-r--r--games-strategy/wesnoth/wesnoth-1.15.2.ebuild9
-rw-r--r--games-strategy/widelands/widelands-0.20.ebuild8
-rw-r--r--games-strategy/widelands/widelands-0.20_rc1.ebuild8
-rw-r--r--games-util/lgogdownloader/lgogdownloader-3.5.ebuild6
-rw-r--r--games-util/lgogdownloader/lgogdownloader-9999.ebuild6
-rw-r--r--games-util/qjoypad/qjoypad-4.3.1.ebuild4
-rw-r--r--media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild2
30 files changed, 128 insertions, 129 deletions
diff --git a/dev-games/openscenegraph-qt/openscenegraph-qt-3.5.7.ebuild b/dev-games/openscenegraph-qt/openscenegraph-qt-3.5.7.ebuild
index 1a1be79e4194..fd7f48f62dbc 100644
--- a/dev-games/openscenegraph-qt/openscenegraph-qt-3.5.7.ebuild
+++ b/dev-games/openscenegraph-qt/openscenegraph-qt-3.5.7.ebuild
@@ -5,7 +5,7 @@ EAPI=7
MY_PN="osgQt"
MY_P=${MY_PN}-${PV}
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Qt support for OpenSceneGraph"
HOMEPAGE="http://www.openscenegraph.org/"
@@ -41,8 +41,8 @@ src_configure() {
-DDYNAMIC_OPENSCENEGRAPH=ON
-DDESIRED_QT_VERSION=5
-DBUILD_OSG_EXAMPLES=$(usex examples)
- $(cmake-utils_use_find_package webkit Qt5WebKitWidgets)
+ $(cmake_use_find_package webkit Qt5WebKitWidgets)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/dev-games/openscenegraph/openscenegraph-3.6.4.ebuild b/dev-games/openscenegraph/openscenegraph-3.6.4.ebuild
index 1f0f59ca8e4f..1e0f1b579dc2 100644
--- a/dev-games/openscenegraph/openscenegraph-3.6.4.ebuild
+++ b/dev-games/openscenegraph/openscenegraph-3.6.4.ebuild
@@ -6,7 +6,7 @@ EAPI=7
MY_PN="OpenSceneGraph"
MY_P=${MY_PN}-${PV}
WX_GTK_VER="3.0"
-inherit cmake-utils flag-o-matic wxwidgets
+inherit cmake flag-o-matic wxwidgets
DESCRIPTION="Open source high performance 3D graphics toolkit"
HOMEPAGE="http://www.openscenegraph.org/"
@@ -101,51 +101,51 @@ src_configure() {
-DOSG_ENVVAR_SUPPORTED=ON
-DOSG_PROVIDE_READFILE=ON
-DOSG_USE_LOCAL_LUA_SOURCE=OFF
- $(cmake-utils_use_find_package asio Asio)
- $(cmake-utils_use_find_package curl CURL)
+ $(cmake_use_find_package asio Asio)
+ $(cmake_use_find_package curl CURL)
-DBUILD_DOCUMENTATION=$(usex doc)
- $(cmake-utils_use_find_package dicom DCMTK)
- $(cmake-utils_use_find_package egl EGL)
+ $(cmake_use_find_package dicom DCMTK)
+ $(cmake_use_find_package egl EGL)
-DBUILD_OSG_EXAMPLES=$(usex examples)
- $(cmake-utils_use_find_package ffmpeg FFmpeg)
- $(cmake-utils_use_find_package gdal GDAL)
- $(cmake-utils_use_find_package gif GIFLIB)
- $(cmake-utils_use_find_package gstreamer GLIB)
- $(cmake-utils_use_find_package gstreamer GStreamer)
- $(cmake-utils_use_find_package gtk GtkGl)
- $(cmake-utils_use_find_package jpeg JPEG)
+ $(cmake_use_find_package ffmpeg FFmpeg)
+ $(cmake_use_find_package gdal GDAL)
+ $(cmake_use_find_package gif GIFLIB)
+ $(cmake_use_find_package gstreamer GLIB)
+ $(cmake_use_find_package gstreamer GStreamer)
+ $(cmake_use_find_package gtk GtkGl)
+ $(cmake_use_find_package jpeg JPEG)
-DCMAKE_DISABLE_FIND_PACKAGE_Jasper=ON
- $(cmake-utils_use_find_package las LIBLAS)
- $(cmake-utils_use_find_package lua Lua51)
+ $(cmake_use_find_package las LIBLAS)
+ $(cmake_use_find_package lua Lua51)
-DCMAKE_DISABLE_FIND_PACKAGE_Lua52=ON
-DCMAKE_DISABLE_FIND_PACKAGE_OpenCascade=ON
- $(cmake-utils_use_find_package openexr OpenEXR)
- $(cmake-utils_use_find_package openinventor Inventor)
+ $(cmake_use_find_package openexr OpenEXR)
+ $(cmake_use_find_package openinventor Inventor)
-DBUILD_OSG_APPLICATIONS=$(usex osgapps)
- $(cmake-utils_use_find_package pdf Poppler-glib)
- $(cmake-utils_use_find_package png PNG)
- $(cmake-utils_use_find_package sdl SDL)
- $(cmake-utils_use_find_package sdl2 SDL2)
- $(cmake-utils_use_find_package svg RSVG)
- $(cmake-utils_use_find_package tiff TIFF)
- $(cmake-utils_use_find_package truetype Freetype)
- $(cmake-utils_use_find_package vnc LibVNCServer)
+ $(cmake_use_find_package pdf Poppler-glib)
+ $(cmake_use_find_package png PNG)
+ $(cmake_use_find_package sdl SDL)
+ $(cmake_use_find_package sdl2 SDL2)
+ $(cmake_use_find_package svg RSVG)
+ $(cmake_use_find_package tiff TIFF)
+ $(cmake_use_find_package truetype Freetype)
+ $(cmake_use_find_package vnc LibVNCServer)
-DOSGVIEWER_USE_XRANDR=$(usex xrandr)
- $(cmake-utils_use_find_package zlib ZLIB)
+ $(cmake_use_find_package zlib ZLIB)
)
if use examples; then
mycmakeargs+=(
- $(cmake-utils_use_find_package fltk FLTK)
- $(cmake-utils_use_find_package fox FOX)
- $(cmake-utils_use_find_package glut GLUT)
- $(cmake-utils_use_find_package wxwidgets wxWidgets)
+ $(cmake_use_find_package fltk FLTK)
+ $(cmake_use_find_package fox FOX)
+ $(cmake_use_find_package glut GLUT)
+ $(cmake_use_find_package wxwidgets wxWidgets)
)
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_compile doc_openscenegraph doc_openthreads
+ cmake_src_compile
+ use doc && cmake_src_compile doc_openscenegraph doc_openthreads
}
diff --git a/dev-games/physfs/physfs-3.0.2.ebuild b/dev-games/physfs/physfs-3.0.2.ebuild
index 37c14d9804c5..774fa791efd5 100644
--- a/dev-games/physfs/physfs-3.0.2.ebuild
+++ b/dev-games/physfs/physfs-3.0.2.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
DESCRIPTION="Abstraction layer for filesystem and archive access"
@@ -40,14 +41,14 @@ multilib_src_configure() {
-DPHYSFS_ARCHIVE_QPAK="$(usex qpak)"
-DPHYSFS_ARCHIVE_ZIP="$(usex zip)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if multilib_is_native_abi && use doc; then
- cmake-utils_src_compile docs
+ cmake_src_compile docs
HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
fi
}
diff --git a/dev-games/physfs/physfs-9999.ebuild b/dev-games/physfs/physfs-9999.ebuild
index dbaa669aacc9..9490039a10a7 100644
--- a/dev-games/physfs/physfs-9999.ebuild
+++ b/dev-games/physfs/physfs-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
DESCRIPTION="Abstraction layer for filesystem and archive access"
@@ -40,14 +41,14 @@ multilib_src_configure() {
-DPHYSFS_ARCHIVE_QPAK="$(usex qpak)"
-DPHYSFS_ARCHIVE_ZIP="$(usex zip)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if multilib_is_native_abi && use doc; then
- cmake-utils_src_compile docs
+ cmake_src_compile docs
HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
fi
}
diff --git a/games-action/abuse/abuse-0.9_p20181213-r1.ebuild b/games-action/abuse/abuse-0.9_p20181213-r1.ebuild
index 5117d81dff90..caf6ee16cf2e 100644
--- a/games-action/abuse/abuse-0.9_p20181213-r1.ebuild
+++ b/games-action/abuse/abuse-0.9_p20181213-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop xdg-utils
+inherit cmake desktop xdg-utils
COMMIT="42b6acd19af00689e8f34355e3b13323d8ea3f79"
DATA_PV="0.8"
@@ -26,7 +26,7 @@ S="${WORKDIR}/${PN}-${COMMIT}"
src_prepare() {
ln -snf ../../${PN}-${DATA_PV}/data/{music,sfx} data/ || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -35,11 +35,11 @@ src_configure() {
-DBUILD_SHARED_LIBS=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
doicon -s 32 doc/${PN}.png
make_desktop_entry abuse Abuse
}
diff --git a/games-action/lugaru/lugaru-20151204-r1.ebuild b/games-action/lugaru/lugaru-20151204-r1.ebuild
index c2abf83066a1..c6e92432e47d 100644
--- a/games-action/lugaru/lugaru-20151204-r1.ebuild
+++ b/games-action/lugaru/lugaru-20151204-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop
+inherit cmake desktop
DESCRIPTION="3D arcade with unique fighting system and anthropomorphic characters"
HOMEPAGE="https://bitbucket.org/osslugaru/lugaru/wiki/Home"
@@ -32,7 +32,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -i \
-e "s:@GENTOO_DIR@:/usr/share/${PN}:" \
@@ -44,7 +44,7 @@ src_configure() {
-DCMAKE_VERBOSE_MAKEFILE=TRUE
-DLUGARU_FORCE_INTERNAL_OPENGL=False
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
diff --git a/games-action/supertuxkart/supertuxkart-1.0.ebuild b/games-action/supertuxkart/supertuxkart-1.0.ebuild
index 96746c833f78..1f2999ac01bb 100644
--- a/games-action/supertuxkart/supertuxkart-1.0.ebuild
+++ b/games-action/supertuxkart/supertuxkart-1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop xdg-utils
+inherit cmake desktop xdg-utils
DESCRIPTION="A kart racing game starring Tux, the linux penguin (TuxKart fork)"
HOMEPAGE="https://supertuxkart.net/"
@@ -56,7 +56,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# remove bundled libraries, just to be sure
rm -r lib/{angelscript,enet,glew,jpeglib,libpng,zlib} || die
@@ -78,11 +78,11 @@ src_configure() {
-DSTK_INSTALL_DATA_DIR=share/${PN}
-DBUILD_SHARED_LIBS=OFF # build bundled libsquish as static library
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodoc CHANGELOG.md
doicon -s 64 "${DISTDIR}"/${PN}.png
diff --git a/games-action/violetland/violetland-0.5.ebuild b/games-action/violetland/violetland-0.5.ebuild
index 7078f00ebd3f..318f5c2470ac 100644
--- a/games-action/violetland/violetland-0.5.ebuild
+++ b/games-action/violetland/violetland-0.5.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop xdg-utils
+inherit cmake desktop xdg-utils
DESCRIPTION="Help a girl named Violet in the struggle with hordes of monsters"
HOMEPAGE="https://violetland.github.io/"
@@ -29,7 +29,7 @@ BDEPEND="
"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# Bizarrely fcitx is only bundled for a CMake module to find libintl
# but let's make sure the rest remains unused.
@@ -42,11 +42,11 @@ src_configure() {
-DLOCALE_INSTALL_DIR=share/locale
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodoc CHANGELOG.md CONTRIBUTORS.md
# Remove duplicate READMEs.
diff --git a/games-arcade/commandergenius/commandergenius-2.3.3.ebuild b/games-arcade/commandergenius/commandergenius-2.3.3.ebuild
index e2625339eed6..9aabfe025211 100644
--- a/games-arcade/commandergenius/commandergenius-2.3.3.ebuild
+++ b/games-arcade/commandergenius/commandergenius-2.3.3.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{5,6,7} )
-inherit cmake-utils desktop python-single-r1 xdg-utils
+inherit cmake desktop python-single-r1 xdg-utils
MY_PN="Commander-Genius"
MY_P="${MY_PN}-v${PV}"
@@ -58,11 +58,11 @@ src_configure() {
-DBUILD_SHARED_LIBS=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# The normal executable name is weird.
dosym CGeniusExe /usr/bin/${PN}
diff --git a/games-arcade/slimevolley/slimevolley-2.4.2-r1.ebuild b/games-arcade/slimevolley/slimevolley-2.4.2-r1.ebuild
index 8b9cc92724b5..d855f92fd16f 100644
--- a/games-arcade/slimevolley/slimevolley-2.4.2-r1.ebuild
+++ b/games-arcade/slimevolley/slimevolley-2.4.2-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="A simple volleyball game"
HOMEPAGE="http://slime.tuxfamily.org/index.php"
@@ -38,8 +38,7 @@ S="${WORKDIR}/${PN}"
src_configure() {
local mycmakeargs=(
-DCMAKE_VERBOSE_MAKEFILE=TRUE
- -DCMAKE_INSTALL_PREFIX=/usr
-DDATA_DIR=/usr/share/slimevolley
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/games-arcade/supertux/supertux-0.6.0.ebuild b/games-arcade/supertux/supertux-0.6.0.ebuild
index c12492e71e3c..4ce0d37323f4 100644
--- a/games-arcade/supertux/supertux-0.6.0.ebuild
+++ b/games-arcade/supertux/supertux-0.6.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
: ${CMAKE_MAKEFILE_GENERATOR:=emake}
-inherit cmake-utils flag-o-matic
+inherit cmake flag-o-matic
MY_P="SuperTux-v${PV}-Source"
@@ -37,7 +37,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# This is not a developer release so switch the logo to the non-dev one.
sed -e 's@logo_dev@logo@' \
@@ -56,5 +56,5 @@ src_configure() {
-DENABLE_BOOST_STATIC_LIBS=OFF # bug! Please check if this is still required.
-DUSE_SYSTEM_PHYSFS=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/games-arcade/supertux/supertux-0.6.1.1.ebuild b/games-arcade/supertux/supertux-0.6.1.1.ebuild
index dce1075f2829..0964ce28665f 100644
--- a/games-arcade/supertux/supertux-0.6.1.1.ebuild
+++ b/games-arcade/supertux/supertux-0.6.1.1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
: ${CMAKE_MAKEFILE_GENERATOR:=emake}
-inherit cmake-utils flag-o-matic
+inherit cmake flag-o-matic
MY_P="SuperTux-v${PV}-Source"
@@ -37,7 +37,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# This is not a developer release so switch the logo to the non-dev one.
sed -e 's@logo_dev@logo@' \
@@ -55,5 +55,5 @@ src_configure() {
-DENABLE_SQDBG="$(usex debug)"
-DUSE_SYSTEM_PHYSFS=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/games-board/cockatrice/cockatrice-20190304-r1.ebuild b/games-board/cockatrice/cockatrice-20190304-r1.ebuild
index b4a18e8d2086..2c4ac0f47f1d 100644
--- a/games-board/cockatrice/cockatrice-20190304-r1.ebuild
+++ b/games-board/cockatrice/cockatrice-20190304-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
MY_PV="2019-03-04-Release-2.7.0"
DESCRIPTION="An open-source multiplatform software for playing card games over a network"
@@ -67,5 +67,5 @@ src_configure() {
sed -e 's/^set(PROJECT_VERSION_FRIENDLY.*/set(PROJECT_VERSION_FRIENDLY \"'${SHA1}'\")/' \
-i cmake/getversion.cmake || die "sed failed!"
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/games-emulation/hatari/hatari-2.2.1.ebuild b/games-emulation/hatari/hatari-2.2.1.ebuild
index a8f84107c83e..7c7a695b755a 100644
--- a/games-emulation/hatari/hatari-2.2.1.ebuild
+++ b/games-emulation/hatari/hatari-2.2.1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_{6,7}} )
-inherit cmake-utils python-single-r1 xdg
+inherit cmake python-single-r1 xdg
DESCRIPTION="Atari ST emulator"
HOMEPAGE="https://hatari.tuxfamily.org/"
@@ -48,7 +48,7 @@ DOCS=(
src_prepare() {
xdg_environment_reset
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -i "s/\.1\.gz\b/.1/g;T;s/gzip[^\$]*/cat /g" {*/,}*/CMakeLists.txt || die
sed -i "s:\"doc\" + sep + \"hatari\":\"doc/${PF}\":" python-ui/uihelpers.py || die
@@ -71,10 +71,10 @@ src_configure() {
-DCMAKE_DISABLE_FIND_PACKAGE_Udev=$(usex !udev)
-DCMAKE_DISABLE_FIND_PACKAGE_ZLIB=$(usex !zlib)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
python_fix_shebang "${ED}"/usr/share/${PN}/
}
diff --git a/games-emulation/vbam/vbam-2.1.4.ebuild b/games-emulation/vbam/vbam-2.1.4.ebuild
index a8a2590c1f1e..b19935ad2686 100644
--- a/games-emulation/vbam/vbam-2.1.4.ebuild
+++ b/games-emulation/vbam/vbam-2.1.4.ebuild
@@ -4,7 +4,7 @@
EAPI=7
WX_GTK_VER="3.0-gtk3"
-inherit wxwidgets xdg cmake-utils
+inherit wxwidgets xdg cmake
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/visualboyadvance-m/visualboyadvance-m.git"
@@ -62,11 +62,11 @@ src_configure() {
-DENABLE_ASM_SCALERS=$(usex x86)
-DCMAKE_SKIP_RPATH=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use sdl ; then
dodoc doc/ReadMe.SDL.txt
diff --git a/games-emulation/vbam/vbam-9999.ebuild b/games-emulation/vbam/vbam-9999.ebuild
index f8607c8a0a0e..29f851e02f7b 100644
--- a/games-emulation/vbam/vbam-9999.ebuild
+++ b/games-emulation/vbam/vbam-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
WX_GTK_VER="3.0-gtk3"
-inherit wxwidgets xdg cmake-utils
+inherit wxwidgets xdg cmake
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/visualboyadvance-m/visualboyadvance-m.git"
@@ -58,11 +58,11 @@ src_configure() {
-DENABLE_ASM_SCALERS=$(usex x86)
-DCMAKE_SKIP_RPATH=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use sdl ; then
dodoc doc/ReadMe.SDL.txt
diff --git a/games-engines/openmw/openmw-0.45.0.ebuild b/games-engines/openmw/openmw-0.45.0.ebuild
index 6a6f448a3fc2..fe3b53da5e0d 100644
--- a/games-engines/openmw/openmw-0.45.0.ebuild
+++ b/games-engines/openmw/openmw-0.45.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg-utils readme.gentoo-r1
+inherit cmake xdg-utils readme.gentoo-r1
DESCRIPTION="Open source reimplementation of TES III: Morrowind"
HOMEPAGE="https://openmw.org/"
@@ -50,7 +50,7 @@ BDEPEND="
S="${WORKDIR}/${PN}-${P}"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# We don't install license files
sed -i '/LICDIR/d' CMakeLists.txt || die
@@ -79,14 +79,14 @@ src_configure() {
-DDESIRED_QT_VERSION=5
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if use doc ; then
- cmake-utils_src_compile doc
+ cmake_src_compile doc
find "${CMAKE_BUILD_DIR}"/docs/Doxygen/html \
-name '*.md5' -type f -delete || die
HTML_DOCS=( "${CMAKE_BUILD_DIR}"/docs/Doxygen/html/. )
@@ -94,7 +94,7 @@ src_compile() {
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
local DOC_CONTENTS="
You need the original Morrowind data files. If you haven't
diff --git a/games-fps/doomsday/doomsday-2.1.1.ebuild b/games-fps/doomsday/doomsday-2.1.1.ebuild
index 757a7f8c4729..8eb5fd81fbea 100644
--- a/games-fps/doomsday/doomsday-2.1.1.ebuild
+++ b/games-fps/doomsday/doomsday-2.1.1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python2_7 python3_{6,7} )
-inherit cmake-utils python-any-r1 readme.gentoo-r1
+inherit cmake python-any-r1 readme.gentoo-r1
DESCRIPTION="A modern gaming engine for Doom, Heretic, and Hexen"
HOMEPAGE="https://www.dengine.net"
@@ -45,7 +45,7 @@ S="${WORKDIR}/${P}/${PN}"
DOC_CONTENTS="You need to copy Doom, Doom 2, Chex Quest, Heretic, Hexen, HexenDD, or Doom64 wads to a folder of your choice and then tell the game engine where that folder is. This is different to older versions, which had separate launchers for each game and required the files to be in a specific place."
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# Fix QA warning for "installing to one or more unexpected paths"
sed -e "10s:/texc:/${PF}:" -i tools/texc/CMakeLists.txt || die
@@ -58,11 +58,11 @@ src_configure() {
-DDENG_ENABLE_TOOLS="$(usex tools)"
-DPYTHON_EXECUTABLE="${PYTHON}"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use tools; then
mv -v "${ED}"/usr/bin/md2tool{,.${PN}} || die
diff --git a/games-puzzle/pingus/pingus-9999.ebuild b/games-puzzle/pingus/pingus-9999.ebuild
index 545884819804..ad3f83ccf4fa 100644
--- a/games-puzzle/pingus/pingus-9999.ebuild
+++ b/games-puzzle/pingus/pingus-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils toolchain-funcs flag-o-matic xdg-utils
+inherit cmake toolchain-funcs flag-o-matic xdg-utils
DESCRIPTION="free Lemmings clone"
HOMEPAGE="http://pingus.gitlab.io/"
@@ -37,7 +37,7 @@ PATCHES=(
src_prepare() {
sed '/find_package(Boost/s@ signals@@' -i CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
strip-flags
}
diff --git a/games-roguelike/moria/moria-5.7.10.ebuild b/games-roguelike/moria/moria-5.7.10.ebuild
index 5261c3d90c41..9ce25df81603 100644
--- a/games-roguelike/moria/moria-5.7.10.ebuild
+++ b/games-roguelike/moria/moria-5.7.10.ebuild
@@ -4,7 +4,7 @@
EAPI=7
CMAKE_IN_SOURCE_BUILD="yes"
-inherit cmake-utils prefix
+inherit cmake prefix
DESCRIPTION="The Dungeons of Moria, a single player roguelike game, also known as Umoria"
HOMEPAGE="https://umoria.org/"
@@ -28,7 +28,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -i "s/@PF@/${PF}/" src/config.cpp || die
hprefixify src/config.cpp
}
diff --git a/games-strategy/hedgewars/hedgewars-1.0.0-r1.ebuild b/games-strategy/hedgewars/hedgewars-1.0.0-r1.ebuild
index 9e8d0f6b1289..a30e287caed4 100644
--- a/games-strategy/hedgewars/hedgewars-1.0.0-r1.ebuild
+++ b/games-strategy/hedgewars/hedgewars-1.0.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
CMAKE_MAKEFILE_GENERATOR=emake
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
MY_P=${PN}-src-${PV}
@@ -88,11 +88,11 @@ src_configure() {
# https://bugzilla.redhat.com/show_bug.cgi?id=1200193
-DCMAKE_SKIP_RPATH=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
doman man/${PN}.6
}
diff --git a/games-strategy/wesnoth/wesnoth-1.14.7.ebuild b/games-strategy/wesnoth/wesnoth-1.14.7.ebuild
index 510a59e68be9..06ff63ec4324 100644
--- a/games-strategy/wesnoth/wesnoth-1.14.7.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.14.7.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils user
+
+inherit cmake user
DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
HOMEPAGE="http://www.wesnoth.org
@@ -55,7 +56,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if ! use doc ; then
sed -i \
@@ -106,14 +107,13 @@ src_configure() {
-DENABLE_FRIBIDI="$(usex fribidi)"
-DENABLE_OMP="$(usex openmp)"
-DENABLE_STRICT_COMPILATION="OFF"
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
local DOCS=( README.md changelog.md )
- cmake-utils_src_install
+ cmake_src_install
if use dedicated || use server; then
rmdir "${ED}/run/wesnothd" || die
newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
diff --git a/games-strategy/wesnoth/wesnoth-1.14.9.ebuild b/games-strategy/wesnoth/wesnoth-1.14.9.ebuild
index 807170165f0b..0451aedf6acf 100644
--- a/games-strategy/wesnoth/wesnoth-1.14.9.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.14.9.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils user xdg
+inherit cmake user xdg
DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
HOMEPAGE="http://www.wesnoth.org
@@ -50,7 +50,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if ! use doc ; then
sed -i \
@@ -100,14 +100,13 @@ src_configure() {
-DENABLE_NOTIFICATIONS="$(usex dbus)"
-DENABLE_FRIBIDI="$(usex fribidi)"
-DENABLE_STRICT_COMPILATION="OFF"
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
local DOCS=( README.md changelog.md )
- cmake-utils_src_install
+ cmake_src_install
if use dedicated || use server; then
rmdir "${ED}/run/wesnothd" || die
newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
diff --git a/games-strategy/wesnoth/wesnoth-1.15.2.ebuild b/games-strategy/wesnoth/wesnoth-1.15.2.ebuild
index 807170165f0b..0451aedf6acf 100644
--- a/games-strategy/wesnoth/wesnoth-1.15.2.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.15.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils user xdg
+inherit cmake user xdg
DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
HOMEPAGE="http://www.wesnoth.org
@@ -50,7 +50,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if ! use doc ; then
sed -i \
@@ -100,14 +100,13 @@ src_configure() {
-DENABLE_NOTIFICATIONS="$(usex dbus)"
-DENABLE_FRIBIDI="$(usex fribidi)"
-DENABLE_STRICT_COMPILATION="OFF"
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
local DOCS=( README.md changelog.md )
- cmake-utils_src_install
+ cmake_src_install
if use dedicated || use server; then
rmdir "${ED}/run/wesnothd" || die
newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
diff --git a/games-strategy/widelands/widelands-0.20.ebuild b/games-strategy/widelands/widelands-0.20.ebuild
index b1bdd2677338..2ccf31fe16eb 100644
--- a/games-strategy/widelands/widelands-0.20.ebuild
+++ b/games-strategy/widelands/widelands-0.20.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit desktop cmake-utils
+inherit desktop cmake
MY_PV="build$(ver_cut 2-)"
MY_P="${PN}-${MY_PV/_/-}"
@@ -43,7 +43,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -i -e 's:__ppc__:__PPC__:' src/map_io/s2map.cc || die
}
@@ -57,11 +57,11 @@ src_configure() {
# Game is NOT happy being moved from /usr/share/games
-DWL_INSTALL_DATADIR="${EPREFIX}"/usr/share/games/${PN}
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# move game binary to correct location
dodir /usr/bin
diff --git a/games-strategy/widelands/widelands-0.20_rc1.ebuild b/games-strategy/widelands/widelands-0.20_rc1.ebuild
index 9cfddcf425f9..aaff95f0bbf1 100644
--- a/games-strategy/widelands/widelands-0.20_rc1.ebuild
+++ b/games-strategy/widelands/widelands-0.20_rc1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit desktop cmake-utils
+inherit desktop cmake
MY_PV="build$(ver_cut 2-)"
MY_P="${PN}-${MY_PV/_/-}"
@@ -43,7 +43,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -i -e 's:__ppc__:__PPC__:' src/map_io/s2map.cc || die
}
@@ -57,11 +57,11 @@ src_configure() {
# Game is NOT happy being moved from /usr/share/games
-DWL_INSTALL_DATADIR="${EPREFIX}"/usr/share/games/${PN}
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# move game binary to correct location
dodir /usr/bin
diff --git a/games-util/lgogdownloader/lgogdownloader-3.5.ebuild b/games-util/lgogdownloader/lgogdownloader-3.5.ebuild
index 9a73f51a45c8..bd02b105269b 100644
--- a/games-util/lgogdownloader/lgogdownloader-3.5.ebuild
+++ b/games-util/lgogdownloader/lgogdownloader-3.5.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Unofficial GOG.com downloader for Linux"
HOMEPAGE="https://sites.google.com/site/gogdownloader/"
@@ -35,10 +35,10 @@ src_configure() {
local mycmakeargs=(
-DUSE_QT_GUI=$(usex gui)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
gunzip "${ED}"/usr/share/man/man1/${PN}.1.gz || die
}
diff --git a/games-util/lgogdownloader/lgogdownloader-9999.ebuild b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
index d0d1304d0133..37dfd7c2f858 100644
--- a/games-util/lgogdownloader/lgogdownloader-9999.ebuild
+++ b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils git-r3
+inherit cmake git-r3
DESCRIPTION="Unofficial GOG.com downloader for Linux"
HOMEPAGE="https://sites.google.com/site/gogdownloader/"
@@ -30,10 +30,10 @@ src_configure() {
local mycmakeargs=(
-DUSE_QT_GUI=$(usex gui)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
gunzip "${ED}"/usr/share/man/man1/${PN}.1.gz || die
}
diff --git a/games-util/qjoypad/qjoypad-4.3.1.ebuild b/games-util/qjoypad/qjoypad-4.3.1.ebuild
index bbe3cb1a2576..ba8e0cec815f 100644
--- a/games-util/qjoypad/qjoypad-4.3.1.ebuild
+++ b/games-util/qjoypad/qjoypad-4.3.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop
+inherit cmake desktop
DESCRIPTION="Translate gamepad/joystick input into key strokes/mouse actions in X"
HOMEPAGE="https://github.com/panzi/qjoypad"
@@ -33,7 +33,7 @@ DEPEND="${RDEPEND}
PATCHES=( "${FILESDIR}/${PN}-4.3.0-cmake.patch" )
src_install() {
- cmake-utils_src_install
+ cmake_src_install
local i
cd icons || die
diff --git a/media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild b/media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild
index f948ce3df0ba..a519c81c0444 100644
--- a/media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild
+++ b/media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild
@@ -38,5 +38,5 @@ multilib_src_configure() {
-DBUILD_RECORDER_WITH_SOUND=$(usex sound)
-DBUILD_WITH_VPX=$(usex vpx)
)
- cmake-utils_src_configure
+ cmake_src_configure
}