summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-board/simsu/Manifest1
-rw-r--r--games-board/simsu/simsu-1.3.9.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/games-board/simsu/Manifest b/games-board/simsu/Manifest
index b5bf182fdda6..15e0e512f468 100644
--- a/games-board/simsu/Manifest
+++ b/games-board/simsu/Manifest
@@ -1 +1,2 @@
DIST simsu-1.3.6-src.tar.bz2 597982 BLAKE2B acf13fe4e3e228cecc76a16352a4df06f14cf58307008f5679b63f1209b4cf191b28544ed3b002375afdf0de8cd92ce179f3cb367f9a5201099da99a806d60c5 SHA512 04e60ccab8345002078b7dbd253bc2a9701f9b8edbbdd9a01ac3ddffd9a5f3ccd32399216b9e497b309b6718646db11a55717e5bd201bfd2aaa80ad9b171cb94
+DIST simsu-1.3.9-src.tar.bz2 594107 BLAKE2B ac347f46bc80dd5045124e7a69668191f4996ac17e64b6da897f0bcdb66f10683944e8bc90a7c98a2000a9275b1925710938ef9ebc384a5b633de5e6c999b79c SHA512 04f46850628c113bca9c44085e073966ecf10aa727112a630894821e378ce35c14502264560c27a85df02c0ea5761e3835501f4869625cd98f50bb0a5e7afeae
diff --git a/games-board/simsu/simsu-1.3.9.ebuild b/games-board/simsu/simsu-1.3.9.ebuild
new file mode 100644
index 000000000000..788697df6d49
--- /dev/null
+++ b/games-board/simsu/simsu-1.3.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop qmake-utils xdg-utils
+
+DESCRIPTION="Basic sudoku game"
+HOMEPAGE="https://gottcode.org/simsu/"
+SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}/translations
+ doins translations/*qm
+ dodoc ChangeLog
+ doicon -s scalable icons/hicolor/scalable/apps/${PN}.svg
+ domenu icons/${PN}.desktop
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}