summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/peewee/peewee-2.8.0.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/dev-python/peewee/peewee-2.8.0.ebuild b/dev-python/peewee/peewee-2.8.0.ebuild
index 3d9a37b6d686..aacf223e06a0 100644
--- a/dev-python/peewee/peewee-2.8.0.ebuild
+++ b/dev-python/peewee/peewee-2.8.0.ebuild
@@ -22,6 +22,16 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
DISTUTILS_IN_SOURCE_BUILD=1
+python_prepare_all() {
+ sed -i -e "s#test_suite='tests',##g;" ./setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
python_compile_all() {
use doc && emake -C docs html
}