summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-fs/sshfs/Manifest1
-rw-r--r--net-fs/sshfs/sshfs-3.7.3.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/net-fs/sshfs/Manifest b/net-fs/sshfs/Manifest
index b92f5ff678f7..b7af6f70fd53 100644
--- a/net-fs/sshfs/Manifest
+++ b/net-fs/sshfs/Manifest
@@ -1,2 +1,3 @@
DIST sshfs-3.7.0.tar.xz 52724 BLAKE2B be974475692e8f9a4d0653776b7b7dc62c6beb1a300caf62c55cbc6bb72fedcf08cdd2c65f051415df57e6e2b21e5a3cb00e8525585c40ab92b0bd0b3474ac77 SHA512 bd8bcd45dd9a5e9686c6fb442e877ffdb592ba0d3424d5dab84a955bfafb17e8666abefba6857467833f5b285842bdadd5a9b6c9e8128ac2e564c36df79aa570
DIST sshfs-3.7.1.tar.xz 52988 BLAKE2B 48fd9b1483a8f4d48e3d9d25dc13c6e265ca3cb623762b2721b955db52fc05a6138cd0fef684e8893c3b380041ac30ecb3df4c5716b067f621790730fa07be08 SHA512 ee91b2eacbad5891006dbac14188ddd591e242b6092c7b7d8234503d79acb52f4b7ea9a15d5eaad83597ff4b4e700580ee2271671edfa6db762d9a8c756d45fd
+DIST sshfs-3.7.3.tar.xz 53596 BLAKE2B 9a229d0f11e7247e319af13245aeaf71082664409b0ca3fe1522bcdb679d402c574438be1931d5d73a16b9eda43daf20de6c1a016442ae53afa27a697e58c212 SHA512 ba0928f85819984a3eb83d2debab658b2cd4e958ed1c3ba9787e361f452687d42b82d478b7d95e7a7c5580bae5c1cdebe4cf3c9b6cb5eb6a570311f276903d99
diff --git a/net-fs/sshfs/sshfs-3.7.3.ebuild b/net-fs/sshfs/sshfs-3.7.3.ebuild
new file mode 100644
index 000000000000..12ab59c78cdb
--- /dev/null
+++ b/net-fs/sshfs/sshfs-3.7.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Fuse-filesystem utilizing the sftp service"
+HOMEPAGE="https://github.com/libfuse/sshfs"
+SRC_URI="https://github.com/libfuse/${PN}/releases/download/${P}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+DEPEND=">=sys-fs/fuse-3.1.0:3
+ >=dev-libs/glib-2.4.2"
+RDEPEND="${DEPEND}
+ >=net-misc/openssh-4.4"
+BDEPEND="dev-python/docutils
+ virtual/pkgconfig"
+
+# requires root privs and specific localhost sshd setup
+RESTRICT="test"
+
+DOCS=( AUTHORS ChangeLog.rst README.rst )