summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-board/peg-e/peg-e-1.1.2-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-board/peg-e/peg-e-1.1.2-r1.ebuild b/games-board/peg-e/peg-e-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..8ca51f51aa1d
--- /dev/null
+++ b/games-board/peg-e/peg-e-1.1.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils gnome2-utils qmake-utils
+
+DESCRIPTION="A peg solitaire game"
+HOMEPAGE="http://gottcode.org/peg-e/"
+SRC_URI="http://gottcode.org/peg-e/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ dobin ${PN}
+ doicon -s 48 icons/hicolor/48x48/apps/${PN}.png
+ domenu icons/${PN}.desktop
+ dodoc CREDITS ChangeLog
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}