summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-emulation/dosbox/dosbox-0.74-r2.ebuild46
-rw-r--r--games-emulation/dosbox/dosbox-9999.ebuild12
2 files changed, 6 insertions, 52 deletions
diff --git a/games-emulation/dosbox/dosbox-0.74-r2.ebuild b/games-emulation/dosbox/dosbox-0.74-r2.ebuild
deleted file mode 100644
index 165707b81f2f..000000000000
--- a/games-emulation/dosbox/dosbox-0.74-r2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-inherit eutils
-
-DESCRIPTION="DOS emulator"
-HOMEPAGE="http://dosbox.sourceforge.net/"
-SRC_URI="mirror://sourceforge/dosbox/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
-IUSE="alsa debug hardened opengl"
-
-DEPEND="alsa? ( media-libs/alsa-lib )
- debug? ( sys-libs/ncurses:0 )
- opengl? ( virtual/glu virtual/opengl )
- media-libs/libpng:0
- media-libs/libsdl[joystick,video,X]
- media-libs/sdl-net
- media-libs/sdl-sound"
-RDEPEND=${DEPEND}
-
-PATCHES=(
- "${FILESDIR}"/${P}-clang.patch
- "${FILESDIR}"/${P}-gcc46.patch
- "${FILESDIR}"/${P}-wine-drive-z.patch
- "${FILESDIR}"/${P}-wine-filenames.patch
-)
-
-src_configure() {
- econf \
- $(use_enable alsa alsa-midi) \
- $(use_enable !hardened dynamic-core) \
- $(use_enable !hardened dynamic-x86) \
- $(use_enable debug) \
- $(use_enable opengl)
-}
-
-src_install() {
- default
- make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
- doicon src/dosbox.ico
-}
diff --git a/games-emulation/dosbox/dosbox-9999.ebuild b/games-emulation/dosbox/dosbox-9999.ebuild
index 1c5c700e10af..f0caa33b0f3c 100644
--- a/games-emulation/dosbox/dosbox-9999.ebuild
+++ b/games-emulation/dosbox/dosbox-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=6
+EAPI=5
ESVN_REPO_URI="https://dosbox.svn.sourceforge.net/svnroot/dosbox/dosbox/trunk"
-inherit autotools eutils subversion
+inherit autotools eutils subversion games
DESCRIPTION="DOS emulator"
HOMEPAGE="http://dosbox.sourceforge.net/"
@@ -15,8 +15,8 @@ KEYWORDS=""
IUSE="alsa debug hardened opengl"
DEPEND="alsa? ( media-libs/alsa-lib )
- debug? ( sys-libs/ncurses:0 )
opengl? ( virtual/glu virtual/opengl )
+ debug? ( sys-libs/ncurses:0 )
media-libs/libpng:0
media-libs/libsdl[joystick,video,X]
media-libs/sdl-net
@@ -30,13 +30,12 @@ src_unpack() {
}
src_prepare() {
- default
subversion_src_prepare
eautoreconf
}
src_configure() {
- econf \
+ egamesconf \
$(use_enable alsa alsa-midi) \
$(use_enable !hardened dynamic-core) \
$(use_enable !hardened dynamic-x86) \
@@ -48,4 +47,5 @@ src_install() {
default
make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
doicon src/dosbox.ico
+ prepgamesdirs
}