summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-auth/pam_p11/pam_p11-0.2.0.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-auth/pam_p11/pam_p11-0.2.0.ebuild b/sys-auth/pam_p11/pam_p11-0.2.0.ebuild
index 012b53a32b65..cc81b3a08cbf 100644
--- a/sys-auth/pam_p11/pam_p11-0.2.0.ebuild
+++ b/sys-auth/pam_p11/pam_p11-0.2.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit ltprune pam
+inherit pam
DESCRIPTION="PAM module for authenticating against PKCS#11 tokens"
HOMEPAGE="https://github.com/opensc/pam_p11/wiki"
@@ -17,8 +17,8 @@ IUSE=""
RDEPEND="virtual/pam
dev-libs/libp11
dev-libs/openssl:0="
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}/${P}-build.patch"
@@ -30,5 +30,5 @@ src_configure() {
src_install() {
default
- prune_libtool_files --all
+ find "${D}" -name '*.la' -delete || die
}