summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/qtox/Manifest3
-rw-r--r--net-im/qtox/qtox-1.3.0.ebuild80
-rw-r--r--net-im/qtox/qtox-1.6.0.ebuild (renamed from net-im/qtox/qtox-1.4.0.ebuild)10
3 files changed, 6 insertions, 87 deletions
diff --git a/net-im/qtox/Manifest b/net-im/qtox/Manifest
index 12eae9fdbdee..a58464e3aa16 100644
--- a/net-im/qtox/Manifest
+++ b/net-im/qtox/Manifest
@@ -1,3 +1,2 @@
-DIST qtox-1.3.0.tar.gz 4679256 SHA256 a2d1483a9aa6e99684853733a0a0a04c8cde168a775b9d2bdab94771fd82bc0a SHA512 9147e9f6c80098a6d1c3d9deaf92d5ae2a62894f0628b058e59a66616873aebbca8a1ba04c0436a1b2793ae766a2ba9056a832be1550b47e1799de24216f19e8 WHIRLPOOL 646eb1bb940408d1d9c7bfddf43ce66898b238158d0f0bb49896ec4899e3d540bae30ee968969bea544b529d6b8279d0017262c4a9a6e5c50d43b35da745eb2d
-DIST qtox-1.4.0.tar.gz 3021956 SHA256 f869aafddb597286dc03b828b48e2560a97983f180914c396fdcf2f1ca07ae79 SHA512 4c93e90ec20e8c9289f5be628f6543d356c99f59d72e735814ba2640b257fbb78f18a9dbd42070a5cfb7fded492906f07cc678d1ae737ac795da689b3e6abe2d WHIRLPOOL 68991d933427be17b6757010d03fda8647c3e3c448fe44a4dad812b9636802f9dc8667b76824d6b867f514e61da202a52d9ea2c4117cc3cda833b82301589f11
DIST qtox-1.5.0.tar.gz 3452369 SHA256 216c07cf6c37f655aa91de6f507f3f0a86831ad502d7733c0e67c336ed197a86 SHA512 253effc91663cac373cf9fd1595f4cb26f38c5cf997050217def4d1c659a710afa10a29cb5aecb5d23dbdeb3ea7cf8b651f4a120d79e8681c96fb7b8b4500812 WHIRLPOOL d73650790e7be2be5636dd3b1507ed1e704307ad8e916f6dc12aa2739525717ccc221c76104bc231f77e4c2c87b6370fdaf8a5aad160a0e06e86767f760eeb66
+DIST qtox-1.6.0.tar.gz 3481328 SHA256 7450e751da5cc6dce00b58df6d06a309e2674c7bd9311de6af21e53c36c3f155 SHA512 6ccf2c17c25ea30899356518b8f8849ed53404a8ac81180e2719c979dab1f411a93aa08ad759b3e8defea994d3baaf538ed354b733a321de3615521dcf6c8192 WHIRLPOOL 999aacf9724697526f925721e7202168076bcaac9fb5a733ef6374518f3ab86c9a3ded9d0911e2a2d677c0af0c474054d7f6c2cc06fd430c98366d9fa48f19ab
diff --git a/net-im/qtox/qtox-1.3.0.ebuild b/net-im/qtox/qtox-1.3.0.ebuild
deleted file mode 100644
index 8c6a71430d2e..000000000000
--- a/net-im/qtox/qtox-1.3.0.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit eutils qmake-utils
-
-DESCRIPTION="Most feature-rich GUI for net-libs/tox using Qt5"
-HOMEPAGE="https://github.com/tux3/qtox"
-SRC_URI="https://github.com/tux3/qTox/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gtk X"
-
-# needed, since tarball provided by github extracts to `qTox`
-S="${WORKDIR}/qTox-${PV}"
-
-RDEPEND="
- dev-db/sqlcipher
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5[gif,jpeg,png,xcb]
- dev-qt/qtnetwork:5
- dev-qt/qtopengl:5
- dev-qt/qtsql:5
- dev-qt/qtsvg:5
- dev-qt/qtxml:5
- media-gfx/qrencode
- media-libs/openal
- >=media-video/ffmpeg-2.6.3[webp,v4l]
- gtk? ( dev-libs/atk
- dev-libs/glib:2
- x11-libs/gdk-pixbuf[X]
- x11-libs/gtk+:2
- x11-libs/cairo[X]
- x11-libs/pango[X] )
- net-libs/tox[av]
- X? ( x11-libs/libX11
- x11-libs/libXScrnSaver )
-"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
-"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if tc-is-gcc ; then
- if [[ $(gcc-major-version) == 4 && $(gcc-minor-version) -lt 8 || $(gcc-major-version) -lt 4 ]] ; then
- eerror "You need at least sys-devel/gcc-4.8.3"
- die "You need at least sys-devel/gcc-4.8.3"
- fi
- fi
- fi
-}
-
-src_configure() {
- use gtk || local NO_GTK_SUPPORT="ENABLE_SYSTRAY_STATUSNOTIFIER_BACKEND=NO ENABLE_SYSTRAY_GTK_BACKEND=NO"
- use X || local NO_X_SUPPORT="DISABLE_PLATFORM_EXT=YES"
- # filter_audio is disabled since it's not available in Gentoo, and
- # support for it in qTox at the present is ~broken anyway
- eqmake5 \
- GIT_DESCRIBE="${PV}" \
- DISABLE_FILTER_AUDIO=YES \
- ${NO_GTK_SUPPORT} \
- ${NO_X_SUPPORT}
-}
-
-src_install() {
- dobin "${S}/qtox"
- # install all png icons
- local ICONS=(16 22 24 32 36 48 64 72 96 128 192 256 512)
- for i in "${ICONS[@]}"; do
- newicon -s "${i}" "${S}/img/icons/qtox-${i}x${i}.png" "qtox.png"
- done
- doicon -s scalable "${S}/img/icons/qtox.svg"
- domenu "${S}/qTox.desktop"
-}
diff --git a/net-im/qtox/qtox-1.4.0.ebuild b/net-im/qtox/qtox-1.6.0.ebuild
index eabc0c9e6402..fb6373082fc7 100644
--- a/net-im/qtox/qtox-1.4.0.ebuild
+++ b/net-im/qtox/qtox-1.6.0.ebuild
@@ -7,8 +7,8 @@ EAPI=6
inherit eutils qmake-utils
DESCRIPTION="Most feature-rich GUI for net-libs/tox using Qt5"
-HOMEPAGE="https://github.com/tux3/qtox"
-SRC_URI="https://github.com/tux3/qTox/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/qTox/qTox"
+SRC_URI="https://github.com/qTox/qTox/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
@@ -20,6 +20,7 @@ S="${WORKDIR}/qTox-${PV}"
RDEPEND="
dev-db/sqlcipher
+ dev-libs/libsodium
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtgui:5[gif,jpeg,png,xcb]
@@ -27,6 +28,7 @@ RDEPEND="
dev-qt/qtopengl:5
dev-qt/qtsql:5
dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
dev-qt/qtxml:5
media-gfx/qrencode
media-libs/openal
@@ -60,12 +62,10 @@ pkg_pretend() {
src_configure() {
use gtk || local NO_GTK_SUPPORT="ENABLE_SYSTRAY_STATUSNOTIFIER_BACKEND=NO ENABLE_SYSTRAY_GTK_BACKEND=NO"
use X || local NO_X_SUPPORT="DISABLE_PLATFORM_EXT=YES"
- # filter_audio is disabled since it's not available in Gentoo, and
- # support for it in qTox at the present is ~broken anyway
+
eqmake5 \
PREFIX="${D}/usr" \
GIT_DESCRIBE="${PV}" \
- DISABLE_FILTER_AUDIO=YES \
${NO_GTK_SUPPORT} \
${NO_X_SUPPORT}
}