summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/agedu/agedu-20170831.ebuild13
-rw-r--r--sys-apps/agedu/agedu-20171202.ebuild13
-rw-r--r--sys-apps/agedu/agedu-20180302.ebuild11
-rw-r--r--sys-apps/agedu/agedu-20180329.ebuild9
-rw-r--r--sys-apps/agedu/files/agedu-r9671-fix-automagic.patch5
5 files changed, 31 insertions, 20 deletions
diff --git a/sys-apps/agedu/agedu-20170831.ebuild b/sys-apps/agedu/agedu-20170831.ebuild
index 8b2ec089f3f4..0924f9239532 100644
--- a/sys-apps/agedu/agedu-20170831.ebuild
+++ b/sys-apps/agedu/agedu-20170831.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
-inherit autotools eutils
+inherit autotools
# agedu-20151213.59b0ed3.ebuild is not a legitimate name
# so we'll drop versionator and just set MY_P manually.
@@ -21,9 +21,12 @@ IUSE="doc ipv6"
DEPEND="doc? ( app-doc/halibut )"
+PATCHES=(
+ "${FILESDIR}/${PN}-r9671-fix-automagic.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}/${PN}-r9671-fix-automagic.patch"
- eapply_user
+ default
eautoreconf
}
diff --git a/sys-apps/agedu/agedu-20171202.ebuild b/sys-apps/agedu/agedu-20171202.ebuild
index b157209b4972..0cfc94bc80fd 100644
--- a/sys-apps/agedu/agedu-20171202.ebuild
+++ b/sys-apps/agedu/agedu-20171202.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
-inherit autotools eutils
+inherit autotools
# agedu-20151213.59b0ed3.ebuild is not a legitimate name
# so we'll drop versionator and just set MY_P manually.
@@ -21,9 +21,12 @@ IUSE="doc ipv6"
DEPEND="doc? ( app-doc/halibut )"
+PATCHES=(
+ "${FILESDIR}/${PN}-r9671-fix-automagic.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}/${PN}-r9671-fix-automagic.patch"
- eapply_user
+ default
eautoreconf
}
diff --git a/sys-apps/agedu/agedu-20180302.ebuild b/sys-apps/agedu/agedu-20180302.ebuild
index 8aeb20dc9846..ced64253757b 100644
--- a/sys-apps/agedu/agedu-20180302.ebuild
+++ b/sys-apps/agedu/agedu-20180302.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
-inherit autotools eutils
+inherit autotools
# agedu-20151213.59b0ed3.ebuild is not a legitimate name
# so we'll drop versionator and just set MY_P manually.
@@ -21,9 +21,12 @@ IUSE="doc ipv6"
DEPEND="doc? ( app-doc/halibut )"
+PATCHES=(
+ "${FILESDIR}/${PN}-r9671-fix-automagic.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}/${PN}-r9671-fix-automagic.patch"
- eapply_user
+ default
eautoreconf
}
diff --git a/sys-apps/agedu/agedu-20180329.ebuild b/sys-apps/agedu/agedu-20180329.ebuild
index 72f7d0242506..24322243c5c3 100644
--- a/sys-apps/agedu/agedu-20180329.ebuild
+++ b/sys-apps/agedu/agedu-20180329.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
inherit autotools eutils
@@ -21,9 +21,12 @@ IUSE="doc ipv6"
DEPEND="doc? ( app-doc/halibut )"
+PATCHES=(
+ "${FILESDIR}/${PN}-r9671-fix-automagic.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}/${PN}-r9671-fix-automagic.patch"
- eapply_user
+ default
eautoreconf
}
diff --git a/sys-apps/agedu/files/agedu-r9671-fix-automagic.patch b/sys-apps/agedu/files/agedu-r9671-fix-automagic.patch
index 8e0c6ea2969e..0ea79d1a170a 100644
--- a/sys-apps/agedu/files/agedu-r9671-fix-automagic.patch
+++ b/sys-apps/agedu/files/agedu-r9671-fix-automagic.patch
@@ -1,6 +1,5 @@
-diff -Naur agedu-r9671.orig/configure.ac agedu-r9671/configure.ac
---- agedu-r9671.orig/configure.ac 2012-10-20 21:20:47.000000000 -0400
-+++ agedu-r9671/configure.ac 2012-10-21 15:13:08.000000000 -0400
+--- a/configure.ac
++++ b/configure.ac
@@ -10,8 +10,6 @@
AC_PROG_CC
AC_PROG_CC_C99