summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/coverage/Manifest2
-rw-r--r--dev-python/coverage/coverage-4.5.2.ebuild44
-rw-r--r--dev-python/coverage/coverage-5.1.ebuild69
3 files changed, 0 insertions, 115 deletions
diff --git a/dev-python/coverage/Manifest b/dev-python/coverage/Manifest
index dbb4b8a2e1c9..1a48a2b1e476 100644
--- a/dev-python/coverage/Manifest
+++ b/dev-python/coverage/Manifest
@@ -1,5 +1,3 @@
-DIST coverage-4.5.2.tar.gz 384845 BLAKE2B a7b4f249a68e025449d26ef8ee2194b9ce355c979d1f5192a7863a0ab0089f9deb3a8e63a39bef528ed7c58fbcc7cd4bc193fea3a135f5996a6655268a6b7a93 SHA512 0d98c8118648a319ac6f3b4c4c6f1ff8a92085bbe8276dd5504c8df4638933f920d7382d8e6de8e16bff43b62091310e0eab7b7722c6d28c976baedbfae3d03e
DIST coverage-4.5.4.tar.gz 385185 BLAKE2B 9d040bff13cebd1cb7147f15c3ec03bb08648cf801b5b2bb046a6b5bcadb3d3886be8bf0a624d225f25d10a5ca82fe5fb88f55e44e92a0a3285836b837972970 SHA512 ba534e04fe35cbadc4b16735f25c08f579a49a6677ec106680f222f2dfb3d0f1e011d0962f1c2108c375173ac4588bea1619ecda05ff9ba6fd888daddfd27b0e
-DIST coverage-5.1.tar.gz 687427 BLAKE2B f4eee548cd6fb58c4a527b9e0ac5ee4133c984358f42ca0c87301f95eb60253a2748ccf9d4e88358941d7897998e68e3c5e70e6dc7387bf5e60eda950f4a679c SHA512 7bd3ca158fe2eab1946c52161fb877623d4ed0382de193aa6eb267443fdda86089ec7aaae518115d6a3b5487fd1400320eb503b9afe83182fb3c3621ccbfb6d7
DIST coverage-5.2.1.tar.gz 694076 BLAKE2B 0aaf9b5668c2fac1220c377d5b841341b534bd14579b70fa3d4c5e64239df71b95c2278e041f46ae3f9d2ae55145894d51457caabdd9540b7d8ce3f32f8d409c SHA512 bda6129a4f4e2db3d26878036ceec137e4f359b8d37ce087e4007751bf0bbda7d706967a50b120378fa533f980e70142328099332374a1f303fa0083ffc078b0
DIST coverage-5.3.tar.gz 693632 BLAKE2B 9daa3a0fd7f8c3ff7c9d68603e11a0a419d3ab50e3c3fb6be5b694aa1f7566040e1212b7175dfa4f71a0a309db325c00f94a85e0e9e755ae8c4f09c499d0daf4 SHA512 f40a21c394b1a72118965f702ae2b8e09c4e0b2fe92709aedf1de4c8074cd9c2cae0ed4860fbb863e4e5479f1067ff806d7051f7683d6b324de9945c0cacfc39
diff --git a/dev-python/coverage/coverage-4.5.2.ebuild b/dev-python/coverage/coverage-4.5.2.ebuild
deleted file mode 100644
index dbdc4f892f0b..000000000000
--- a/dev-python/coverage/coverage-4.5.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Code coverage measurement for Python"
-HOMEPAGE="https://coverage.readthedocs.io/en/latest/ https://pypi.org/project/coverage/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="
- >=dev-python/setuptools-18.4[${PYTHON_USEDEP}]
- test? (
- dev-python/PyContracts[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-
-python_compile() {
- if [[ ${EPYTHON} == python2.7 ]]; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- export CFLAGS
- fi
-
- distutils-r1_python_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- [[ "${PYTHON}" =~ pypy ]] && export COVERAGE_NO_EXTENSION=no
- ${PYTHON} "${S}"/igor.py test_with_tracer py || die
- ${PYTHON} "${S}"/igor.py test_with_tracer c || die
-}
diff --git a/dev-python/coverage/coverage-5.1.ebuild b/dev-python/coverage/coverage-5.1.ebuild
deleted file mode 100644
index 279b142fc1a9..000000000000
--- a/dev-python/coverage/coverage-5.1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
-PYTHON_REQ_USE="threads(+),sqlite(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Code coverage measurement for Python"
-HOMEPAGE="https://coverage.readthedocs.io/en/latest/ https://pypi.org/project/coverage/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
-#IUSE="test"
-# The tests are impossible to appease. Please run them externally
-# via tox. Or fix the ebuild if you have hours of time to spend
-# on something utterly useless.
-RESTRICT="test"
-
-#BDEPEND="
-# test? (
-# dev-python/PyContracts[${PYTHON_USEDEP}]
-# dev-python/flaky[${PYTHON_USEDEP}]
-# dev-python/hypothesis[${PYTHON_USEDEP}]
-# dev-python/mock[${PYTHON_USEDEP}]
-# dev-python/pytest[${PYTHON_USEDEP}]
-# >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
-# )
-#"
-
-src_prepare() {
- # avoid the dep on xdist, run tests verbosely
- sed -i -e '/^addopts/s:-n3:-v:' setup.cfg || die
- distutils-r1_src_prepare
-}
-
-python_compile() {
- if [[ ${EPYTHON} == python2.7 ]]; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- export CFLAGS
- fi
-
- distutils-r1_python_compile
-}
-
-python_test() {
- distutils_install_for_testing
- local bindir=${TEST_DIR}/scripts
-
- pushd tests/eggsrc >/dev/null || die
- distutils_install_for_testing
- popd >/dev/null || die
-
- "${EPYTHON}" igor.py zip_mods || die
- PATH="${bindir}:${PATH}" "${EPYTHON}" igor.py test_with_tracer py || die
-
- # No C extensions under pypy
- if [[ ${EPYTHON} != pypy* ]]; then
- cp -l -- "${TEST_DIR}"/lib/*/coverage/*.so coverage/ || die
- PATH="${bindir}:${PATH}" "${EPYTHON}" igor.py test_with_tracer c || die
- fi
-
- # clean up leftover "egg1" directory
- rm -rf build/lib/egg1 || die
-}